summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c38f4f192097..a559ac49724f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cherrytree-git
pkgdesc = Hierarchical note-taking application, git version
- pkgver = 0.99.27.r0.g86ad4015
+ pkgver = 0.99.27.r6.g6e9d4a38
pkgrel = 1
url = https://github.com/giuspen/cherrytree
arch = x86_64
@@ -15,6 +15,10 @@ pkgbase = cherrytree-git
provides = cherrytree
conflicts = cherrytree
source = git+https://github.com/giuspen/cherrytree.git
+ source = git+https://github.com/gabime/spdlog.git
+ source = git+https://github.com/google/googletest.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = cherrytree-git
diff --git a/PKGBUILD b/PKGBUILD
index 9884146b83b3..621594dff6b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=cherrytree-git
_pkgname="${pkgname%%-git}"
-pkgver=0.99.27.r0.g86ad4015
+pkgver=0.99.27.r6.g6e9d4a38
pkgrel=1
pkgdesc="Hierarchical note-taking application, git version"
arch=('x86_64')
-url="https://github.com/giuspen/cherrytree"
+url="https://github.com/giuspen/${_pkgname}"
license=('GPL3')
depends=('gspell'
'gtksourceviewmm'
@@ -17,8 +17,12 @@ makedepends=('cmake'
'python')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("git+https://github.com/giuspen/${_pkgname}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/giuspen/${_pkgname}.git"
+ "git+https://github.com/gabime/spdlog.git"
+ "git+https://github.com/google/googletest.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "${_pkgname}"
@@ -26,8 +30,11 @@ pkgver() {
}
prepare() {
- # Fix automatic optimisation flag override
- sed -i 's/-O3/-O2/' "${_pkgname}/CMakeLists.txt"
+ cd "${_pkgname}"
+ git submodule init
+ git config submodule.spdlog.url "${srcdir}/spdlog"
+ git config submodule.googletest.url "${srcdir}/googletest"
+ git submodule update
}
build() {