summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
-rw-r--r--ct.patch28
-rw-r--r--ct_game_tags.patch15
3 files changed, 29 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c61fcda2efc5..75a980d9dd07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ build() {
git clone $_gitroot
cd $_gitname
fi
- patch lib/ct_game_tags.c < ../../ct_game_tags.patch
+ patch -p1 < ../../ct.patch
./configure --prefix=/usr || return 1
make clean || return 1
make -j3 || return 1
diff --git a/ct.patch b/ct.patch
new file mode 100644
index 000000000000..69443ccc78ec
--- /dev/null
+++ b/ct.patch
@@ -0,0 +1,28 @@
+diff -Naur chess_toolkit/lib/chess_toolkit/ct_game_tags.h chess_toolkit_/lib/chess_toolkit/ct_game_tags.h
+--- chess_toolkit/lib/chess_toolkit/ct_game_tags.h 2016-07-26 23:59:40.323195228 +0300
++++ chess_toolkit_/lib/chess_toolkit/ct_game_tags.h 2016-07-27 00:05:19.856527707 +0300
+@@ -22,7 +22,7 @@
+
+ enum
+ {
+- GAME_TAGS_KEY_MAX_LENGTH = 9,
++ GAME_TAGS_KEY_MAX_LENGTH = 12,
+ GAME_TAGS_VALUE_MAX_LENGTH = 256 /* includes null termination */
+ };
+
+diff -Naur chess_toolkit/lib/ct_game_tags.c chess_toolkit_/lib/ct_game_tags.c
+--- chess_toolkit/lib/ct_game_tags.c 2016-07-26 23:59:40.326528563 +0300
++++ chess_toolkit_/lib/ct_game_tags.c 2016-07-27 00:04:41.766527803 +0300
+@@ -26,10 +26,10 @@
+
+ enum
+ {
+- NUMBER_OF_TAGS = 10 /* The PGN Seven Tag Roster, White and Black ELOs, and ECO */
++ NUMBER_OF_TAGS = 12 /* The PGN Seven Tag Roster, White and Black ELOs, and ECO */
+ };
+
+-static const char *valid_keys[] = {"Event", "Site", "Date", "Round", "White", "Black", "Result", "WhiteElo", "BlackElo", "ECO"};
++static const char *valid_keys[] = {"Event", "Site", "Date", "Round", "White", "Black", "Result", "WhiteElo", "BlackElo", "ECO", "WhiteFideId", "BlackFideId"};
+
+ typedef struct CtGameTagsStruct
+ {
diff --git a/ct_game_tags.patch b/ct_game_tags.patch
deleted file mode 100644
index 28dace2492a8..000000000000
--- a/ct_game_tags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- ct_game_tags.c.prev 2016-07-26 23:35:58.583198811 +0300
-+++ ct_game_tags.c 2016-07-26 23:31:13.366532862 +0300
-@@ -26,10 +26,10 @@
-
- enum
- {
-- NUMBER_OF_TAGS = 10 /* The PGN Seven Tag Roster, White and Black ELOs, and ECO */
-+ NUMBER_OF_TAGS = 12 /* The PGN Seven Tag Roster, White and Black ELOs, and ECO */
- };
-
--static const char *valid_keys[] = {"Event", "Site", "Date", "Round", "White", "Black", "Result", "WhiteElo", "BlackElo", "ECO"};
-+static const char *valid_keys[] = {"Event", "Site", "Date", "Round", "White", "Black", "Result", "WhiteElo", "BlackElo", "ECO", "WhiteFideId", "BlackFideId"};
-
- typedef struct CtGameTagsStruct
- {