summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c36add7e89f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = chicken-condition-utils
+ pkgdesc = Chicken Scheme Egg: SRFI 12 Condition Utilities
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://chicken.wiki.br/eggref/4/condition-utils
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = chicken>=4.5.0
+ depends = chicken-setup-helper
+ depends = chicken-check-errors>=1.12.0
+
+pkgname = chicken-condition-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48fc3b06b6e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Aaron P <aaronbpaden@gmail.com>
+# Contributer: Jim Pryor <profjim@jimpryor.net>
+
+pkgname=chicken-condition-utils
+_pkgname=condition-utils
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Chicken Scheme Egg: SRFI 12 Condition Utilities"
+arch=('i686' 'x86_64')
+url="http://chicken.wiki.br/eggref/4/condition-utils"
+license=('BSD')
+depends=('chicken>=4.5.0' 'chicken-setup-helper' 'chicken-check-errors>=1.12.0' )
+
+build() {
+ cd "$srcdir/"
+ chicken-install -r "${_pkgname}":"${pkgver}"
+}
+
+package() {
+ cd "$_pkgname"
+ chicken-install -p "$pkgdir/usr"
+}