summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca89a74a76d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = chirurgien-git
+ pkgdesc = Chirurgien helps understand and manipulate file formats
+ pkgver = 1.0.r7.g10da91c
+ pkgrel = 1
+ url = https://github.com/leonardschardijn/Chirurgien
+ arch = any
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ depends = gtk4
+ depends = glib2
+ provides = chirurgien
+ conflicts = chirurgien
+ source = git+https://github.com/leonardschardijn/Chirurgien.git
+ sha256sums = SKIP
+
+pkgname = chirurgien-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0fa0fc74b85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=chirurgien-git
+_pkgname=Chirurgien
+pkgver=1.0.r7.g10da91c
+pkgrel=1
+pkgdesc="Chirurgien helps understand and manipulate file formats"
+arch=('any')
+url="https://github.com/leonardschardijn/Chirurgien"
+license=('GPL3')
+depends=('gtk4' 'glib2')
+makedepends=('git' 'meson')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ arch-meson $_pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}