summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD14
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61927c4b39cb..7ea1d3c0f640 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chkcrontab
pkgdesc = A tool for checking system crontab files for errors and common mistakes.
pkgver = 1.7
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/lyda/chkcrontab
arch = any
license = Apache
@@ -10,4 +10,3 @@ pkgbase = chkcrontab
sha256sums = 1725172dbdea26f1aef915b9acd7100605e49f8675761900bc0992a227d767b9
pkgname = chkcrontab
-
diff --git a/.gitignore b/.gitignore
index 2d72b4cd24ca..e38eb34d4ee1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-*.tar.gz
-*.pkg.tar.xz
/pkg/
/src/
+*.pkg.tar.*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index fa33a03c86bf..8f58e263d746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chkcrontab
pkgver=1.7
-pkgrel=4
+pkgrel=5
pkgdesc="A tool for checking system crontab files for errors and common mistakes."
arch=("any")
url="https://github.com/lyda/chkcrontab"
@@ -11,7 +11,17 @@ depends=("python")
source=("https://github.com/lyda/chkcrontab/archive/v${pkgver}.tar.gz")
sha256sums=("1725172dbdea26f1aef915b9acd7100605e49f8675761900bc0992a227d767b9")
+build() {
+ cd "chkcrontab-${pkgver}"
+
+ python setup.py build
+}
+
package() {
cd "chkcrontab-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 README.rst "${pkgdir}/usr/share/doc/chkcrontab/README.rst"
+ install -Dm644 doc/chkcrontab.1 "${pkgdir}/usr/share/man/man1/chkcrontab.1"
}