summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efc90164782c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chksum-git
+ pkgdesc = Check and compare easily the checksum of a file.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/ChacaS0/chksum
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = go-pie
+ conflicts = chksum
+ source = git+https://gitlab.com/chacas0/chksum#branch=master
+ sha256sums = SKIP
+
+pkgname = chksum-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0742b91d47ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ChacaS0 <incoming+chacas0-chksum-13830438-issue-@incoming.gitlab.com>
+pkgname=chksum-git
+pkgver=0.1
+pkgrel=1
+pkgdesc='Check and compare easily the checksum of a file.'
+arch=('x86_64')
+url="https://gitlab.com/ChacaS0/chksum"
+license=('Apache')
+conflicts=("chksum")
+makedepends=('git' 'go-pie')
+source=("git+https://gitlab.com/chacas0/chksum#branch=master")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/chksum"
+ go build \
+ -trimpath \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ .
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/chksum"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file