summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a333c7aed94..111a091e3fdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
- pkgver = 47.0.2526.16
+ pkgver = 48.0.2535.0
pkgrel = 1
url = http://www.chromium.org
install = chromium-dev.install
@@ -52,7 +52,7 @@ pkgbase = chromium-dev
optdepends = libexif: Need for read EXIF metadata
optdepends = ttf-font: For some typography
options = !strip
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-47.0.2526.16.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-48.0.2535.0.tar.xz
source = chromium-launcher-3.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v3.tar.gz
source = chromium-dev.desktop
source = chromium-dev.xml
@@ -60,8 +60,7 @@ pkgbase = chromium-dev
source = https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-system-jinja-r7.patch
source = https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-system-ffmpeg-r0.patch
source = enable_vaapi_on_linux-r1.diff
- source = https://codereview.chromium.org/download/issue1383303002_20001.diff
- sha1sums = 6992c7fd9f429251b89f4a9e1031b544e253e297
+ sha1sums = 9e897ff526bd2bf36ce74f53a2e7a1c54fdee3bb
sha1sums = d18f8d96e80be9c31d994cc6362d7d8041c53319
sha1sums = 0acc45b901418f270d0b2068502e39c407c74ea4
sha1sums = 2b98c549332e7337307ce287e150930cfc1dfa5f
@@ -69,7 +68,6 @@ pkgbase = chromium-dev
sha1sums = c24d14029714d2295f3220a7173a5a7362f578a2
sha1sums = 8e828ffd7de532becdd30378cdcc8411575a7b0b
sha1sums = 255d71cd9b9e55265e1bfeaa4612bcf60d293204
- sha1sums = 002b0bb9b07d8a823cf32fb399730031e86a49c3
makedepends_x86_64 = lib32-gcc-libs
makedepends_x86_64 = lib32-zlib
diff --git a/PKGBUILD b/PKGBUILD
index c78d6e6b2389..530e493f15ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
#########################
_use_clang=1 # Use clang compiler (system). Results in faster build and smaller chromium.
-_use_bundled_clang=1 # Use bundled clang compiler (needs build). NOTE: if use this option , _use_clang need set to 1
+_use_bundled_clang=1 # Use bundled clang compiler (needs build). NOTE: if use this option , '_use_clang' need set to 1
_use_ccache=0 # Use ccache when build
_use_pax=0 # Set 1 to change PaX permisions in executables NOTE: only use if use PaX environment
_use_gtk3=1 # If set 1, then build with GTK3 support, if set 0, then build with GTK2
@@ -18,7 +18,7 @@ _use_gtk3=1 # If set 1, then build with GTK3 support, if set 0, then
## -- Package and components information -- ##
##############################################
pkgname=chromium-dev
-pkgver=47.0.2526.16
+pkgver=48.0.2535.0
_launcher_ver=3
pkgrel=1
pkgdesc="The open-source project behind Google Chrome (Dev Channel)"
@@ -85,7 +85,7 @@ source=("https://commondatastorage.googleapis.com/chromium-browser-official/chro
# Misc Patches
'enable_vaapi_on_linux-r1.diff'
# Patch from crbug (chromium bugtracker)
- 'https://codereview.chromium.org/download/issue1383303002_20001.diff' ## https://codereview.chromium.org/1383303002
+
)
sha1sums=( #"$(curl -sL https://gsdview.appspot.com/chromium-browser-official/?marker=chromium-${pkgver}.tar.x | awk -v FS='<td>"' -v RS='"</td>' '$0=$2' | head -n1)"
"$(curl -sL "https://commondatastorage.googleapis.com/chromium-browser-official/chromium-${pkgver}.tar.xz.hashes" | grep sha1 | cut -d " " -f3)"
@@ -99,7 +99,7 @@ sha1sums=( #"$(curl -sL https://gsdview.appspot.com/chromium-browser-official/?m
# Misc Patches
'255d71cd9b9e55265e1bfeaa4612bcf60d293204'
# Patch from crbug (chromium bugtracker)
- '002b0bb9b07d8a823cf32fb399730031e86a49c3'
+
)
options=('!strip')
install=chromium-dev.install
@@ -118,12 +118,10 @@ _google_default_client_secret="0ZChLK6AxeA3Isu96MkwqDR4"
# 32 or 64 bits?
if [ "${CARCH}" = "i686" ]; then
- _build_ffmpeg_args=" --disable-asm"
_target_arch=ia32
_build_pnacl=0
_pnacl_arch=32
elif [ "${CARCH}" = "x86_64" ]; then
- _build_ffmpeg_args=""
_target_arch=x64
_build_pnacl=1
_pnacl_arch=64
@@ -404,10 +402,6 @@ _use_system=('-Duse_system_expat=1'
'-Duse_system_zlib=1'
)
-# Add more options to ffmpeg NOTE: in testing
-_extended_ffmpeg_flags=('--enable-vdpau'
- '--enable-vaapi'
- )
################################################
@@ -440,8 +434,6 @@ prepare() {
# fix the missing define (if not, fail build) (need upstream fix) (https://crbug.com/473866)
sed '14i#define WIDEVINE_CDM_VERSION_STRING "The Cake Is a Lie"' -i "third_party/widevine/cdm/stub/widevine_cdm_version.h"
- # Add support for Kwallet5 in KF5 environment (https://codereview.chromium.org/1383303002)
- patch -p1 -i ../issue1383303002_20001.diff
# Make it possible to remove third_party/adobe
echo > "${srcdir}/flapper_version.h"