summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40f0a66ddef7..381b133bb45d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Sep 30 11:18:57 UTC 2016
+# Sat Oct 1 11:03:21 UTC 2016
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
pkgver = 55.0.2873.4
diff --git a/PKGBUILD b/PKGBUILD
index e646876e864e..ed5965dcfdd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -141,7 +141,7 @@ if [ "${CARCH}" = "i686" ]; then
elif [ "${CARCH}" = "x86_64" ]; then
_build_nacl=1
_nacl="true"
- makedepends=('ncurses5-compat-libs')
+ makedepends+=('ncurses5-compat-libs')
fi
# If use PaX environment.
@@ -149,7 +149,6 @@ if [ "${_use_pax}" = "1" ]; then
makedepends+=('paxctl')
fi
-
# Build with GTK3?.
if [ "${_use_gtk3}" = "1" ]; then
depends+=('gtk3')
@@ -537,8 +536,17 @@ package() {
install -Dm644 natives_blob.bin "${pkgdir}/usr/lib/chromium-dev/natives_blob.bin"
install -Dm644 snapshot_blob.bin "${pkgdir}/usr/lib/chromium-dev/snapshot_blob.bin"
+ _resources=('chrome_100_percent'
+ 'chrome_200_percent'
+ 'keyboard_resources'
+ 'mus_app_resources_100'
+ 'mus_app_resources_200'
+ 'mus_app_resources_strings'
+ 'resources'
+ 'views_mus_resources'
+ )
# Install Resources.
- for i in chrome_100_percent chrome_200_percent keyboard_resources keyboard_resources mus_app_resources_100 mus_app_resources_200 mus_app_resources_strings resources views_mus_resources; do
+ for i in "${_resources[@]}"; do
install -Dm644 "${i}.pak" "${pkgdir}/usr/lib/chromium-dev/${i}.pak"
done