summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acb055f6d928..5e5e67f5a45e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jul 31 19:10:25 UTC 2018
+# Sat Sep 22 22:15:11 UTC 2018
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
- pkgver = 69.0.3497.12
+ pkgver = 71.0.3554.4
pkgrel = 1
url = http://www.chromium.org
install = chromium-dev.install
@@ -45,7 +45,7 @@ pkgbase = chromium-dev
optdepends = libva-vdpau-driver-chromium: HW video acceleration for NVIDIA users
optdepends = libva-mesa-driver: HW video acceleration for Nouveau, R600 and RadeonSI users
optdepends = libva-intel-driver: HW video acceleration for Intel G45 and HD users
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-69.0.3497.12.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-71.0.3554.4.tar.xz
source = git+https://github.com/foutrelis/chromium-launcher.git
source = chromium-dev.svg
source = https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-compiler-r4.patch
@@ -56,7 +56,7 @@ pkgbase = chromium-dev
source = chromium-widevine-r2.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-widevine-r2.patch?h=packages/chromium
source = chromium-skia-harmony.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-skia-harmony.patch?h=packages/chromium
source = fix_mixup_between_DIP_pixel_coordinates.diff.base64::https://chromium-review.googlesource.com/changes/1083692/revisions/3/patch?download
- sha256sums = 9bcdec32fc570e83ba9b12ecc74e67d13b024a58113e6d28668ba52aa8c55480
+ sha256sums = cf3ad33c0fe4125dd539997e2f3631576205d847db0d5b2e80d9ebdf43aee570
sha256sums = SKIP
sha256sums = dd2b5c4191e468972b5ea8ddb4fa2e2fa3c2c94c79fc06645d0efc0e63ce7ee1
sha256sums = c8225c0c14288c21f5cc448afc0f67fc4563517c39a8680af9e659f5b2d8f418
diff --git a/PKGBUILD b/PKGBUILD
index 1193a2680f70..3fecea0d29e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ _use_wayland=0 # Build Wayland NOTE: extremely experimental and don't
## -- Package and components information -- ##
##############################################
pkgname=chromium-dev
-pkgver=69.0.3497.12
+pkgver=71.0.3554.4
pkgrel=1
pkgdesc="The open-source project behind Google Chrome (Dev Channel)"
arch=('x86_64')
@@ -144,6 +144,7 @@ _keeplibs=(
'net/third_party/nss'
'net/third_party/quic'
'net/third_party/spdy'
+ 'net/third_party/uri_template'
'third_party/WebKit'
'third_party/abseil-cpp'
'third_party/analytics'
@@ -277,6 +278,13 @@ _keeplibs=(
'third_party/web-animations-js'
'third_party/webdriver'
'third_party/webrtc'
+ 'third_party/webrtc/common_audio/third_party/fft4g'
+ 'third_party/webrtc/common_audio/third_party/spl_sqrt_floor'
+ 'third_party/webrtc/modules/third_party/fft'
+ 'third_party/webrtc/modules/third_party/g711'
+ 'third_party/webrtc/modules/third_party/g722'
+ 'third_party/webrtc/rtc_base/third_party/base64'
+ 'third_party/webrtc/rtc_base/third_party/sigslot'
'third_party/widevine'
'third_party/woff2'
'third_party/zlib/google'
@@ -284,7 +292,7 @@ _keeplibs=(
'v8/src/third_party/valgrind'
'v8/src/third_party/utf8-decoder'
'v8/third_party/inspector_protocol'
- 'v8/third_party/antlr4'
+ 'v8/third_party/v8'
# gyp -> gn leftovers
'base/third_party/libevent'
@@ -323,6 +331,8 @@ _flags=(
'use_jumbo_build=false' # https://chromium.googlesource.com/chromium/src/+/lkcr/docs/jumbo.md
'enable_vulkan=true'
'use_vaapi=true'
+ 'enable_hevc_demuxing=true'
+ 'enable_ac3_eac3_audio_demuxing=true'
)
if [ "${_wayland}" = "1" ]; then
@@ -397,9 +407,6 @@ elif [ "${_use_bundled_clang}" = "1" ]; then
_flags+=(
'clang_use_chrome_plugins=true'
)
- # Bundled clang not like this.
- CXXFLAGS="${CXXFLAGS//-fno-plt/}"
- CFLAGS="${CFLAGS//-fno-plt/}"
if [ ! -f "${BUILDDIR}/PKGBUILD" ]; then
_builddir="/${pkgname}"
@@ -525,6 +532,8 @@ build() {
LC_ALL=C gn gen out/Release -v --args="${_flags[*]}" --script-executable=/usr/bin/python2
# Build all.
+ # Work around broken deps
+ LC_ALL=C ninja -C out/Release gen/ui/accessibility/ax_enums.mojom.h
LC_ALL=C ninja -C out/Release -v chrome chrome_sandbox chromedriver #widevinecdmadapter
}
@@ -568,7 +577,6 @@ package() {
'snapshot_blob.bin'
'v8_context_snapshot.bin'
'icudtl.dat'
- 'transport_security_state_generator'
#
'MEIPreload/manifest.json'
'MEIPreload/preloaded_data.pb'