summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD50
-rw-r--r--chromium-extension-privacybadger.changelog585
-rw-r--r--privacybadger.pem28
5 files changed, 81 insertions, 600 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 600ef96ae6c4..ccd92acb5d46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = chromium-extension-privacybadger
pkgdesc = Block third party tracking in your browser
- pkgver = 2021.6.8
- pkgrel = 1
+ pkgver = 2024.2.6
+ pkgrel = 3
url = https://privacybadger.org/
- changelog = chromium-extension-privacybadger.changelog
arch = any
license = GPL3
+ makedepends = jq
+ makedepends = openssl
depends = chromium
- source = chromium-extension-privacybadger-2021.6.8.crx::https://www.eff.org/files/privacy_badger-2021.6.8.crx
- b2sums = e5c6022e33a9374d6e759e61222bbd0781cb10428eba7228c5abffc0a978ad3258fb1dbc45db4908be6339342004c043e20eec08c6d2c40ceb9b58be3f17f8f3
+ source = chromium-extension-privacybadger-2024.2.6.tar.gz::https://github.com/EFForg/privacybadger/archive/refs/tags/release-2024.2.6.tar.gz
+ source = privacybadger.pem
+ sha256sums = e38c88f74236ef2549933603403428c43b45dabbf384964064d124135d5a0cfc
+ sha256sums = 0f6e6fa1bb901480be99d24d26104f4ff67b41b9d748595f01f1779b7fc2a642
pkgname = chromium-extension-privacybadger
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7e5df6cdf93d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.crx
+*.zst
+pkg/
+src/
+chromium-extension-*
diff --git a/PKGBUILD b/PKGBUILD
index b55929391ca7..977b453d7584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,52 @@
-# Maintainer: Qontinuum <qontinuum.dev@protonmail.ch>
+# Maintainer: Noah Vogt (noahvogt) <noah@noahvogt.com>
+# private key generated with `openssl genrsa 2048| openssl pkcs8 -topk8 -nocrypt -traditional`
-pkgname='chromium-extension-privacybadger'
-pkgver=2021.6.8
-pkgrel=1
+_extension='privacybadger'
+pkgname="chromium-extension-$_extension"
+pkgver=2024.2.6
+pkgrel=3
pkgdesc="Block third party tracking in your browser"
license=('GPL3')
arch=('any')
url="https://privacybadger.org/"
depends=('chromium')
-changelog=$pkgname.changelog
-source=("$pkgname-$pkgver.crx::https://www.eff.org/files/privacy_badger-$pkgver.crx")
-b2sums=('e5c6022e33a9374d6e759e61222bbd0781cb10428eba7228c5abffc0a978ad3258fb1dbc45db4908be6339342004c043e20eec08c6d2c40ceb9b58be3f17f8f3')
+makedepends=('jq' 'openssl')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/EFForg/privacybadger/archive/refs/tags/release-$pkgver.tar.gz"
+ "$_extension.pem")
+sha256sums=('e38c88f74236ef2549933603403428c43b45dabbf384964064d124135d5a0cfc'
+ '0f6e6fa1bb901480be99d24d26104f4ff67b41b9d748595f01f1779b7fc2a642')
build() {
- echo "{ \"external_crx\": \"/usr/share/$pkgname/$pkgname.crx\", \"external_version\": \"$pkgver\" }" > pkehgijcmpdhfbdbbnkijodmdjhbjlgp.json
+ # prepare source directory (while retaining reproducibility)
+ mv "privacybadger-release-$pkgver/src" "$pkgname-$pkgver"
+ find "$pkgname-$pkgver" -exec touch -t 202403120000 {} +
+
+ # derive variables from private key
+ pubkey="$(openssl rsa -in "$_extension.pem" -pubout -outform DER | base64 -w0)"
+ export _id="$(echo $pubkey | base64 -d | sha256sum | head -c32 | tr '0-9a-f' 'a-p')"
+
+ # create extension json
+ _extver="$(jq -r '.version' "$pkgname-$pkgver/manifest.json")"
+ cat << EOF > "$_id".json
+{
+ "external_crx": "/usr/lib/$pkgname/$pkgname-$pkgver.crx",
+ "external_version": "$_extver"
+}
+EOF
+
+ # enroll public key in manifest
+ cd "$pkgname-$pkgver"
+ jq --ascii-output --arg key "$pubkey" '. + {key: $key}' manifest.json > manifest.json.new
+ mv manifest.json.new manifest.json
+ touch -t 202403120000 manifest.json
+ cd ..
+
+ # pack extension
+ tmpdir="$(mktemp -d chromium-pack-XXXXXX)"
+ chromium --user-data-dir="$tmpdir" --pack-extension="$pkgname-$pkgver" --pack-extension-key="$srcdir/$_extension.pem"
}
package() {
- install -Dm644 "$pkgname-$pkgver.crx" "$pkgdir/usr/share/$pkgname/$pkgname.crx"
- install -Dm644 pkehgijcmpdhfbdbbnkijodmdjhbjlgp.json "$pkgdir/usr/share/chromium/extensions/pkehgijcmpdhfbdbbnkijodmdjhbjlgp.json"
+ install -Dm644 -t "$pkgdir/usr/share/chromium/extensions/" "$_id.json"
+ install -Dm644 -t "$pkgdir/usr/lib/$pkgname/" "$pkgname-$pkgver.crx"
}
diff --git a/chromium-extension-privacybadger.changelog b/chromium-extension-privacybadger.changelog
deleted file mode 100644
index c5b2b1460795..000000000000
--- a/chromium-extension-privacybadger.changelog
+++ /dev/null
@@ -1,585 +0,0 @@
-Privacy Badger Release Notes
-============================
-
-2021.6.8
-* Disabled Google's Federated Learning of Cohorts (FLoC). To learn more, visit
-https://www.eff.org/deeplinks/2021/03/googles-floc-terrible-idea
-* Improved tracker detection and blocking by looking up known CNAME tracker
-aliases. Thanks to AdGuard for providing the CNAME DNS data behind this
-feature.
-* You can now see in the popup when first-party protections
-such as link unwrapping are active on the site you are on
-* Fixed various site breakages
-* Added Greek and Hungarian translations
-* Improved translations (Simplified Chinese, Esperanto, Hebrew, Korean,
-European Portuguese, Turkish, Swedish)
-
-2021.2.2
-* Added a dark theme. To see it, enable dark mode in operating system
-or device preferences.
-* Added a section to the Widget Replacement tab on the options page to manage
-the list of widgets that were set to be always allowed on certain sites
-* Disabled network prefetching/preloading to improve privacy
-* Added replacements for Dailymotion and OK.ru video player widgets
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Czech, French, Hebrew)
-
-2020.12.10
-* Added a direct link to widget content to replacements for widgets like
-YouTube, Vimeo, SoundCloud and Spotify. You can click this link to watch
-a video (for example) without sharing the page you are on with the video
-provider.
-* Fixed "fbclid" tracking parameter removal on Facebook
-* Enabled Google Search link unwrapping on Firefox for Android
-* Fixed various site breakages
-* Improved translations (Dutch, Esperanto, French, German, Hebrew, Polish,
-Russian, Swedish, Turkish, Ukrainian)
-
-2020.10.7
-* Disabled learning (by default) to address privacy concerns.
-Visit https://www.eff.org/badger-evolution to learn more.
-* Added support for Global Privacy Control, a new specification that
-lets you tell companies you'd like to opt out of data sharing and selling.
-Visit https://globalprivacycontrol.org/ to learn more.
-* Added a section to the options page to display the browser settings
-that Privacy Badger overrides for privacy reasons
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Dutch, Finnish, Hebrew, Italian,
-Russian, Spanish, Ukrainian)
-
-2020.8.25
-* Added a button to widget replacements to always allow a widget on a site
-* Improved scrolling of tracking domains on the options page
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Traditional Chinese, Esperanto,
-Finnish, French, Polish, Brazilian Portuguese, Russian, Spanish, Swedish)
-
-2020.7.21
-* Improved broken site reporting screen in the popup
-* Refreshed the look of options page tabs
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Danish, European Portuguese,
-Spanish, Turkish)
-
-2020.6.29
-* Added replacement placeholder for Disqus comments widgets
-* Fixed domain sliders on the options page not saving in some cases
-* Fixed slider changes on the options page resetting the list of domains,
-causing you to lose your place if you were scrolled down
-* Fixed domain slider tooltip display
-* Re-enabled custom tooltips in Firefox
-* Fixed various site breakages
-* Improved translations (Esperanto, Hebrew, Ukrainian)
-
-2020.6.2
-* Added replacement placeholders for Facebook Comments/Video and Twitch Player
-* Removed Twitter link unwrapping. We are unable to unwrap t.co links
-on Twitter at this time, as the original URL is no longer present
-in the Twitter website's document structure.
-* Fixed various site breakages
-* Improved translations (Hebrew, Polish, Swedish)
-
-2020.5.12
-* Made buttons in the popup easier to see and click (or tap, on Firefox for
-Android)
-* Added a replacement placeholder widget for Google reCAPTCHA
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Dutch, Finnish, French, German,
-Hebrew, Italian, Brazilian Portuguese, Spanish, Swedish, Turkish)
-
-2020.2.19
-* Added website breakage warnings, shown in the popup when you block a domain
-known to break websites
-* Removed pixel cookie sharing detection pending security fixes
-* Fixed various site breakages
-* Improved translations (Catalan, Simplified Chinese, Danish, Dutch, German,
-Russian)
-
-2020.1.13
-* Fixed bug that sometimes loses pre-trained data for new users
-* Fixed various site breakages
-
-2020.1.7.1
-* Added helpful text to popup on disabled sites
-* Fixed display issues in popup on smaller displays
-* Fixed Facebook link unwrapping on messenger.com
-* Fixed some cookies getting incorrectly flagged as high entropy
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Traditional Chinese, French,
-Hebrew, Italian, Korean, Russian, Spanish, Swedish, Ukrainian)
-
-2019.11.18
-* Improved display of domains Privacy Badger hasn't yet learned to block
-* Fixed export/import of the WebRTC protection setting
-* Fixed certain YouTube ("video unavailable"), Vimeo ("Because of its privacy
-settings, this video cannot be played here"), and other video players
-by revising referrer protection for "cookieblocked" domains
-* Fixed various other site breakages
-* Added Korean translations
-* Improved translations (Finnish, French, Hebrew, Swedish)
-
-2019.10.28
-* Refreshed the popup with a higher-contrast look
-* Widget placeholders will no longer be applied for domains on the yellowlist.
-The value of widget placeholders is full blocking (best privacy) combined with
-a clear way to restore potentially useful blocked content (convenience).
-Mixing cookie blocking and placeholders doesn't actually improve privacy or
-convenience but does introduce various bugs.
-* Added a replacement placeholder for YouTube (disabled by default as youtube.com
-is still on the yellowlist for now)
-* Added the Widget Replacement tab to the options page to manage widgets that
-do get blocked and replaced with Privacy Badger placeholders. Visit Widget
-Replacement to selectively disable placeholders. For example, you want social
-buttons out of your life completely.
-* Fixed various site breakages
-* Added Hebrew translations
-* Improved translations (Italian, Russian, Ukrainian)
-
-2019.10.8
-* Fixed image/video thumbnails in Google search results
-* Fixed various other site breakages
-* Removed the green "0" tracker count badge.
-No need to draw attention when there is nothing to show.
-* Improved translations (Simplified Chinese, Ukrainian)
-
-2019.9.23
-* Added helpful text to popup on special browser pages like the New Tab page
-* Fixed pixel cookie sharing detection being broken by First-Party Isolation
-in Firefox
-* Fixed major issues with Service Workers-powered sites like Gmail and Twitter
-* Fixed various other site breakages
-* Improved translations (Simplified Chinese, French, Spanish, Swedish,
-Turkish, Ukrainian)
-
-2019.7.1
-* Added pixel cookie sharing detection. Privacy Badger now records
-tracking by images with querystrings that contain first-party cookie data.
-This catches Google Analytics.
-* Removed display of non-tracking domains from the popup by default.
-Hiding domains that Privacy Badger does not consider to be tracking
-should reduce self-inflicted Web breakage.
-* Enabled Facebook link unwrapping on messenger.com
-* Fixed various site breakages
-* Added Catalan translations
-* Improved translations (Bulgarian, Traditional Chinese, Persian,
-Brazilian Portuguese, European Portuguese, Swedish, Ukrainian)
-
-2019.2.19
-* Improved replacement widgets:
-
- - Replaced the "play" icon with an "allow once" button to improve
- accessibility and to make it more clear our widgets are interactive
- - Made activation also activate any other widgets of the same type
- - Updated the replacement for Vimeo to ignore background videos
- - Set minimum dimensions to avoid becoming too small or hidden
-
-* Fixed various site breakages
-
-2019.1.30
-* Added replacement widgets for embedded Spotify, Streamable and Vimeo
-players. Privacy Badger can replace potentially useful third-party widgets
-with placeholders. This avoids on-by-default tracking while providing a clear
-way to restore the original widget on demand.
-* Fixed various site breakages
-* Added Arabic and European Portuguese translations
-* Improved translations (Traditional Chinese, Czech, German, Persian, Swedish,
-Turkish)
-
-2018.12.17
-* Fixed major Privacy Badger breakages in Chrome 72+
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Spanish, Turkish)
-
-2018.12.5
-* Added a Share button to the popup. This lets you easily copy and paste
-Badger's findings on any page.
-* Updated link protection to work on all Google Search country domains
-* Updated link protection on Facebook to remove the new "fbclid" tracking
-parameter
-* Added support for enterprise/admin/group policy settings overrides. This
-lets administrators preconfigure Privacy Badger installations. For more
-information, please visit
-https://github.com/EFForg/privacybadger/blob/master/doc/admin-deployment.md
-* Fixed various bugs with local storage protection for "cookieblocked" (slider
-set to "yellow") domains
-* Made the options page work better on small and on large displays
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Dutch, Esperanto, Finnish,
-German, Italian, Persian, Polish, Spanish, Swedish)
-
-2018.10.3.1
-* Fixed style problems with Google Search results
-* Fixed the setting to open results in new browser windows on Google Search
-
-2018.10.3
-* Added protection against outgoing link click tracking on Google Search,
-Google Docs and Google Hangouts
-* Fixed various site breakages
-* Added Finnish translations
-* Improved translations (Simplified Chinese)
-
-2018.9.20
-* Added buttons to back up and restore the disabled sites list using
-Firefox/Google Sync. The new buttons live under the Manage Data tab
-on the options page.
-* Added saving of in-progress error reports so that you no longer lose
-your typing when you close the popup for whatever reason
-* Fixed popup layout problems when opened in the overflow menu in Firefox
-* Updated popup and options to use a higher resolution Badger logo on higher
-pixel density displays
-* Fixed problems with broken fonts and images on Google Docs
-* Improved translations (Traditional Chinese, French, German,
-Brazilian Portuguese, Russian, Spanish, Swedish, Turkish)
-
-2018.8.22
-* Added pre-trained tracker data for new Privacy Badger installations.
-Visit www.eff.org/badger-pretraining to learn more.
-* Added reset/clear tracker data buttons to the Manage Data options page tab
-* Fixed various site breakages
-* Added Persian and Brazilian Portuguese translations
-* Improved translations (Simplified Chinese, Danish, Esperanto, French,
-German, Italian, Norwegian Bokmål, Spanish, Swedish)
-
-2018.8.1
-* Fixed security issues with HTML5 local storage tracking detection as well as
-SoundCloud widget replacement. Thanks again to Cure53 for discovering and
-reporting these vulnerabilities.
-* Improved Facebook link unwrapping; now enabled on the Facebook Onion domain
-* Improved translations (Italian, Norwegian Bokmål, Swedish, Ukrainian)
-
-2018.7.18.1
-* Added setting to disable sending Do Not Track to websites
-* Fixed security issue with link unwrapping on Facebook. Thanks to Cure53 for
-discovering and reporting this vulnerability.
-* Improved ordering of domain names in the popup and on the options page
-* Improved handling of disabled sites with wildcards
-* Added t.co link replacement to user profiles on Twitter
-* Linked to EFF software privacy policy from the new user welcome page
-* Updated to latest dummy Google Tag Manager script from uBlock Origin
-to avoid "failed to redirect a network request" warnings in Chrome
-* Fixed various site breakages
-* Improved translations (Simplified Chinese, Dutch, Esperanto, German,
-Russian, Swedish, Turkish)
-
-2018.5.10
-* Added protection against outgoing link click tracking on Facebook
-* Updated WebRTC protection to revert to browser default (off) when disabled
-* Fixed popup in the Italian locale in Chrome
-* Updated to latest dummy Google Analytics script from uBlock Origin
-to avoid "failed to redirect a network request" warnings in Chrome
-* Fixed various site breakages
-* Improved translations (Traditional Chinese, Danish, Dutch, Esperanto,
-French, German, Italian, Polish, Russian, Swedish, Ukrainian)
-
-2018.4.23
-* Fixed changes not being persisted for domains that appear after scrolling
-the tracking domains list on the options page
-* Improved tracking domains search on the options page
-* Fixed "can't access dead object" errors in Firefox
-* Fixed XML document rendering in Firefox
-* Updated WebRTC protection checkbox to become disabled when the setting is
-controlled by other extensions
-* Fixed various site breakages
-* Improved translations (Traditional Chinese, Czech, Danish, Esperanto,
-French, German, Italian, Polish, Russian, Swedish, Turkish, Ukrainian)
-
-2018.4.10
-* Updated the new user welcome page. The redesigned page is mobile-friendly,
-accessible and already translated into several languages.
-* Fixed Do Not Track being checked sometimes in Private Browsing/Incognito
-windows. By default, Privacy Badger should not record anything in Incognito.
-* Added setting to allow learning in Private Browsing/Incognito windows
-* Fixed unwanted scrolling when switching tabs on the options page
-* Updated replacement icon for Google+
-* Fixed various site breakages
-* Improved translations (Bulgarian, Simplified Chinese, Traditional Chinese,
-Danish, Esperanto, French, German, Italian, Polish, Russian, Spanish,
-Ukrainian)
-
-2018.3.21
-* Fixed Do Not Track not being recognized by sites that test for it by
-checking navigator.doNotTrack with JavaScript
-* Stopped signaling DNT on sites where Privacy Badger is disabled
-* Fixed popup in Private Browsing windows in Firefox
-* Fixed certain kinds of site breakages (such as visual issues with charts)
-not going away even after disabling Privacy Badger on the site
-* Updated to latest dummy Google Tag Manager script from uBlock Origin to
-avoid "failed to redirect a network request" warnings in Chrome
-* Fixed various site breakages
-* Improved translations (Bulgarian, Traditional Chinese, German, Italian,
-Swedish)
-
-2018.2.5
-* Added type/status filters to the tracking domains list on the options page
-* Reworked social widget replacement to avoid WebExtensions fingerprintability
-issue in Firefox
-* New translations (Turkish)
-* Improved translations (Danish, Esperanto, French, German, Polish, Swedish,
-Ukrainian)
-
-2018.1.30
-* Removed the "unlimitedStorage" permission from the manifest
-* Changed the tracker count badge color from red to "Privacy Badger orange"
-
-2018.1.25
-* Added workaround to avoid Privacy Badger getting disabled as "Not from
-Chrome Web Store" in Chrome
-
-2018.1.22
-* Reduced amount of data stored as part of normal operation. Privacy Badger
-will no longer record (or check Do Not Track policies for) non-tracking
-domains. This should enable us to remove the "unlimitedStorage" permission
-with the next Badger update.
-* Improved tracker detection status summaries in popup and options
-* Added explanatory acknowledgement to Tracking Domains options page tab
-* Fixed file download dialog not showing when exporting user data in Firefox
-* Removed tutorial reminder link from popup when already on tutorial page
-* Removed "Requests to the server have been blocked by an extension" messages
-in Chrome and Opera
-* Fixed style issue with replacement social widgets
-* Fixed error reporting on pages where Privacy Badger has been disabled
-* Fixed various site breakages
-* Improved translations (Bulgarian, Danish, Esperanto, French, German,
-Italian, Polish, Russian, Spanish, Swedish, Ukrainian)
-
-2017.11.20
-* Disabled custom tooltips in Firefox to work around browser freezing issues
-* Added validation to the disabled sites form
-* Improved translations (Dutch, Esperanto and German)
-* Added Bulgarian and Polish translations
-
-2017.11.9
-* Fixed various site breakages
-* Improved translations (French, Serbian and Ukrainian)
-* Added Esperanto translation
-
-2017.10.25.1
-* Reverted manifest file change preventing upload to Chrome Web Store
-
-2017.10.25
-* Added Beta support for Firefox for Android
-* Updated popup to close after doing anything that reloads the page
-* Improved handling of long domain names
-* Improved tooltips
-* Restored canvas fingerprinting detection to Firefox
-* Fixed yellowlist updates not getting applied when importing Badger data
-* Updated to latest dummy Google Analytics script from uBlock Origin
-to avoid "failed to redirect a network request" warnings in Chrome
-* Fixed various site breakages
-* Improved translations (Danish, French, German, Italian, Swedish)
-
-2017.9.12.1
-* Fixed build script issue that reintroduced major site breakages on Firefox
-
-2017.9.12
-* Fixed DNT policy checking for blocked domains
-* Fixed exporting large Badger datasets
-* Made progress on Firefox for Android compatibility
-* Fixed various site breakages
-* Improved badge updating performance
-* Improved translations (Czech, Italian, Swedish, Ukrainian)
-* Added Danish translation
-
-2017.7.24
-* Added validation to yellowlist (f.k.a. "cookieblock list") updating
-* Removed faulty yellowlist domain removal logic, which, together with missing
-validation and eff.org serving a maintenance page instead of the actual
-yellowlist, resulted in major breakages all across the Web, something this
-update should prevent from happening ever again
-* Fixed various site breakages
-* Improved translations (Swedish)
-
-2017.6.13.1
-* Added workaround for validation issue preventing upload to Chrome Web Store
-* Fixed chrome.privacy-related exceptions in Firefox 54
-
-2017.6.13
-* Added automatic replacement of t.co shortened tracking URLs with original
-unobfuscated URLs on twitter.com
-* Added option to disable Do Not Track policy checking
-* Restricted DNT policy checking from sending cookies
-* Fixed tooltips for DNT-compliant domains in popup
-* Fixed localStorage tracking sometimes being attributed to unrelated domains
-* Improved translations (Swedish, Ukrainian)
-
-2017.5.9
-* Improved popup rendering
-* Added version number to popup
-* Restricted Do Not Track policy checking from being able to set cookies
-* Fixed several cookie parsing issues
-* Added workaround for Cloudflare security cookies
-* Improved translations (Simplified Chinese, Swedish, Ukrainian)
-
-2017.4.19.1
-* Rework DNT policy rechecking to only happen during browsing. Eliminates
-needless rechecking of unlikely-to-be-visited-again domains. Should further
-mitigate CPU issues.
-* Fix DNT policies to only apply to specific domains they are posted on
-* New translations (Ukrainian)
-* Improved translations (Simplified Chinese, Italian)
-* Fix "trackers" link on popup and options pages
-* Fix broken site (sharepoint.com)
-
-2017.3.28
-* New Translations (Czech)
-* Translation Updates
-* Fix bug in DNT policy re-checking code
-* Rate limit DNT checking to one request per second
-* Fix issue with multiple DNT checks at once for a single domain
-* Fix cookieblock updating issue
-* Fix popup width issue
-* Fix DNT hash updating issue
-* Fix toggle switch issue
-* Automated tests now also run on Firefox
-* Other minor bugfixes and broken site fixes
-
-2017.3.22
-* AMO (Firefox) only release.
-* Fix cookie tracking detection in Firefox.
-
-2017.1.26.1
-* AMO only release
-* Fixes an error in the build scripts which reintroduced a firefox bug for AMO users
-
-2017.1.26
-* Huge speed improvements for settings import and on startup
-* Fixes no content blocking bug (firefox)
-* Several fixes for broken websites
-* Translations fixes
-* New Translation: Nordic
-* New Translation: Traditional Chineese (Taiwan)
-* New Translation: Serbian
-* Bugfix: Crash on browsers without WebRTC
-* Bugfix: narrow poup if icon is in the menu (firefox)
-* Bugfix: Import/Export now uses utf-8 and can handle non english character
-sets
-* Enhancement: Convert icons to SVG
-* Enhancement: Script surrogate for google analytics, gigya, and more...
-* KNOWN ISSUE: Chrome will now display a message "Not downloaded from chrome
-
-2016.12.15.1 (2.0.2)
-* BUGFIX: Chrome browsers no longer display privacy badger as (corrupted)
-* BUGFIX: Fixes lockup issue on some versions of firefox
-* BUGFIX: Fixes issue where privacy badger panel gets cut off
-* BUGFIX: Fixes a non implmeneted API in firefox which was causing numerous
-sites to break.
-* KNOWN ISSUE: Chrome will now display a message "Not downloaded from chrome
-store". This is a known side effect of a workaround for a different bug.
-
-2016.12.8.1 (2.0.1)
-* BUGFIX: Sanitize origin and action in popup
-
-2016.12.8 (2.0)
-* BUGFIX: Fix ublock origin warnings
-* BUGFIX: Remove need for download permission
-
-2016.12.7.2 (2.0RC1)
-* Huge speed improvements
-* Multiprocess Compatible (E10S) for firefox
-* Breaks many fewer websites
-* Many small bugfixes
-* Import and Export your data
-* Block WebRTC from leaking your IP address
-* Forget data in incognito mode
-* block html5 "ping" tracking
-* Translation fixes
-* (Developers) Firefox and Chrome versions now share one code base!
-
-2016.9.7 (1.13)
-* Add exceptions for multi domain first parties
-* Fix google drive download issue
-* Fix wikipedia login issue
-* Fix youtube comments and notifications issues
-* Several other broken site fixes
-* Hopefully a fix for the "corrupted extension" issue
-
-2016.8.29 (1.12)
-* UI Tweaks
-* Remove last adblock plus code
-* Feature: remove domains from list
-* Refactor incognito mode handling
-* Compatibile with firefox web extensions
-
-2016.5.24 (1.11)
-* Fix build error
-
-2016.5.23 (1.10)
-* Fix cookie block list adding bug
-* New migration to fix bug retroactively
-
-2016.5.16 (1.9)
-* Remove Adblock Plus Engine
-* Switch to using storage.js and chrome storage API
-* Massive refactoring of code
-* Huge speed improvements
-* Fixes bug where privacy badger "forgets" settings
-* Fixes first run tab opening on every startup
-* Fix waiting for privacy badger bug
-* Fix high CPU usage bug
-* Uses separate data store for incognito mode
-* Ads selenium test to run pbtest.org sweet
-* Fixes weird subdomain handling edge case
-* Fixes bug where pages stop loading sometimes
-
-2015.4.6 (1.8)
-* Fix "waiting for privacy badger bug"
-* Huge speed improvement
-
-2015.4.6 (1.7)
-* Fix crash when closing options page
-* Add EFF Donate Button
-* New popup to nag user to go through tutorial
-
-2015.3.2 (1.0.6)
-* New feature: Search within blocked domain list
-* Replace soundcloud widget with a click to play button
-* Misc. bug fixes and translation improvements
-
-2015.12.3 (1.0.4)
-* Lots of site bug fixes
-* Chinese Translation
-* Spanish Translation
-* italian translation
-* UI Overhaul
-* Update Swedish locale
-* Typo fixes
-* Numerous bug fixes
-* Added support for disabled sites with wildcards
-* Red badge now reflects the number of domains blocked or cookieblocked
-instead of all third parties.
-* Tooltips show full domain name
-
-2015.8.14 (1.0.1)
-* Fixes a bug where slider settings for a base domain wouldn't take effect
-* Fixes 'this extension is slowing down chrome' errors
-
-2015.8.5 (1.0)
-* 1.0 release
-* Bugfixes from 2015.7.24 (0.99)
-* Detects Canvas Fingerprinting
-* Detect Local Storage Supercookies
-* Improved UI
-* Options page for overriding privacy badger settings
-* Report Broken Site button
-* Many Bugfixes (see github)
-* Translations into swedish, french and german
-
-2015.7.24 (0.99)
-* Release candidate for version 1.0!
-
-2015.4.1
-* Miscellanious bugfixes
-* Improvements to heuristic
-
-2014.9.16
-* Adds lots of tests including selenium tests.
-* Adds lots of domains to the cookie block list.
-* Fixes bug with downloading cookie block list.
-* Fixes other minor stylistic bugs.
-
-2014.7.17
-* Created dialog to allow users to unblock certain third parties on certain
-* sites for addedd functionality. E.g. disqus comments, facebook comments, etc.
-* Added lots of domains to cookie block list.
-* do not show domains that do not appear to be trackers in the popup
-* added missing google+ button override
diff --git a/privacybadger.pem b/privacybadger.pem
new file mode 100644
index 000000000000..3748c021b362
--- /dev/null
+++ b/privacybadger.pem
@@ -0,0 +1,28 @@
+-----BEGIN PRIVATE KEY-----
+MIIEvQIBADANBgkqhkiG9w0BAQEFAASCBKcwggSjAgEAAoIBAQC/FDVL/5lrFCdu
+fPfiHX8JtbMg1pOCjvCASHJoZWFdVsNd/v+zukzcbbrnxXhTGQ8yICKgsNuDnHy/
+8A44v9+AmOV/A8huVW26bjItbKVzm/iouY6yCQ+NoipS53ujPNjBQwRfsTck945x
+dj2Ve+naueM97TWRJSH/ykJTVk0lG/kWD0qUN9U/mFy16BsvRAkxiGaHp183F/Jm
+kVLMLBZX0B8iNxa388R0FhoU3lDshLrG0vuIo1pweceVqqWaExb9VQbpfoQkl6vH
+0Kl+bWPDNLjes6wP85TH4CIgrv0EXSeUmHHM5L8LDOIEq7wWoyq4NkPT1bplSYyn
+VAuPbzV9AgMBAAECggEAAQH9bV8JFnWKGk0HIXaE3NtluRxdaLPR/mc2nUJw0t7a
+IG6JUQLmri0kLkR0tKfkh3mAA6dzI1ZQGexzv4zGUPJ3F8ym27gdIEpw/s7WIsFo
+yUds3BdsPgbwxxrb8TnPeqapfDGEocmhdj7Vc9EHvas7anBY49QiW58PBJgA4UHd
+n06nPmy9csOv85IYvCRdh1VqVWEDjLLWjr+5ZspELft+mQnDJmWzkYqQ7+wFhN5k
+dpaSw/9AWdckwiZllf6kdKKvbDvWKeeQ7tL4cx8ZTcz8GPnpE/N0LA4LpMiF6jEI
+gJc7wxne3PtGH8sYMJ4mYbRCU/fuOt7uNyzZrm/XmQKBgQDuNptk74FclTI9XTUa
+cGyiawIuvuk3SOM9wKralLyx1bwSnuLR1Df5z1qCJrMbm88EMSUrE16W3O8saFjm
+W8xJx9Ua+uE5R4grCVjfS/Cw2khlAHce2seu5Vx7Q4QGaLl6mljf3In9FZsUCuN5
+0U7geEV3PXOubUSt+qPgt1tF5QKBgQDNWKNx5gxxG52MEMj+3YDhUGXNbvFi/J7L
+/NO7MjzK8E3CRv9AzxsZc8nK5Q1xBH15uA3on+qhXXqu9OqM2XSSkTJofhrxXVDy
+ebwPAgz+FaD4K2eUTy5mJ/kBm3YQoWF3tU5OeohVROyPdBWE9K6JYsHbMcxwnrDa
+5KGb6Ue3uQKBgHd0KriS4evrZSYgd2Cqv88ymgWW9pwikNGGrCawL29+HrG3u0Y9
+hVRgBqL9hRNzLnyLqHfRXr2ITOeX6/yYS/kznEnLROXUWRQ7u7U9/5Sv4V3Evfda
+/odVvOqTEMGmAlzYyXh4vzmKfBmw3CFaNJObvDnvNvNhF++moEcvqzWBAoGAXWpz
+gH89Lb94Xp3MMlWmKdofVeOgoH136CiuUby69z92wGj3+g29sEiChnDJOp7mThcz
+DJ6jaKFUDH+SrFzIsVyoZ+zmaOMgzg4fRVyTeItyXTOxvUCARSzuFJMalNo1svWi
+GAWaO+BNFb2jhIajWBC7S/JNpPYsUogsFPd9DtECgYEAr0XT+YvWAlKvskigY0XV
+bG5avm1gI+ANmmQKoPr5qYXmbKaPmChc1PTaE5/Ft1MM+92yhydRhU7Aio/uNT0O
+GGb/tjJFfz1JTItzDGyg1/FZuFh7c+Stm87i2ddn7TFhKopOOhBhkR7X78mAkxb9
+vNViheUL5T3BneuhPBB453Y=
+-----END PRIVATE KEY-----