summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
-rw-r--r--chromium-snapshot-bin.install19
-rw-r--r--chromium-snapshot-bin.sh14
4 files changed, 12 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7080d7185502..950a51a07c82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,10 +34,9 @@ pkgbase = chromium-snapshot-bin
optdepends = kdebase-kdialog: needed for file dialogs in KDE
optdepends = gnome-keyring: for storing passwords in GNOME keyring
optdepends = kdeutils-kwalletmanager: for storing passwords in KWallet
- optdepends = chromium-pepper-flash-dev: for Pepper Flash plugin [AUR]
- optdepends = google-chrome-dev: for Pepper Flash plugin [AUR]
+ optdepends = pepper-flash: for Pepper Flash plugin [AUR]
provides = chromium
- source = chrome-linux-r411883.zip::http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux_x64/411883/chrome-linux.zip
+ source = chrome-linux-r431563.zip::http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux_x64/431563/chrome-linux.zip
source = chromium-snapshot-bin.sh
source = chromium-snapshot-bin.desktop
source = chromium-snapshot-bin_16.png
@@ -50,7 +49,7 @@ pkgbase = chromium-snapshot-bin
source = chromium-snapshot-bin_256.png
source = LICENSE
md5sums = SKIP
- md5sums = 52c593f49e39413dc6a421235590d77f
+ md5sums = 6777e99bcfdb4c7a004b0e3b2ab54c84
md5sums = 1f7c85955a1b845105b3464186d82b97
md5sums = 6cd41f6e08eee03c6553603fb0b6ecd7
md5sums = 227eac16d1e737bed42742840b950d41
diff --git a/PKGBUILD b/PKGBUILD
index edd406084fef..898f8034df30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,7 @@ depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss' 'icu'
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
'gnome-keyring: for storing passwords in GNOME keyring'
'kdeutils-kwalletmanager: for storing passwords in KWallet'
- 'chromium-pepper-flash-dev: for Pepper Flash plugin [AUR]'
- 'google-chrome-dev: for Pepper Flash plugin [AUR]')
+ 'pepper-flash: for Pepper Flash plugin [AUR]')
provides=('chromium')
install=$pkgname.install
_build=$(curl -s "http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux_x64/LAST_CHANGE")
@@ -27,7 +26,7 @@ source=("chrome-linux-r$_build.zip::http://commondatastorage.googleapis.com/chro
"$pkgname"_{16,22,24,32,48,64,128,256}.png
'LICENSE')
md5sums=('SKIP'
- '52c593f49e39413dc6a421235590d77f'
+ '6777e99bcfdb4c7a004b0e3b2ab54c84'
'1f7c85955a1b845105b3464186d82b97'
'6cd41f6e08eee03c6553603fb0b6ecd7'
'227eac16d1e737bed42742840b950d41'
diff --git a/chromium-snapshot-bin.install b/chromium-snapshot-bin.install
index acc2e7132f4d..ea7b020eefbd 100644
--- a/chromium-snapshot-bin.install
+++ b/chromium-snapshot-bin.install
@@ -12,21 +12,8 @@ bold="${all_off}$(tput bold)"
blue="${bold}$(tput setaf 4)"
yellow="${bold}$(tput setaf 3)"
-_update() {
- msg_blue "Updating icon cache.."
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
- msg_blue "Updating desktop MIME database..."
- update-desktop-database -q
-}
-
post_install() {
- _update
- echo
-
- note "Pepper Flash is now auto-detected from:
- - /usr/lib/PepperFlash/ (chromium-pepper-flash-dev)
- - /opt/google/chrome-unstable/PepperFlash/ (google-chrome-dev)"
+ note "Pepper Flash is now auto-detected from: /usr/lib/PepperFlash/ (pepper-flash [AUR])
echo
note "Custom flags should be put directly in: ~/.config/chromium-flags.conf
@@ -41,7 +28,3 @@ post_upgrade() {
post_install
}
-
-post_remove() {
- _update
-}
diff --git a/chromium-snapshot-bin.sh b/chromium-snapshot-bin.sh
index bc3204114c9a..50193d66c34b 100644
--- a/chromium-snapshot-bin.sh
+++ b/chromium-snapshot-bin.sh
@@ -6,14 +6,12 @@ if [[ -f ~/.config/chromium-flags.conf ]]; then
fi
# Detect Pepper Flash
-for i in '/opt/google/chrome-unstable' '/usr/lib'; do
- if [[ -f $i/PepperFlash/libpepflashplayer.so ]]; then
- PepperFlash="$i/PepperFlash/libpepflashplayer.so"
- PepperFlashVersion="$(grep 'version' $i/PepperFlash/manifest.json | cut -d '"' -f4)"
- CHROMIUM_USER_FLAGS+=" --ppapi-flash-path=$PepperFlash --ppapi-flash-version=$PepperFlashVersion"
- continue
- fi
-done
+if [[ -f /usr/lib/PepperFlash/libpepflashplayer.so ]]; then
+ PepperFlashLib="/usr/lib/PepperFlash/libpepflashplayer.so"
+ PepperFlashVersion="$(grep 'version' /usr/lib/PepperFlash/manifest.json | cut -d '"' -f4)"
+ CHROMIUM_USER_FLAGS+=" --ppapi-flash-path=$PepperFlashLib --ppapi-flash-version=$PepperFlashVersion"
+ continue
+fi
# Let the wrapped binary know that it has been run through the wrapper.
export CHROME_WRAPPER="$(readlink -f $0)"