summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO52
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD80
-rw-r--r--chromium-snapshot-bin23
-rw-r--r--chromium-snapshot-bin.desktop113
-rw-r--r--chromium-snapshot-bin.install46
6 files changed, 341 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..172cd214542c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,52 @@
+pkgbase = chromium-snapshot-bin
+ pkgdesc = The open-source project behind Google Chrome (Snapshot builds)
+ pkgver = 45.0.2432.0.r334343
+ pkgrel = 1
+ url = https://build.chromium.org
+ install = chromium-snapshot-bin.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = gtk2
+ depends = nss
+ depends = alsa-lib
+ depends = xdg-utils
+ depends = bzip2
+ depends = libevent
+ depends = libxss
+ depends = icu
+ depends = libexif
+ depends = libgcrypt
+ depends = ttf-font
+ depends = systemd
+ depends = dbus
+ depends = flac
+ depends = snappy
+ depends = speech-dispatcher
+ depends = pciutils
+ depends = libpulse
+ depends = harfbuzz
+ depends = libsecret
+ depends = perl
+ depends = perl-file-basedir
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ optdepends = kdebase-kdialog: needed for file dialogs in KDE
+ optdepends = gnome-keyring: for storing passwords in GNOME keyring
+ optdepends = kdeutils-kwalletmanager: for storing passwords in KWallet
+ optdepends = chromium-pepper-flash-dev: for Pepper Flash plugin [AUR]
+ optdepends = google-chrome-dev: for Pepper Flash plugin [AUR]
+ provides = chromium
+ source = chromium-snapshot-bin
+ source = chromium-snapshot-bin.desktop
+ source = LICENSE
+ md5sums = 1ac561e11601b7229942bede39fcfb54
+ md5sums = 793b3dca6ae19d15a830e7de7e1f6fd3
+ md5sums = 537e0b52077bf0a616d0a0c8a79bc9d5
+ source_i686 = chrome-linux-r334344.zip::http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux/334344/chrome-linux.zip
+ md5sums_i686 = SKIP
+ source_x86_64 = chrome-linux-r334344.zip::http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux_x64/334344/chrome-linux.zip
+ md5sums_x86_64 = SKIP
+
+pkgname = chromium-snapshot-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..972bb2edb099
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+// Copyright 2014 The Chromium Authors. All rights reserved.
+//
+// Redistribution and use in source and binary forms, with or without
+// modification, are permitted provided that the following conditions are
+// met:
+//
+// * Redistributions of source code must retain the above copyright
+// notice, this list of conditions and the following disclaimer.
+// * Redistributions in binary form must reproduce the above
+// copyright notice, this list of conditions and the following disclaimer
+// in the documentation and/or other materials provided with the
+// distribution.
+// * Neither the name of Google Inc. nor the names of its
+// contributors may be used to endorse or promote products derived from
+// this software without specific prior written permission.
+//
+// THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+// "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+// LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+// A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+// OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+// SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+// LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+// DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+// THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+// (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+// OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68af5f4eb64a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer: Det
+# Contributors: Ner0, alexwizard, thotypous, jdhore, xduugu, randypenguin, bdheeman, AlK
+
+pkgname=chromium-snapshot-bin
+pkgver=45.0.2432.0.r334343
+pkgrel=1
+pkgdesc="The open-source project behind Google Chrome (Snapshot builds)"
+arch=('i686' 'x86_64')
+url="https://build.chromium.org"
+license=('BSD')
+depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss' 'icu'
+ 'libexif' 'libgcrypt' 'ttf-font' 'systemd' 'dbus' 'flac' 'snappy'
+ 'speech-dispatcher' 'pciutils' 'libpulse' 'harfbuzz' 'libsecret'
+ 'perl' 'perl-file-basedir' 'desktop-file-utils' 'hicolor-icon-theme')
+optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
+ 'gnome-keyring: for storing passwords in GNOME keyring'
+ 'kdeutils-kwalletmanager: for storing passwords in KWallet'
+ 'chromium-pepper-flash-dev: for Pepper Flash plugin [AUR]'
+ 'google-chrome-dev: for Pepper Flash plugin [AUR]')
+provides=('chromium')
+install=$pkgname.install
+source=('chromium-snapshot-bin'
+ 'chromium-snapshot-bin.desktop'
+ 'LICENSE')
+md5sums=('1ac561e11601b7229942bede39fcfb54'
+ '793b3dca6ae19d15a830e7de7e1f6fd3'
+ '537e0b52077bf0a616d0a0c8a79bc9d5')
+
+[[ $CARCH = x86_64 ]] && _64="_x64"
+_build=$(curl -s "http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux$_64/LAST_CHANGE")
+source_i686=("chrome-linux-r$_build.zip::http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux/$_build/chrome-linux.zip")
+source_x86_64=("chrome-linux-r$_build.zip::http://commondatastorage.googleapis.com/chromium-browser-snapshots/Linux_x64/$_build/chrome-linux.zip")
+md5sums_i686=('SKIP')
+md5sums_x86_64=('SKIP')
+
+pkgver() {
+ echo $(chrome-linux/chrome --version | cut -d " " -f2).r$_build
+}
+
+package() {
+ msg2 "Creating directory structure..."
+ install -d "$pkgdir"/opt/
+ install -d "$pkgdir"/usr/bin/
+ install -d "$pkgdir"/usr/share/applications/
+ install -d "$pkgdir"/usr/share/licenses/chromium-snapshot/
+ install -d "$pkgdir"/usr/share/man/man1/
+ install -d "$pkgdir"/usr/share/pixmaps/
+
+ msg2 "Making it nice..."
+ # Permissions
+ find -type d -exec chmod 755 {} ';'
+ find -type f -exec chmod +r {} ';'
+ cd chrome-linux
+ chmod 755 chrome chrome-wrapper nacl_* xdg-*
+ chmod 4755 chrome_sandbox
+ cd ..
+
+ msg2 "Moving contents..."
+ # Main script
+ install -m755 chromium-snapshot-bin "$pkgdir"/usr/bin/
+
+ # Rename chrome-sandbox
+ mv chrome-linux/chrome{_,-}sandbox
+
+ # Desktop
+ install -m644 chromium-snapshot-bin.desktop "$pkgdir"/usr/share/applications/
+
+ # Icon
+ mv chrome-linux/product_logo_48.png "$pkgdir"/usr/share/pixmaps/chromium-snapshot-bin.png
+
+ # Man page
+ gzip -9 chrome-linux/chrome.1
+ mv chrome-linux/chrome.1.gz "$pkgdir"/usr/share/man/man1/chromium-snapshot-bin.1.gz
+
+ # License
+ install -m644 LICENSE "$pkgdir"/usr/share/licenses/chromium-snapshot/
+
+ msg2 "Installing main directory..."
+ mv chrome-linux/ "$pkgdir"/opt/chromium-snapshot
+}
diff --git a/chromium-snapshot-bin b/chromium-snapshot-bin
new file mode 100644
index 000000000000..98b0dd95c816
--- /dev/null
+++ b/chromium-snapshot-bin
@@ -0,0 +1,23 @@
+#!/bin/bash
+
+# Allow users to override command-line options
+if [[ -f ~/.config/chromium-flags.conf ]]; then
+ CHROMIUM_USER_FLAGS="$(cat ~/.config/chromium-flags.conf)"
+fi
+
+# Detect Pepper Flash
+for i in '/opt/google/chrome-unstable' '/usr/lib'; do
+ if [[ -f $i/PepperFlash/libpepflashplayer.so ]]; then
+ PepperFlash="$i/PepperFlash/libpepflashplayer.so"
+ PepperFlashVersion="$(grep 'version' $i/PepperFlash/manifest.json | cut -d '"' -f4)"
+
+ CHROMIUM_USER_FLAGS+=" --ppapi-flash-path=$PepperFlash --ppapi-flash-version=$PepperFlashVersion"
+ continue
+ fi
+done
+
+export CHROME_WRAPPER=$(readlink -f "$0")
+export CHROME_DESKTOP="chromium-snapshot-bin.desktop"
+
+# Launch
+exec /opt/chromium-snapshot/chrome $CHROMIUM_USER_FLAGS "$@" \ No newline at end of file
diff --git a/chromium-snapshot-bin.desktop b/chromium-snapshot-bin.desktop
new file mode 100644
index 000000000000..f17109ef71ad
--- /dev/null
+++ b/chromium-snapshot-bin.desktop
@@ -0,0 +1,113 @@
+[Desktop Entry]
+Version=1.0
+Name=Chromium Snapshot
+# Only KDE 4 seems to use GenericName, so we reuse the KDE strings.
+# From Ubuntu's language-pack-kde-XX-base packages, version 9.04-20090413.
+GenericName=Web Browser
+GenericName[ar]=متصفح الشبكة
+GenericName[bg]=Уеб браузър
+GenericName[ca]=Navegador web
+GenericName[cs]=WWW prohlížeč
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής ιστού
+GenericName[en_GB]=Web Browser
+GenericName[es]=Navegador web
+GenericName[et]=Veebibrauser
+GenericName[fi]=WWW-selain
+GenericName[fr]=Navigateur Web
+GenericName[gu]=વેબ બ્રાઉઝર
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hu]=Webböngésző
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[kn]=ಜಾಲ ವೀಕ್ಷಕ
+GenericName[ko]=웹 브라우저
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Tīmekļa pārlūks
+GenericName[ml]=വെബ് ബ്രൌസര്‍
+GenericName[mr]=वेब ब्राऊजर
+GenericName[nb]=Nettleser
+GenericName[nl]=Webbrowser
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador da Internet
+GenericName[ro]=Navigator de Internet
+GenericName[ru]=Веб-браузер
+GenericName[sl]=Spletni brskalnik
+GenericName[sv]=Webbläsare
+GenericName[ta]=இணைய உலாவி
+GenericName[th]=เว็บเบราว์เซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_HK]=網頁瀏覽器
+GenericName[zh_TW]=網頁瀏覽器
+# Not translated in KDE, from Epiphany 2.26.1-0ubuntu1.
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[fil]=Web Browser
+GenericName[hr]=Web preglednik
+GenericName[id]=Browser Web
+GenericName[or]=ଓ୍ବେବ ବ୍ରାଉଜର
+GenericName[sk]=WWW prehliadač
+GenericName[sr]=Интернет прегледник
+GenericName[te]=మహాతల అన్వేషి
+GenericName[vi]=Bộ duyệt Web
+# Gnome and KDE 3 uses Comment.
+Comment=Access the Internet
+Comment[ar]=الدخول إلى الإنترنت
+Comment[bg]=Достъп до интернет
+Comment[bn]=ইন্টারনেটটি অ্যাক্সেস করুন
+Comment[ca]=Accedeix a Internet
+Comment[cs]=Přístup k internetu
+Comment[da]=Få adgang til internettet
+Comment[de]=Internetzugriff
+Comment[el]=Πρόσβαση στο Διαδίκτυο
+Comment[en_GB]=Access the Internet
+Comment[es]=Accede a Internet.
+Comment[et]=Pääs Internetti
+Comment[fi]=Käytä internetiä
+Comment[fil]=I-access ang Internet
+Comment[fr]=Accéder à Internet
+Comment[gu]=ઇંટરનેટ ઍક્સેસ કરો
+Comment[he]=גישה אל האינטרנט
+Comment[hi]=इंटरनेट तक पहुंच स्थापित करें
+Comment[hr]=Pristup Internetu
+Comment[hu]=Internetelérés
+Comment[id]=Akses Internet
+Comment[it]=Accesso a Internet
+Comment[ja]=インターネットにアクセス
+Comment[kn]=ಇಂಟರ್ನೆಟ್ ಅನ್ನು ಪ್ರವೇಶಿಸಿ
+Comment[ko]=인터넷 연결
+Comment[lt]=Interneto prieiga
+Comment[lv]=Piekļūt internetam
+Comment[ml]=ഇന്റര്‍‌നെറ്റ് ആക്‌സസ് ചെയ്യുക
+Comment[mr]=इंटरनेटमध्ये प्रवेश करा
+Comment[nb]=Gå til Internett
+Comment[nl]=Verbinding maken met internet
+Comment[or]=ଇଣ୍ଟର୍ନେଟ୍ ପ୍ରବେଶ କରନ୍ତୁ
+Comment[pl]=Skorzystaj z internetu
+Comment[pt]=Aceder à Internet
+Comment[pt_BR]=Acessar a internet
+Comment[ro]=Accesaţi Internetul
+Comment[ru]=Доступ в Интернет
+Comment[sk]=Prístup do siete Internet
+Comment[sl]=Dostop do interneta
+Comment[sr]=Приступите Интернету
+Comment[sv]=Gå ut på Internet
+Comment[ta]=இணையத்தை அணுகுதல்
+Comment[te]=ఇంటర్నెట్‌ను ఆక్సెస్ చెయ్యండి
+Comment[th]=เข้าถึงอินเทอร์เน็ต
+Comment[tr]=İnternet'e erişin
+Comment[uk]=Доступ до Інтернету
+Comment[vi]=Truy cập Internet
+Comment[zh_CN]=访问互联网
+Comment[zh_HK]=連線到網際網路
+Comment[zh_TW]=連線到網際網路
+Exec=chromium-snapshot-bin %U
+Terminal=false
+Icon=chromium-snapshot-bin
+Type=Application
+Categories=GTK;Network;WebBrowser;
+MimeType=text/html;text/xml;application/xhtml+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
diff --git a/chromium-snapshot-bin.install b/chromium-snapshot-bin.install
new file mode 100644
index 000000000000..649d19de1eb7
--- /dev/null
+++ b/chromium-snapshot-bin.install
@@ -0,0 +1,46 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}::${bold} ${1}${all_off}\n"
+}
+
+note() {
+ printf "${yellow}::${bold} ${1}${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating icon cache.."
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+}
+
+post_install() {
+ _update
+ echo
+
+ note "Custom flags should be put directly in: ~/.config/chromium-flags.conf
+ Setting CHROMIUM_FLAGS in /etc is deprecated."
+ echo
+
+ note "Pepper Flash is now auto-detected from:
+ - /usr/lib/PepperFlash (chromium-pepper-flash-dev)
+ - /opt/google/chrome-unstable/PepperFlash (google-chrome-dev)"
+ echo
+
+ note "The launcher is called: 'chromium-snapshot-bin'"
+}
+
+
+post_upgrade() {
+ post_install
+}
+
+
+post_remove() {
+ _update
+}