summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..473623c2ae7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue Jun 23 10:02:57 UTC 2020
+pkgbase = chromium-unpaywall-git
+ pkgdesc = Chromium extension to find free journal articles
+ pkgver = 264.ea5587a
+ pkgrel = 1
+ url = https://github.com/ourresearch/unpaywall
+ arch = any
+ license = MIT
+ makedepends = git
+ source = git+https://github.com/ourresearch/unpaywall.git
+ sha512sums = SKIP
+
+pkgname = chromium-unpaywall-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..20aded0ec39e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/PKGBUILD-namcap.log
+/unpaywall/
+/chromium-unpaywall-git-*.log
+/chromium-unpaywall-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..217a0e70353d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Yardena Cohen <yardenack at gmail dot com>
+
+gitname=unpaywall
+pkgname=chromium-${gitname}-git
+pkgver=264.ea5587a
+pkgrel=1
+pkgdesc="Chromium extension to find free journal articles"
+arch=('any')
+url="https://github.com/ourresearch/${gitname}"
+license=('MIT')
+makedepends=(git)
+source=("git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${gitname}"
+ local ver="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ printf "%s" "${ver//-/.}"
+}
+package() {
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ shopt -u dotglob
+ cp -dr --no-preserve=ownership "${srcdir}/${gitname}"/extension/* "${pkgdir}/usr/share/${pkgname}/"
+}