summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bbff592916b..b79fe8a69eb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = chronoengine
pkgdesc = C++ library for physics simulation
- pkgver = 3.0.0
- pkgrel = 3
- url = http://projectchrono.org/chronoengine/
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://projectchrono.org/
arch = i686
arch = x86_64
license = custom
@@ -29,7 +29,7 @@ pkgbase = chronoengine
optdepends = python: Python bindings
optdepends = nvidia-utils: CUDA support in PARALLEL module
optdepends = opencascade: add 3D CAD file support (STEP format)
- source = chronoengine::git+https://github.com/projectchrono/chrono.git
+ source = chronoengine::git+https://github.com/projectchrono/chrono.git#tag=4.0.0
source = git+https://github.com/google/benchmark.git
source = git+https://github.com/google/googletest.git
source = chronoengine.sh
diff --git a/PKGBUILD b/PKGBUILD
index 26d957535488..5dde499a0021 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=chronoengine
-pkgver=3.0.0
-#fragment="#tag=${pkgver}"
-pkgrel=3
+pkgver=4.0.0
+_fragment="#tag=${pkgver}"
+pkgrel=1
pkgdesc="C++ library for physics simulation"
license=('custom')
arch=('i686' 'x86_64')
-url="http://projectchrono.org/chronoengine/"
+url="https://projectchrono.org/"
depends=(openmpi boost-libs)
makedepends=(cmake git boost glm glew glfw irrlicht glut openmpi)
makedepends+=(python swig) # -DENABLE_MODULE_PYTHON requirement
@@ -30,7 +30,7 @@ optdepends=(
#CXXFLAGS="-O2 -pipe -fstack-protector-strong"
#CFLAGS=${CXXFLAGS}
-source=("${pkgname}::git+https://github.com/projectchrono/chrono.git${fragment}"
+source=("${pkgname}::git+https://github.com/projectchrono/chrono.git${_fragment}"
"git+https://github.com/google/benchmark.git"
"git+https://github.com/google/googletest.git"
"chronoengine.sh"
@@ -78,7 +78,7 @@ prepare() {
sed -i 's/lib64/lib/' ${files[@]}
sed -i 's|share/chrono/bin|bin/chronoengine|' CMakeLists.txt
git apply ${srcdir}/glm.patch
- git apply ${srcdir}/opencascade.patch
+# git apply ${srcdir}/opencascade.patch
}
build() {