summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 708753842501..b31b7c25c713 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Jan 7 18:13:26 UTC 2016
+# Thu Jan 7 18:53:23 UTC 2016
pkgbase = chronoengine
pkgdesc = C++ library for physics simulation
pkgver = 2.0.0
diff --git a/PKGBUILD b/PKGBUILD
index 782239dc015c..4e87feb059c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,17 +11,16 @@ source=("git+https://github.com/projectchrono/chrono.git#tag=${pkgver}")
sha1sums=('SKIP')
build() {
- cd chrono
+ cd chrono/src
mkdir -p build && pushd build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_DEMOS=OFF \
- -DBUILD_ADDITIONAL_TESTS=OFF \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
..
make
}
package() {
- cd chrono/build
+ cd chrono/src/build
make DESTDIR="$pkgdir" install
}