summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore22
-rw-r--r--PKGBUILD40
-rw-r--r--chronojump-git.install4
4 files changed, 49 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4a563ab1fd5..b78a4de498ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,20 @@
-# Generated by mksrcinfo v8
-# Mon Feb 13 20:47:18 UTC 2017
pkgbase = chronojump-git
pkgdesc = Measurement, management and statistics of sport short-time tests
- pkgver = 1.7.0.40.gd9f9425b
+ pkgver = 2.3.0.1009.g1fdf0e54f
pkgrel = 1
- url = http://chronojump.org/
+ url = https://chronojump.org/
install = chronojump-git.install
arch = x86_64
- arch = i686
- license = GPL
- makedepends = gtk-sharp-2
+ license = GPL2
makedepends = mono
makedepends = intltool
makedepends = git
- depends = gstreamer0.10-base
depends = python
- depends = gtk2
+ depends = gtk-sharp-3
provides = chronojump
conflicts = chronojump
options = !libtool
- source = git+https://git.gnome.org/browse/chronojump
+ source = git+https://gitlab.gnome.org/GNOME/chronojump.git
md5sums = SKIP
pkgname = chronojump-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ddfe915b4f92
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,22 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+!LICENSE
+!*.service
+!*.conf
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
index 9467ada2c0ec..a92008fe2b19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,46 +2,44 @@
_name=chronojump
pkgname=$_name-git
-pkgver=1.7.0.40.gd9f9425b
+pkgver=2.3.0.1009.g1fdf0e54f
pkgrel=1
pkgdesc="Measurement, management and statistics of sport short-time tests"
-arch=('x86_64' 'i686')
-url="http://chronojump.org/"
-license=('GPL')
-depends=('gstreamer0.10-base' 'python' 'gtk2')
-makedepends=('gtk-sharp-2' 'mono' 'intltool' 'git')
+arch=(x86_64)
+url="https://chronojump.org/"
+license=(GPL2)
+depends=(python gtk-sharp-3)
+makedepends=(mono intltool git)
provides=($_name)
conflicts=($_name)
options=(!libtool)
install=$pkgname.install
-source=("git+https://git.gnome.org/browse/$_name")
+source=("git+https://gitlab.gnome.org/GNOME/$_name.git")
md5sums=('SKIP')
pkgver() {
- cd "$_name"
- git describe --long | sed 's/-/./g'
+ cd "$_name"
+ git describe --long | sed 's/-/./g'
}
prepare() {
- cd "$_name"
- NOCONFIGURE=1 ./autogen.sh
- # fix path for mono 4.6.1.3-1
- sed -i 's|/mono/4.0/|/mono/4.5/|' configure
-
+ cd "$_name"
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "$_name"
- ./configure --prefix=/usr
- make
+ cd "$_name"
+ ./configure --prefix=/usr
+ make
}
+# https://gitlab.gnome.org/GNOME/chronojump/-/issues/637
check() {
- cd "$_name"
- make -k check || true
+ cd "$_name"
+ make -k check || true
}
package() {
- cd "$_name"
- make DESTDIR="$pkgdir" install
+ cd "$_name"
+ make DESTDIR="$pkgdir" install
}
diff --git a/chronojump-git.install b/chronojump-git.install
index 750416f0ce2e..142be4514ef5 100644
--- a/chronojump-git.install
+++ b/chronojump-git.install
@@ -1,5 +1,7 @@
post_install() {
- echo "NOTE: To run Chronojump with Chronopic as normal user make sure to add yourself into 'dialout' group"
+ echo "NOTE: In order to run Chronojump with Chronopic as normal user"
+ echo " make sure to add your user to the 'uucp' group"
+ echo ""
}
post_upgrade() {