summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61ea01de482b..1bc3cc6d1588 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = chugins-git
pkgdesc = Repository for ChuGins (to use with chuck)
- pkgver = 1.3.5.2.r86.g9ed524f
- pkgrel = 6
+ pkgver = chuck.1.5.2.1.r2.gebc3223
+ pkgrel = 2
url = https://github.com/ccrma/chugins
arch = i686
arch = x86_64
license = GPL
- makedepends = cpio
makedepends = git
depends = chuck
- source = chugins-git::git://github.com/ccrma/chugins.git
+ source = chugins-git::git+https://github.com/ccrma/chugins.git
sha256sums = SKIP
pkgname = chugins-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 95d7fd2a259d..dfcb64dafae5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: schaap137 <dojo86@gmail.com>
pkgname=chugins-git
-pkgver=1.3.5.2.r86.g9ed524f
-pkgrel=6
+pkgver=chuck.1.5.2.1.r2.gebc3223
+pkgrel=2
pkgdesc="Repository for ChuGins (to use with chuck)"
arch=('i686' 'x86_64')
url="https://github.com/ccrma/chugins"
license=('GPL')
depends=('chuck')
-makedepends=('cpio' 'git')
-source=("$pkgname"::"git://github.com/ccrma/chugins.git")
+makedepends=('git')
+source=("$pkgname"::"git+https://github.com/ccrma/chugins.git")
+#buildflags=('FLAGS="${FLAGS} -std=c++14"')
sha256sums=('SKIP')
pkgver() {
@@ -22,6 +23,8 @@ prepare() {
# Change JACK to PULSE if you use chuck-pulse, or comment out the next line if you use chuck-alsa
sed -e 's/__LINUX_ALSA__/__LINUX_JACK__/g' -i **/makefile.linux
sed -e 's/\/usr\/local\/lib/\/usr\/lib/g' -i **/makefile.linux makefile
+ # Temporary fix until this code becomes fully ISO C++17 compliant - with thanks to phaise
+ sed -i '71s/^/FLAGS+= -Wno-error=register/' Mesh2D/makefile
}
build() {
@@ -34,5 +37,5 @@ package() {
mkdir -p "$pkgdir"/usr/lib/chuck
install -Dm755 **/*.chug "$pkgdir"/usr/lib/chuck/
mkdir -p "$pkgdir"/usr/share/doc/chuck/examples/chugins
- find . -type f -regex '.*\.\(md\|wav\|ck\)' | cpio -p -d -v -u "$pkgdir"/usr/share/doc/chuck/examples/chugins/
+ while read -r file; do install -Dm644 "$file" "$pkgdir/usr/share/doc/chuck/examples/chugins/$file"; done < <(find . -type f -regex '.*\.\(md\|wav\|ck\)')
}