summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 35 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fc10e59ccd1..ff91df7cea49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = chwall-git
pkgdesc = A tiny wallpaper changer, written in python
- pkgver = v0.6.1.dev.667f992
+ pkgver = v0.7.1.dev.46b81a4
pkgrel = 1
url = https://git.umaneti.net/chwall/about/
arch = any
- license = custom:WTFPL
- makedepends = imagemagick
+ license = LicenseRef-WTFPL
makedepends = git
+ makedepends = imagemagick
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = gdk-pixbuf2
depends = gobject-introspection-runtime
depends = gtk3
@@ -18,15 +22,16 @@ pkgbase = chwall-git
depends = python-importlib-metadata
depends = python-lxml
depends = python-pillow
+ depends = python-pyxdg
depends = python-requests
- depends = python-setuptools
- depends = python-xdg
depends = python-yaml
+ optdepends = feh: to apply wallpaper on independant desktop manager
optdepends = imagemagick: to extract wallpaper size when using feh
+ optdepends = libappindicator-gtk3: to display a tray icon
optdepends = libnotify: to send notification when wallpaper change
- optdepends = feh: to apply wallpaper on independant desktop manager
optdepends = xorg-xrandr: to extract screen config when using feh
conflicts = chwall
+ options = !debug
source = git+https://git.umaneti.net/chwall/
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a91c8ab4722f..da0c0db08a96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=chwall-git
_gitname=chwall
-pkgver=v0.6.1.dev.667f992
+pkgver=v0.7.1.dev.46b81a4
pkgrel=1
pkgdesc="A tiny wallpaper changer, written in python"
arch=("any")
url="https://git.umaneti.net/chwall/about/"
-license=("custom:WTFPL")
+license=("LicenseRef-WTFPL")
depends=("gdk-pixbuf2" "gobject-introspection-runtime" "gtk3"
"hicolor-icon-theme" "procps-ng" "python" "python-cssselect"
"python-gobject" "python-importlib-metadata" "python-lxml"
- "python-pillow" "python-requests" "python-setuptools" "python-xdg"
- "python-yaml")
-makedepends=("imagemagick" "git")
-optdepends=('imagemagick: to extract wallpaper size when using feh'
- 'libnotify: to send notification when wallpaper change'
- 'feh: to apply wallpaper on independant desktop manager'
- 'xorg-xrandr: to extract screen config when using feh')
+ "python-pillow" "python-pyxdg" "python-requests" "python-yaml")
+makedepends=("git" "imagemagick" "python-build" "python-installer"
+ "python-setuptools" "python-wheel")
+optdepends=("feh: to apply wallpaper on independant desktop manager"
+ "imagemagick: to extract wallpaper size when using feh"
+ "libappindicator-gtk3: to display a tray icon"
+ "libnotify: to send notification when wallpaper change"
+ "xorg-xrandr: to extract screen config when using feh")
conflicts=("chwall")
source=("git+https://git.umaneti.net/${_gitname}/")
-md5sums=('SKIP')
+md5sums=("SKIP")
+options=(!debug)
prepare() {
- cd "$srcdir/${_gitname}"
+ cd "${_gitname}"
# Determine which is the last branch
devbranch=$(git branch --sort=-committerdate --format "%(refname:short)" --list --remotes "origin/v*-dev" | head -n1)
@@ -30,15 +32,22 @@ prepare() {
}
pkgver() {
- cd "$srcdir/${_gitname}"
+ cd "${_gitname}"
hash=$(git show --format="%h" -s)
- branch=$(git branch --show-current | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
+ branch=$(git branch --show-current | sed "s/\([^-]*-g\)/r\1/;s/-/./g")
echo "$branch.$hash"
}
+check() {
+ cd "${_gitname}"
+ make test
+}
+
package() {
- cd "$srcdir/${_gitname}"
+ cd "${_gitname}"
+ make package DESTDIR="$pkgdir" CHWALL_NATIVE_PATH=yes
- make dist DESTDIR="$pkgdir"
+ cd "$pkgdir/usr/share/licenses"
+ mv chwall chwall-git
}