summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--RELEASE_INFO.md8
4 files changed, 32 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb5f228e21d2..d6478456b325 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,14 @@
pkgbase = chwp-git
pkgdesc = Changes the background wallpaper and lockscreen from the command line.
- pkgver = 0.0.26
+ pkgver = 1.239.3
pkgrel = 1
- url = https://gitlab.com/rouvenhimmelstein/chwp
+ url = https://github.com/RouHim/chwp
arch = x86_64
- license = GPL3
- makedepends = git
- makedepends = cmake
- makedepends = qt5-base
- depends = xorg-xrandr
- depends = qt5-base
+ license = GPL-3.0-or-later
+ makedepends = cargo
provides = chwp
conflicts = chwp
- source = https://gitlab.com/rouvenhimmelstein/chwp/-/archive/0.0.26/chwp-0.0.26.tar.gz
+ source = chwp-1.239.3.tar.gz::https://static.crates.io/crates/chwp/chwp-1.239.3.crate
sha1sums = SKIP
pkgname = chwp-git
-
diff --git a/.gitignore b/.gitignore
index 723ef36f4e4f..3bb6dd0520a2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
-.idea \ No newline at end of file
+.idea
+*.tar.gz
+*.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 0c14261c31f8..010614c1e03e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,33 @@
# Maintainer: Rouven Himmelstein <rouvenhimmelstein@gmail.com>
-_gitname=chwp
-_cmdname=chwp
-pkgname=${_gitname}-git
-pkgver=0.0.26
+_pkgname=chwp
+pkgname=${_pkgname}-git
+pkgver=1.239.3
pkgrel=1
pkgdesc="Changes the background wallpaper and lockscreen from the command line."
arch=('x86_64')
-url="https://gitlab.com/rouvenhimmelstein/chwp"
-license=('GPL3')
-depends=('xorg-xrandr' 'qt5-base')
-makedepends=('git' 'cmake' 'qt5-base')
+url="https://github.com/RouHim/chwp"
+license=('GPL-3.0-or-later')
+makedepends=('cargo')
provides=('chwp')
conflicts=('chwp')
-source=("https://gitlab.com/rouvenhimmelstein/chwp/-/archive/${pkgver}/${_gitname}-${pkgver}.tar.gz")
+source=("$_pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$_pkgname/$_pkgname-$pkgver.crate")
sha1sums=('SKIP')
prepare() {
- mkdir -p $srcdir/$_gitname-${pkgver}/cmake-build-release
+ cd "$srcdir/$_pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
-
build() {
- cd $srcdir/$_gitname-${pkgver}/cmake-build-release
- cmake .. -DCMAKE_BUILD_TYPE=Release
- make
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
}
package() {
- cd $srcdir/$_gitname-${pkgver}/cmake-build-release
- make DESTDIR="$pkgdir" install
-
- cd ${srcdir}/${_gitname}-${pkgver}
- install -D -m755 ${_cmdname}.1 ${pkgdir}/usr/share/man/man1/${_cmdname}.1
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$_pkgname"
} \ No newline at end of file
diff --git a/RELEASE_INFO.md b/RELEASE_INFO.md
new file mode 100644
index 000000000000..d539468c0aaf
--- /dev/null
+++ b/RELEASE_INFO.md
@@ -0,0 +1,8 @@
+# How to release
+
+1. Push something to the main branch.
+2. The CI/CD pipe will trigger and release a new version on crates.io.
+3. publish the version to aur.
+4. Test installation of package with: `makepkg --clean --cleanbuild --install --force`
+6. Generate `.SRCINFO` with `./generate-srcinfo.sh`
+7. Commit changes & push to AUR Repository \ No newline at end of file