summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--Cider.desktop11
-rw-r--r--PKGBUILD14
-rw-r--r--cider.desktop10
4 files changed, 23 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff7e32e4bba6..8ca306deb6c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cider
- pkgdesc = Project Cider. A new look into listening and enjoying music in style and performance. Built from the ground up with vue.js and electron. Compiled from the GitHub repositories main branch.
- pkgver = 1.1.0.1841.2a9622fa
+ pkgdesc = Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories develop branch.
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/CiderApp/Cider.git
arch = armv7h
@@ -12,10 +12,10 @@ pkgbase = cider
makedepends = yarn
depends = gtk3
depends = nss
- optdepends = libnotify: Playback notifications
- source = git+https://github.com/CiderApp/Cider.git
- source = Cider.desktop
+ optdepends = libno1tify: Playback notifications
+ source = git+https://github.com/CiderApp/Cider.git#branch=develop
+ source = cider.desktop
sha256sums = SKIP
- sha256sums = 8a8d3aebe1b415fd71d49db1e6d4cfd5470c69c8999ccda20d38b531d0583507
+ sha256sums = c41e9b1019411019fce8509e32f770edf33c9e864bf707c30ffe2e3f2dcf1571
pkgname = cider
diff --git a/Cider.desktop b/Cider.desktop
deleted file mode 100644
index 05bc6c609123..000000000000
--- a/Cider.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Name=Cider
-Exec="/opt/cider/cider" %U
-Terminal=False
-Type=Application
-Icon=cider
-StartupWMClass=Cider
-Encoding=UTF-8
-Comment=Project Cider. A new look into listening and enjoying music in style and performance.
-MimeType=x-scheme-handler/ame;x-scheme-handler/itms;x-scheme-handler/itmss;x-scheme-handler/musics;x-scheme-handler/music;x-scheme-handler/cider;
-Categories=AudioVideo;
diff --git a/PKGBUILD b/PKGBUILD
index f721fdd13046..aa926458aba4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=cider
_pkgname=Cider
-pkgver=1.1.0.1841.2a9622fa
+pkgver=1.4.0.2852.1dcd5ec4
pkgrel=1
-pkgdesc="Project Cider. A new look into listening and enjoying music in style and performance. Built from the ground up with vue.js and electron. Compiled from the GitHub repositories main branch."
+pkgdesc="Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories develop branch."
arch=("armv7h" "i686" "x86_64")
url="https://github.com/CiderApp/${_pkgname}.git"
license=("GPL")
depends=('gtk3' 'nss')
makedepends=('git' 'npm' 'yarn')
-optdepends=('libnotify: Playback notifications')
+optdepends=('libno1tify: Playback notifications')
source=(
"git+https://github.com/CiderApp/${_pkgname}.git"
- "Cider.desktop"
+ "cider.desktop"
)
sha256sums=('SKIP'
- '8a8d3aebe1b415fd71d49db1e6d4cfd5470c69c8999ccda20d38b531d0583507')
+ 'c41e9b1019411019fce8509e32f770edf33c9e864bf707c30ffe2e3f2dcf1571')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -49,11 +49,11 @@ package() {
cd "${srcdir}/${_pkgname}"
echo "Packaging : [Desktop Shortcut] | Icon | Build Files | Other Files | Done"
- install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname%-git}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-git}.desktop"
+
echo "Packaging : Desktop Shortcut | [Icon] | Build Files | Other Files | Done"
install -Dm644 "${srcdir}/${_pkgname}/resources/icons/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname%-git}.png"
-
echo "Packaging : Desktop Shortcut | Icon | [Build Files] | Other Files | Done"
install -d "$pkgdir/opt/"
install -d "$pkgdir/usr/bin/"
diff --git a/cider.desktop b/cider.desktop
new file mode 100644
index 000000000000..cdd8d7c57594
--- /dev/null
+++ b/cider.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Cider
+StartupWMClass=Cider
+Comment=Project Cider. A new look into listening and enjoying music in style and performance.
+GenericName=Music Player
+Exec=/usr/bin/cider %U
+Icon=cider
+Type=Application
+Categories=Audio;Music;Player;AudioVideo;Network;
+MimeType=x-scheme-handler/ame;x-scheme-handler/cider;x-scheme-handler/itms;x-scheme-handler/itmss;x-scheme-handler/musics;x-scheme-handler/music;