summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
-rw-r--r--cinelerra_4.6.patch45
-rw-r--r--gpac.patch12
-rw-r--r--libavcodec.patch11
-rw-r--r--plugin_dir.patch32
-rw-r--r--quicktime.patch25
-rw-r--r--texi2html.patch11
8 files changed, 13 insertions, 183 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cb21844a77f..87318bd6c6f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cinelerra-heroine
pkgdesc = Cinelerra from the HeroineWarrior.com (64-bit)
- pkgver = 4.6
- pkgrel = 2
+ pkgver = 7.2
+ pkgrel = 1
url = http://www.heroinewarrior.com/cinelerra.php
arch = x86_64
license = GPL
@@ -18,22 +18,10 @@ pkgbase = cinelerra-heroine
depends = freetype2
depends = alsa-lib
conflicts = cinelerra-cv
- source = https://sourceforge.net/projects/heroines/files/cinelerra-4.6.src.tar.xz
- source = quicktime.patch
- source = plugin_dir.patch
- source = texi2html.patch
- source = gpac.patch
- source = libavcodec.patch
- source = cinelerra_4.6.patch
+ source = https://netcologne.dl.sourceforge.net/project/heroines/cinelerra-7.2-src.tar.xz
source = cinelerra.desktop
- md5sums = 3da60ce525abc278a028c8889d5b9fd6
- md5sums = 0babae23875017653914bd121477ec97
- md5sums = cf9861e808948fe8ea4d4be27765ffa5
- md5sums = 431503db853032e14ade0438ed3eea29
- md5sums = cefa6a8efe5ba5bc00ad9fc5649dd25c
- md5sums = 4dd7fd1184dfe3813a8821d47ef70a55
- md5sums = 3e84af8442b5a3d426ed64f29be71cbf
- md5sums = 54ee50b75e5318509da5d4e8fa55caf3
+ sha512sums = da422379e738bb9c9019bb95fbe4d3cf2f2df995e4d42bd1ef958a79b5013bbdb5c9f50f64e1091d2990215c514e4d28c30f50f65b94bb01a69f6a3e78c02dc7
+ sha512sums = 111cd582cc8d165a6888f66b7de4286058e8037ed9b5dbcbffc4ad6ab283df15203325a2ba5096112e583cc03b56f38b604e7a070113a5deb3762af8f382ff94
pkgname = cinelerra-heroine
diff --git a/PKGBUILD b/PKGBUILD
index adeb944fc6bd..1b7106aaf0d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Garrett <floft.net/contact>
pkgname=cinelerra-heroine
-pkgver=4.6
-pkgrel=2
+pkgver=7.2
+pkgrel=1
pkgdesc="Cinelerra from the HeroineWarrior.com (64-bit)"
arch=('x86_64')
url="http://www.heroinewarrior.com/cinelerra.php"
@@ -10,42 +10,20 @@ depends=('libpng' 'freeglut' 'libxv' 'ncurses' 'libva'
'openexr' 'libxft' 'freetype2' 'alsa-lib')
makedepends=('yasm' 'nasm' 'libtool')
conflicts=('cinelerra-cv')
-source=(https://sourceforge.net/projects/heroines/files/cinelerra-$pkgver.src.tar.xz
- quicktime.patch
- plugin_dir.patch
- texi2html.patch
- gpac.patch
- libavcodec.patch
- cinelerra_4.6.patch
+source=(https://netcologne.dl.sourceforge.net/project/heroines/cinelerra-${pkgver}-src.tar.xz
cinelerra.desktop)
-md5sums=('3da60ce525abc278a028c8889d5b9fd6'
- '0babae23875017653914bd121477ec97'
- 'cf9861e808948fe8ea4d4be27765ffa5'
- '431503db853032e14ade0438ed3eea29'
- 'cefa6a8efe5ba5bc00ad9fc5649dd25c'
- '4dd7fd1184dfe3813a8821d47ef70a55'
- '3e84af8442b5a3d426ed64f29be71cbf'
- '54ee50b75e5318509da5d4e8fa55caf3')
+sha512sums=('da422379e738bb9c9019bb95fbe4d3cf2f2df995e4d42bd1ef958a79b5013bbdb5c9f50f64e1091d2990215c514e4d28c30f50f65b94bb01a69f6a3e78c02dc7'
+ '111cd582cc8d165a6888f66b7de4286058e8037ed9b5dbcbffc4ad6ab283df15203325a2ba5096112e583cc03b56f38b604e7a070113a5deb3762af8f382ff94')
prepare() {
- cd "$srcdir/cinelerra-$pkgver-src"
+ cd "$srcdir/cinelerra-$pkgver"
# Use ncurses instead of termcap
sed -i 's/ltermcap/lncurses/g' ./thirdparty/speech_tools/{configure{,.in},config/config}
-
- # fixes to make it compile
- patch -Np1 -i "$srcdir/quicktime.patch"
- patch -Np1 -i "$srcdir/texi2html.patch"
- patch -Np1 -i "$srcdir/gpac.patch"
- patch -Np1 -i "$srcdir/libavcodec.patch"
- patch -Np1 -i "$srcdir/cinelerra_4.6.patch"
-
- # fix problems with Cinelerra_plugins in read-only directories
- patch -Np1 -i "$srcdir/plugin_dir.patch"
}
build() {
- cd "$srcdir/cinelerra-$pkgver-src"
+ cd "$srcdir/cinelerra-$pkgver"
./configure
@@ -57,7 +35,7 @@ build() {
}
package() {
- cd "$srcdir/cinelerra-$pkgver-src"
+ cd "$srcdir/cinelerra-$pkgver"
# makes repackaging work
[ ! -e "bin/cinelerra" ] && \
diff --git a/cinelerra_4.6.patch b/cinelerra_4.6.patch
deleted file mode 100644
index 99c13d62017f..000000000000
--- a/cinelerra_4.6.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -ru cinelerra-4.6-src/cinelerra/filejpeg.C cinelerra-4.6-src.new/cinelerra/filejpeg.C
---- cinelerra-4.6-src/cinelerra/filejpeg.C 2014-09-01 21:18:54.000000000 -0700
-+++ cinelerra-4.6-src.new/cinelerra/filejpeg.C 2014-09-15 09:47:05.087692323 -0700
-@@ -33,6 +33,7 @@
- #include "videodevice.inc"
-
-
-+#include <string.h>
- #include <errno.h>
-
-
-diff -ru cinelerra-4.6-src/cinelerra/filemov.C cinelerra-4.6-src.new/cinelerra/filemov.C
---- cinelerra-4.6-src/cinelerra/filemov.C 2014-09-01 21:18:54.000000000 -0700
-+++ cinelerra-4.6-src.new/cinelerra/filemov.C 2014-09-15 09:48:06.208668661 -0700
-@@ -36,6 +36,8 @@
- #include "videodevice.inc"
-
- #include <unistd.h>
-+#include <string.h>
-+#include <strings.h>
-
- #if 0
- N_("MPEG-4")
-diff -ru cinelerra-4.6-src/cinelerra/filepng.C cinelerra-4.6-src.new/cinelerra/filepng.C
---- cinelerra-4.6-src/cinelerra/filepng.C 2014-09-01 21:18:54.000000000 -0700
-+++ cinelerra-4.6-src.new/cinelerra/filepng.C 2014-09-15 09:41:24.460835813 -0700
-@@ -29,6 +29,7 @@
- #include "vframe.h"
- #include "videodevice.inc"
-
-+#include <string.h>
- #include <png.h>
-
- FilePNG::FilePNG(Asset *asset, File *file)
-diff -ru cinelerra-4.6-src/cinelerra/videodevice.C cinelerra-4.6-src.new/cinelerra/videodevice.C
---- cinelerra-4.6-src/cinelerra/videodevice.C 2014-09-01 21:18:54.000000000 -0700
-+++ cinelerra-4.6-src.new/cinelerra/videodevice.C 2014-09-15 09:53:27.356291064 -0700
-@@ -50,6 +50,7 @@
-
- #include <unistd.h>
- #include <fcntl.h>
-+#include <string.h>
-
- KeepaliveThread::KeepaliveThread(VideoDevice *device)
- : Thread()
diff --git a/gpac.patch b/gpac.patch
deleted file mode 100644
index b39dbfeaaa9a..000000000000
--- a/gpac.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru cinelerra-4.4.orig/quicktime/thirdparty/x264.052906/configure cinelerra-4.4/quicktime/thirdparty/x264.052906/configure
---- cinelerra-4.4.orig/quicktime/thirdparty/x264.052906/configure 2013-01-02 15:42:12.870084505 -0800
-+++ cinelerra-4.4/quicktime/thirdparty/x264.052906/configure 2013-01-02 15:43:59.639182303 -0800
-@@ -290,7 +290,7 @@
- esac
- fi
-
--MP4_LDFLAGS="-lgpac_static"
-+MP4_LDFLAGS="-lgpac_static -lz"
- if [ $SYS = CYGWIN -o $SYS = MINGW ]; then
- MP4_LDFLAGS="$MP4_LDFLAGS -lwinmm"
- fi
diff --git a/libavcodec.patch b/libavcodec.patch
deleted file mode 100644
index d7f8e0c1fa90..000000000000
--- a/libavcodec.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur cinelerra-4.4/quicktime/thirdparty/ffmpeg-0.6.1/libavcodec/vaapi_mpeg4.c cinelerra-4.4new/quicktime/thirdparty/ffmpeg-0.6.1/libavcodec/vaapi_mpeg4.c
---- cinelerra-4.4/quicktime/thirdparty/ffmpeg-0.6.1/libavcodec/vaapi_mpeg4.c 2010-03-30 16:30:55.000000000 -0700
-+++ cinelerra-4.4new/quicktime/thirdparty/ffmpeg-0.6.1/libavcodec/vaapi_mpeg4.c 2013-06-18 09:02:32.953720213 -0700
-@@ -20,6 +20,7 @@
- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
- */
-
-+#include "h263.h"
- #include "vaapi_internal.h"
-
- /** Reconstruct bitstream intra_dc_vlc_thr */
diff --git a/plugin_dir.patch b/plugin_dir.patch
deleted file mode 100644
index 3157c91d2845..000000000000
--- a/plugin_dir.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -ur cinelerra-4.4.orig/cinelerra/mwindow.C cinelerra-4.4.new/cinelerra/mwindow.C
---- cinelerra-4.4.orig/cinelerra/mwindow.C 2012-09-09 15:56:45.003303505 -0700
-+++ cinelerra-4.4.new/cinelerra/mwindow.C 2012-09-09 18:15:33.360657582 -0700
-@@ -107,6 +107,7 @@
- #include "zoombar.h"
-
- #include <string.h>
-+#include <sys/stat.h>
-
-
-
-@@ -376,7 +377,7 @@
- char index_path[BCTEXTLEN];
- FILE *index_fd = 0;
-
-- sprintf(index_path, "%s/%s", path, PLUGIN_FILE);
-+ sprintf(index_path, "%s/%s", preferences->index_directory, PLUGIN_FILE);
- //printf("MWindow::init_plugin_path %d %s plugindb=%p\n", __LINE__, index_path, plugindb);
-
-
-@@ -401,8 +402,10 @@
- // Create plugin server from index entry
- PluginServer *new_plugin = new PluginServer(path);
- result = new_plugin->read_table(index_line);
-+ struct stat buffer;
-+ int exists = stat(new_plugin->path, &buffer);
- //printf("%p new_plugin=%p %s", result2, new_plugin, index_line);
-- if(!result)
-+ if(!result && !exists)
- {
- plugindb->append(new_plugin);
- }
diff --git a/quicktime.patch b/quicktime.patch
deleted file mode 100644
index 1dfe210a7eb7..000000000000
--- a/quicktime.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -ur cinelerra-4.4.orig/cinelerra/Makefile cinelerra-4.4/cinelerra/Makefile
---- cinelerra-4.4.orig/cinelerra/Makefile 2012-09-09 19:12:50.740569440 -0700
-+++ cinelerra-4.4/cinelerra/Makefile 2012-09-09 19:13:20.339370457 -0700
-@@ -396,7 +396,8 @@
- -lpng \
- -lz \
- -ldl \
-- -lbz2
-+ -lbz2 \
-+ -lva
-
- # -lXxf86vm \
-
-diff -ur cinelerra-4.4.orig/quicktime/thirdparty/faac-1.24/frontend/main.c cinelerra-4.4/quicktime/thirdparty/faac-1.24/frontend/main.c
---- cinelerra-4.4.orig/quicktime/thirdparty/faac-1.24/frontend/main.c 2012-09-09 19:12:51.407209104 -0700
-+++ cinelerra-4.4/quicktime/thirdparty/faac-1.24/frontend/main.c 2012-09-09 19:13:02.150107282 -0700
-@@ -30,7 +30,7 @@
- #endif
-
- #ifdef HAVE_LIBMP4V2
--# include <mp4.h>
-+# include <mp4v2/mp4v2.h>
- #endif
-
- #define DEFAULT_TNS 1
diff --git a/texi2html.patch b/texi2html.patch
deleted file mode 100644
index a5b87553b7c3..000000000000
--- a/texi2html.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- cinelerra-4.4.orig/quicktime/thirdparty/ffmpeg-0.6.1/Makefile 2013-01-02 15:17:54.625193189 -0800
-+++ cinelerra-4.4/quicktime/thirdparty/ffmpeg-0.6.1/Makefile 2013-01-02 15:18:31.860356486 -0800
-@@ -107,7 +107,7 @@
-
- doc/%.html: TAG = HTML
- doc/%.html: doc/%.texi
-- $(M)cd doc && texi2html -monolithic -number $(<:doc/%=%)
-+ $(M)cd doc && texi2html $(<:doc/%=%)
-
- doc/%.pod: TAG = POD
- doc/%.pod: doc/%-doc.texi