summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db66ebea30a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cinny-web-git
+ pkgdesc = Yet another matrix client — web version
+ pkgver = r254.5b0f95f
+ pkgrel = 1
+ url = https://github.com/ajbura/cinny
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ source = cinny-web::git+https://github.com/ajbura/cinny.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = cinny-web-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..603fffab3d22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Andy Bao <contact@andybao.me>
+_pkgname=cinny-web
+pkgname="${_pkgname}-git"
+pkgver=r254.5b0f95f
+pkgrel=1
+pkgdesc="Yet another matrix client — web version"
+arch=('any')
+url="https://github.com/ajbura/cinny"
+license=('MIT')
+makedepends=('git' 'npm')
+source=("${_pkgname}::git+https://github.com/ajbura/cinny.git#branch=dev")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ npm install
+ npm run build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -d "$pkgdir/usr/share/webapps/cinny"
+ cp -r dist/* "$pkgdir/usr/share/webapps/cinny"
+ chmod -R 0755 "$pkgdir/usr/share/webapps/cinny"
+}