summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f3e55adee4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = cirkuit
+ pkgdesc = Cirkuit is a KDE4 GUI for the Circuit macros by Dwight Aplevich, for drawing high-quality line diagrams to include in TeX, LaTeX, for similar documents.
+ pkgver = 0.4.3
+ pkgrel = 4
+ url = http://wwwu.uni-klu.ac.at/magostin/cirkuit.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = automoc4
+ depends = kdebase-runtime
+ depends = texlive-core
+ depends = m4
+ depends = ghostscript
+ depends = texlive-pstricks
+ depends = netpbm
+ depends = poppler-qt
+ optdepends = dpic: improved circuit macros support
+ optdepends = gnuplot: Gnuplot backend
+ source = http://wwwu.uni-klu.ac.at/magostin/src/cirkuit-0.4.3.tar.bz2
+ md5sums = dccdb6bdb6f1afb99cbebe4780f96b49
+
+pkgname = cirkuit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f0219d2b5da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
+
+pkgname=cirkuit
+pkgver=0.4.3
+pkgrel=4
+pkgdesc="Cirkuit is a KDE4 GUI for the Circuit macros by Dwight Aplevich, for drawing high-quality line diagrams to include in TeX, LaTeX, for similar documents."
+url="http://wwwu.uni-klu.ac.at/magostin/cirkuit.html"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('kdebase-runtime' 'texlive-core' 'm4' 'ghostscript' 'texlive-pstricks' 'netpbm' 'poppler-qt')
+makedepends=('cmake' 'automoc4')
+optdepends=('dpic: improved circuit macros support' 'gnuplot: Gnuplot backend')
+source=(http://wwwu.uni-klu.ac.at/magostin/src/$pkgname-$pkgver.tar.bz2)
+md5sums=('dccdb6bdb6f1afb99cbebe4780f96b49')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ rm -rf build
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DQT_QMAKE_EXECUTABLE=qmake4
+ make clean
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ make DESTDIR=${pkgdir} install
+ rm -rf ${pkgdir}/usr/share/apps/katepart/syntax/gnuplot.xml
+} \ No newline at end of file