summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68a7c42879ff..18d6c49354d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = citadel-git
pkgdesc = Manage your ebook library without frustrations. Calibre compatible.
- pkgver = r196.8cf1dd2
+ pkgver = r201.0ec173e
pkgrel = 1
url = https://github.com/every-day-things/citadel
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = citadel-git
makedepends = cargo
depends = webkit2gtk
depends = gtk3
+ optdepends = calibre: initialize ebook library
provides = citadel
conflicts = citadel
source = git+https://github.com/every-day-things/citadel
diff --git a/PKGBUILD b/PKGBUILD
index fcbe5193f357..1b3c972b83b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: AlphaJack <alphajack at tuta dot io>
pkgname="citadel-git"
-pkgver=r196.8cf1dd2
+pkgver=r201.0ec173e
pkgrel=1
pkgdesc="Manage your ebook library without frustrations. Calibre compatible."
url="https://github.com/every-day-things/citadel"
@@ -11,6 +11,7 @@ provides=("citadel")
conflicts=("citadel")
depends=("webkit2gtk" "gtk3")
makedepends=("bun" "cargo")
+optdepends=("calibre: initialize ebook library")
source=("git+$url")
b2sums=("SKIP")
@@ -19,21 +20,14 @@ pkgver(){
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pepare(){
- cd "${pkgname%-git}"
- # explicitely build a deb package https://tauri.app/v1/guides/building/linux/#prerequisites
- sed -i "src-tauri/tauri.conf.json" \
- -e 's|"targets": .*,|"targets": ["deb"],|'
-}
-
build(){
cd "${pkgname%-git}"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
# install dependencies, including tauri and vite
bun install
- # build front-end and back-end
- bun run build
+ # build front-end and back-end, limiting the targets to a .deb package
+ bun run build --bundles deb
}
package(){