summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5985bfeff163..f13ab259c13a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cjdns-git
pkgdesc = A routing engine designed for security, scalability, speed and ease of use
- pkgver = 21.1.r38.g20ddc268
+ pkgver = 22.r7.g2faa4c83
pkgrel = 1
url = https://github.com/cjdelisle/cjdns
arch = i686
@@ -9,9 +9,10 @@ pkgbase = cjdns-git
arch = armv6h
arch = armv7h
license = GPL3
+ makedepends = cargo
makedepends = git
makedepends = nodejs
- makedepends = python2
+ makedepends = python
makedepends = binutils
makedepends = llvm
depends = bash
@@ -22,8 +23,7 @@ pkgbase = cjdns-git
options = !distcc
options = !strip
options = !buildflags
- source = git+https://github.com/cjdelisle/cjdns#branch=crashey
+ source = git+https://github.com/cjdelisle/cjdns#branch=master
sha512sums = SKIP
pkgname = cjdns-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9e8beee9ad68..95b095947be3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: openfbt
# Contributor: Werecat
# Contributor: Xyne
_pkgname=cjdns
pkgname=$_pkgname-git
-pkgver=21.1.r38.g20ddc268
+pkgver=22.r7.g2faa4c83
pkgrel=1
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
@@ -13,7 +14,7 @@ license=('GPL3')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
options=('!distcc' '!strip' '!buildflags')
depends=('bash')
-makedepends=('git' 'nodejs' 'python2' 'binutils' 'llvm')
+makedepends=('cargo' 'git' 'nodejs' 'python' 'binutils' 'llvm')
optdepends=(
'cjdnsify: allows you to run some programs bound to your cjdns address'
@@ -22,7 +23,7 @@ optdepends=(
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+$url#branch=crashey")
+source=("git+$url#branch=master")
sha512sums=('SKIP')
pkgver() {
@@ -32,8 +33,7 @@ pkgver() {
build() {
cd $_pkgname
- bash 'do'
-
+ CJDNS_RELEASE_VERSION="${pkgver}" ./do
}
package() {