summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--build-fix.patch61
3 files changed, 5 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b78f2d3b299..6f423cdcaaf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 16 19:28:20 UTC 2017
+# Mon Jun 26 02:35:10 UTC 2017
pkgbase = cjdns-git
pkgdesc = A routing engine designed for security, scalability, speed and ease of use
- pkgver = 19.1.r121.g66b60035
+ pkgver = 20
pkgrel = 1
url = https://github.com/cjdelisle/cjdns
arch = i686
@@ -23,9 +23,7 @@ pkgbase = cjdns-git
options = !strip
options = !buildflags
source = git+https://github.com/cjdelisle/cjdns#branch=crashey
- source = build-fix.patch
sha512sums = SKIP
- sha512sums = f8effe23cde89aed048a796bc181fac0a5dc272132d819d91b7c777ec30e00cf7682e4f7e50413d6b2ecab366d5eb8925fb91f6b2ab063faebf5604004f3ec09
pkgname = cjdns-git
diff --git a/PKGBUILD b/PKGBUILD
index a52bdae67697..bbee925882bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=cjdns
pkgname=$_pkgname-git
-pkgver=19.1.r121.g66b60035
+pkgver=20
pkgrel=1
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
@@ -22,27 +22,14 @@ optdepends=(
provides=("$_pkgname")
conflicts=("$_pkgname")
-
-source=(
- "git+$url#branch=crashey"
- 'build-fix.patch'
-)
-
-sha512sums=(
- 'SKIP'
- 'f8effe23cde89aed048a796bc181fac0a5dc272132d819d91b7c777ec30e00cf7682e4f7e50413d6b2ecab366d5eb8925fb91f6b2ab063faebf5604004f3ec09'
-)
+source=("git+$url#branch=crashey")
+sha512sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --tags | sed 's|^[^-]*-v||;s|-|.r|;s|-|.|g'
}
-prepare() {
- cd $_pkgname
- patch -p1 < ../build-fix.patch
-}
-
build() {
cd $_pkgname
bash 'do'
diff --git a/build-fix.patch b/build-fix.patch
deleted file mode 100644
index a3be41614f40..000000000000
--- a/build-fix.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 00e32c6ec3044c32d1a3ec7eac3343dd360e143e Mon Sep 17 00:00:00 2001
-From: xulfer <xulfer at cheapbsd.net>
-Date: Fri, 16 Jun 2017 13:39:28 -0500
-Subject: [PATCH] Fixed some issues with newer GCC versions.
-
-A few new warnings popped up with newer GCC versions that
-prevented building due to -Werror. These should appear to be
-fixed for now, but may not be compatible with BSD versions so
-more testing may be required.
-
-diff --git a/benc/serialization/json/JsonBencSerializer.c b/benc/serialization/json/JsonBencSerializer.c
-index edc1f3d2..7d1690f6 100644
---- a/benc/serialization/json/JsonBencSerializer.c
-+++ b/benc/serialization/json/JsonBencSerializer.c
-@@ -72,15 +72,15 @@ static int32_t serializeString(struct Writer* writer,
- Writer_write(writer, "\"", 1);
- size_t i;
- uint8_t chr;
-- char buffer[4];
-+ char buffer[5];
- for (i = 0; i < string->len; i++) {
- chr = (uint8_t) string->bytes[i] & 0xFF;
- /* Nonprinting chars, \ and " are hex'd */
- if (chr < 126 && chr > 31 && chr != '\\' && chr != '"') {
-- snprintf(buffer, 4, "%c", chr);
-+ snprintf(buffer, 5, "%c", chr);
- Writer_write(writer, buffer, 1);
- } else {
-- snprintf(buffer, 4, "\\x%.2X", chr);
-+ snprintf(buffer, 5, "\\x%.2X", chr);
- Writer_write(writer, buffer, 4);
- }
- }
-diff --git a/dht/dhtcore/NodeStore.c b/dht/dhtcore/NodeStore.c
-index decab6c0..5199d865 100644
---- a/dht/dhtcore/NodeStore.c
-+++ b/dht/dhtcore/NodeStore.c
-@@ -1771,7 +1771,9 @@ struct NodeList* NodeStore_getPeers(uint64_t label,
- }
- switch (j) {
- default: Bits_memmove(out->nodes, &out->nodes[1], (j - 1) * sizeof(char*));
-+ __attribute__ ((fallthrough)); // C and C++03
- case 1: out->nodes[j - 1] = next->child;
-+ __attribute__ ((fallthrough)); // C and C++03
- case 0:;
- }
- }
-diff --git a/subnode/GetPeersResponder.c b/subnode/GetPeersResponder.c
-index 5110d0dd..a37fd38e 100644
---- a/subnode/GetPeersResponder.c
-+++ b/subnode/GetPeersResponder.c
-@@ -81,7 +81,9 @@ static void onGetPeers(Dict* msg,
- }
- switch (j) {
- default: Bits_memmove(ptrList, &ptrList[1], (j - 1) * sizeof(char*));
-+ __attribute__ ((fallthrough)); // C and C++03
- case 1: ptrList[j - 1] = peer;
-+ __attribute__ ((fallthrough)); // C and C++03
- case 0:;
- }
- }