summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch35
-rw-r--r--PKGBUILD13
3 files changed, 9 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76b028a7fe1c..83c6baa8f7a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ckb-next
pkgdesc = Corsair Keyboard and Mouse Input Driver, release version
- pkgver = 0.5.0
- pkgrel = 3
+ pkgver = 0.6.0
+ pkgrel = 1
url = https://github.com/ckb-next/ckb-next
install = ckb-next.install
arch = i686
@@ -25,12 +25,10 @@ pkgbase = ckb-next
conflicts = ckb-git
conflicts = ckb-git-latest
conflicts = ckb-next-git
- source = https://github.com/ckb-next/ckb-next/archive/v0.5.0.tar.gz
+ source = https://github.com/ckb-next/ckb-next/archive/v0.6.0.tar.gz
source = AUR-wrapper::git+https://github.com/ckb-next/AUR-wrapper.git
- source = 0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch
- sha256sums = 12705aa86cb544a77df6d7a73744f21513bcc6cce805ed8caf5d3b72a950157e
+ sha256sums = dd7c9a30ce7bf4fafcdfff974c519b2b3d2ff888c99d3255a6e0194ece5056f4
sha256sums = SKIP
- sha256sums = 6cddbf71179ad385d89b9a2ed318b0fa3dd5817b5bcfd4432d22b088d183bfcd
pkgname = ckb-next
diff --git a/0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch b/0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch
deleted file mode 100644
index 4ad323874888..000000000000
--- a/0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 1de099678ea522e7a66bed19c1cc86de0e24b759 Mon Sep 17 00:00:00 2001
-From: Tasos Sahanidis <tasos@tasossah.com>
-Date: Mon, 20 Jun 2022 22:58:28 +0300
-Subject: [PATCH] Fix autostart checkbox detection with renamed binary
-
----
- src/gui/autorun.cpp | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/gui/autorun.cpp b/src/gui/autorun.cpp
-index 0f11ff0f..cac6bb11 100644
---- a/src/gui/autorun.cpp
-+++ b/src/gui/autorun.cpp
-@@ -4,6 +4,7 @@
- #include "autorun.h"
- #include "ckbsettings.h"
- #include <QDebug>
-+#include <QFileInfo>
-
- // >=0.3.0 (new) paths
- #ifdef Q_OS_LINUX
-@@ -30,7 +31,9 @@ static const QString oldSettingPath = "Program/DidLoginItem";
- bool AutoRun::available() {
- // Allow autostart if the program is located in a system path
- #ifdef Q_OS_LINUX
-- return QDir::root().absoluteFilePath(QStandardPaths::findExecutable("ckb-next")) == qApp->applicationFilePath();
-+ const QString& fpath = qApp->applicationFilePath();
-+ QFileInfo finfo(fpath);
-+ return QDir::root().absoluteFilePath(QStandardPaths::findExecutable(finfo.fileName())) == fpath;
- #elif defined(Q_OS_MACOS)
- return qApp->applicationFilePath().startsWith("/Applications/ckb-next.app", Qt::CaseInsensitive);
- #endif
---
-2.25.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 6779b1adc5cf..44da12c98ea4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tasos Sahanidis <aur@tasossah.com>
# Contributor: Light2Yellow <oleksii.vilchanskyi@gmail.com>
pkgname=ckb-next
-pkgver=0.5.0
-pkgrel=3
+pkgver=0.6.0
+pkgrel=1
pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
arch=('i686' 'x86_64' 'pentium4')
url="https://github.com/ckb-next/ckb-next"
@@ -14,11 +14,9 @@ conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next-git')
provides=('ckb-next')
install=ckb-next.install
source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz"
- 'AUR-wrapper::git+https://github.com/ckb-next/AUR-wrapper.git'
- '0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch')
-sha256sums=('12705aa86cb544a77df6d7a73744f21513bcc6cce805ed8caf5d3b72a950157e'
- 'SKIP'
- '6cddbf71179ad385d89b9a2ed318b0fa3dd5817b5bcfd4432d22b088d183bfcd')
+ 'AUR-wrapper::git+https://github.com/ckb-next/AUR-wrapper.git')
+sha256sums=('dd7c9a30ce7bf4fafcdfff974c519b2b3d2ff888c99d3255a6e0194ece5056f4'
+ 'SKIP')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -36,7 +34,6 @@ build() {
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
- patch -p1 -i "$srcdir/0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch"
}
package() {