summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a967858604d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cl-protobuf-git
+ pkgdesc = Protobuf is a Common Lisp implementation of Google's protocol buffers.
+ pkgver = r128.bfcde84
+ pkgrel = 1
+ url = https://github.com/brown/protobuf
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = make
+ optdepends = boost
+ optdepends = protobuf
+ provides = cl-protobuf
+ source = git+file:///home/eschulte/lisp/local-projects/protobuf
+ sha512sums = SKIP
+
+pkgname = cl-protobuf-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4a82f8763822
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+protobuf/
+cl-protobuf-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da12d185e0a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Eric Schulte <eschulte@grammatech.com>
+# Maintainer: Eric Schulte <eschulte@grammatech.com>
+_srcname=protobuf
+pkgname=cl-${_srcname}-git
+pkgver=r128.bfcde84
+pkgrel=1
+pkgdesc="Protobuf is a Common Lisp implementation of Google's protocol buffers."
+arch=('x86_64')
+url="https://github.com/brown/protobuf"
+license=('BSD')
+optdepends=('boost' 'protobuf')
+depends=()
+makedepends=('git' 'make')
+provides=("cl-${_srcname}")
+# source=('git://github.com/brown/protobuf.git')
+source=('git+file:///home/eschulte/lisp/local-projects/protobuf')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_srcname/protoc/lisp/"
+ cp /usr/include/google/protobuf/stubs/strutil.h .
+ INSTALL_ROOT=/usr/ PROTOC_ROOT=/usr/ make
+}
+
+package() {
+ cd "$_srcname/protoc/lisp/"
+ mkdir -p "$pkgdir"/usr
+ INSTALL_ROOT="$pkgdir"/usr/ PROTOC_ROOT=/usr/ make install
+}