summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c033fbcb936b..27a90ced2810 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
+# Generated by mksrcinfo v8
+# Sat Mar 5 23:13:15 UTC 2016
pkgbase = clam-git
pkgdesc = The most widely held crypto-currency ever! This package provides both the GUI QT4 and daemon clients.
- pkgver = 1.4.5.135.gc7b62b5
+ pkgver = 1.4.5.265.ge15b722
pkgrel = 1
url = http://www.clamclient.com
arch = any
license = MIT
makedepends = pkg-config
makedepends = git
- makedepends = boost-libs
makedepends = boost
makedepends = gcc
makedepends = qrencode
@@ -17,17 +18,18 @@ pkgbase = clam-git
makedepends = autoconf
makedepends = libtool
depends = qt4
- depends = gcc-libs
depends = miniupnpc
- depends = openssl
depends = db4.8
- depends = protobuf
+ depends = boost-libs
+ depends = qrencode
provides = clam-qt
provides = clamd
conflicts = clam-qt
conflicts = clamd
source = git://github.com/nochowderforyou/clams.git
- md5sums = SKIP
+ source = https://github.com/bitcoin/bitcoin/commit/9f3e48e5219a09b5ddfd6883d1f0498910eff4b6.patch
+ sha256sums = SKIP
+ sha256sums = 0910004577764c2251a33c4868c7358a42da68f94d6462e44bbcb1945cefd748
pkgname = clam-git
diff --git a/PKGBUILD b/PKGBUILD
index 7181b265f514..7d96c03ff614 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,43 @@
-# Maintainer: Raansu <gero3977@gmail.com>
+# Maintainer: Jeffrey Lin <anaveragehuman.0 AT gmail DOT com>
+# Contributor: Raansu <gero3977@gmail.com>
# Based on PKGBUILD from vertcoin-git maintained by Lothar_m <lothar_m at riseup dot net>
# Clams original code by nochowderforyou <https://github.com/nochowderforyou>
pkgname='clam-git'
_gitname=clams
-pkgver=1.4.5.135.gc7b62b5
+pkgver=1.4.5.265.ge15b722
pkgrel=1
arch=('any')
url="http://www.clamclient.com"
-depends=('qt4' 'gcc-libs' 'miniupnpc' 'openssl' 'db4.8' 'protobuf')
-makedepends=('pkg-config' 'git' 'boost-libs' 'boost' 'gcc' 'qrencode' 'make' 'automoc4' 'automake' 'autoconf' 'libtool')
+depends=('qt4' 'miniupnpc' 'db4.8' 'boost-libs' 'qrencode')
+makedepends=('pkg-config' 'git' 'boost' 'gcc' 'qrencode' 'make' 'automoc4' 'automake' 'autoconf' 'libtool')
license=('MIT')
pkgdesc="The most widely held crypto-currency ever! This package provides both the GUI QT4 and daemon clients."
provides=('clam-qt' 'clamd')
conflicts=('clam-qt' 'clamd')
-source=("git://github.com/nochowderforyou/clams.git")
-md5sums=('SKIP')
+source=("git://github.com/nochowderforyou/clams.git"
+ "https://github.com/bitcoin/bitcoin/commit/9f3e48e5219a09b5ddfd6883d1f0498910eff4b6.patch")
+sha256sums=('SKIP'
+ '0910004577764c2251a33c4868c7358a42da68f94d6462e44bbcb1945cefd748')
pkgver() {
cd "$srcdir/$_gitname"
git describe | sed "s/^v//; s/-/./g"
}
+prepare() {
+ cd "$srcdir/$_gitname"
+ patch -Np1 -i "$srcdir"/9f3e48e5219a09b5ddfd6883d1f0498910eff4b6.patch
+}
+
build() {
cd "$srcdir/$_gitname"
- ./autogen.sh
- ./configure
- make
+ CXXFLAGS="$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1 -UUPNPDISCOVER_SUCCESS"
+ ./autogen.sh
+ ./configure
+ make
}
-
package() {
# install clam-qt client
install -D -m755 "$srcdir/$_gitname/src/qt/clam-qt" "$pkgdir/usr/bin/clam-qt"