summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD37
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..392f54e42169
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = clam-git
+ pkgdesc = The most widely held crypto-currency ever! This package provides both the GUI QT4 and daemon clients.
+ pkgver = 1.4.16
+ pkgrel = 1
+ url = http://www.clamclient.com
+ arch = any
+ license = MIT
+ makedepends = pkg-config
+ makedepends = git
+ makedepends = boost-libs
+ makedepends = boost
+ makedepends = gcc
+ makedepends = qrencode
+ makedepends = make
+ makedepends = automoc4
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = libtool
+ depends = qt4
+ depends = gcc-libs
+ depends = miniupnpc
+ depends = openssl
+ depends = db4.8
+ depends = protobuf
+ provides = clam-qt
+ provides = clamd
+ conflicts = clam-qt
+ conflicts = clamd
+ source = git://github.com/nochowderforyou/clams.git
+ md5sums = SKIP
+
+pkgname = clam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3322cce033d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Raansu <gero3977 at gmail dot com>
+# Based on PKGBUILD from vertcoin-git maintained by Lothar_m <lothar_m at riseup dot net>
+# Clams original code by nochowderforyou <https://github.com/nochowderforyou>
+
+pkgname='clam-git'
+_gitname=clams
+pkgver=1.4.16
+pkgrel=1
+arch=('any')
+url="http://www.clamclient.com"
+depends=('qt4' 'gcc-libs' 'miniupnpc' 'openssl' 'db4.8' 'protobuf')
+makedepends=('pkg-config' 'git' 'boost-libs' 'boost' 'gcc' 'qrencode' 'make' 'automoc4' 'automake' 'autoconf' 'libtool')
+license=('MIT')
+pkgdesc="The most widely held crypto-currency ever! This package provides both the GUI QT4 and daemon clients."
+provides=('clam-qt' 'clamd')
+conflicts=('clam-qt' 'clamd')
+source=("git://github.com/nochowderforyou/clams.git")
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/$_gitname
+ ./autogen.sh
+ ./configure
+ make
+}
+
+
+package() {
+ # install clam-qt client
+ install -D -m755 "$srcdir/$_gitname/src/qt/clam-qt" "$pkgdir/usr/bin/clam-qt"
+
+ # install clam daemon
+ install -D -m755 "$srcdir/$_gitname/src/clamd" "$pkgdir/usr/bin/clamd"
+
+ # install license
+ install -D -m644 "$srcdir/$_gitname/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}