summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73463a63ebd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = clapper-git
+ pkgdesc = A GNOME media player built using GJS and powered by GStreamer with OpenGL rendering. Can also be used as a pre-made widget for Gtk apps.
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/Rafostar/clapper
+ arch = any
+ license = GPL-3.0
+ makedepends = meson
+ makedepends = gjs
+ depends = gjs
+ depends = gst-plugins-base-libs
+ depends = gst-plugin-gtk
+ depends = gst-plugins-bad-libs
+ optdepends = gst-libav: Additional Codecs,
+ optdepends = gstreamer-vaapi: Hardware acceleration
+ provides = clapper
+ source = clapper-0.0.0::git+https://github.com/Rafostar/clapper.git
+ md5sums = SKIP
+
+pkgname = clapper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83f609953c5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+#
+# PKGBUILD file for package clapper
+#
+# Copyright (C) 2020 sp1rit
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Maintainer: sp1rit <sp1ritCS@protonmail.com>
+
+pkgname=clapper-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="A GNOME media player built using GJS and powered by GStreamer with OpenGL rendering. Can also be used as a pre-made widget for Gtk apps."
+arch=(any)
+url="https://github.com/Rafostar/clapper"
+license=("GPL-3.0")
+depends=("gjs" "gst-plugins-base-libs" "gst-plugin-gtk" "gst-plugins-bad-libs")
+makedepends=("meson" "gjs")
+optdepends=("gst-libav: Additional Codecs", "gstreamer-vaapi: Hardware acceleration")
+provides=("${pkgname%-git}")
+source=("${pkgname%-git}-$pkgver"::git+https://github.com/Rafostar/clapper.git)
+md5sums=("SKIP")
+
+prepare() {
+ cd "${pkgname%-git}-$pkgver"
+}
+
+build() {
+ cd "${pkgname%-git}-$pkgver"
+ meson build/ --prefix=/usr
+}
+
+package() {
+ cd "${pkgname%-git}-$pkgver"
+ DESTDIR="$pkgdir" meson install -C build/
+ ln -s "$pkgdir/usr/bin/com.github.rafostar.Clapper" "$pkgdir/usr/bin/clapper"
+}
+