summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e11e73dcb6f4..43b6f4549b4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = clash-verge-bin
pkgdesc = A Clash GUI based on tauri.
- pkgver = 1.0.3
- pkgrel = 1
+ pkgver = 1.3.8
+ pkgrel = 0
url = https://github.com/zzzgydi/clash-verge
arch = x86_64
license = GPL3
- depends = libappindicator-gtk3
depends = webkit2gtk
depends = gtk3
depends = libayatana-appindicator
- provides = clash
- conflicts = clash
- source = clash-verge-1.0.3-x86_64.deb::https://github.com/zzzgydi/clash-verge/releases/download/v1.0.3/clash-verge_1.0.3_amd64.deb
- sha512sums = 9e00a6e25630c312c265c2b72115badf19271a76c53896e912b370485c6a95b51dee0fa61668f9b108fe48ad85c2817df36ef73516e2c834e04c97366b213958
+ depends = clash
+ optdepends = clash-meta: Another Clash Kernel
+ source = clash-verge-1.3.8-x86_64.deb::https://github.com/zzzgydi/clash-verge/releases/download/v1.3.8/clash-verge_1.3.8_amd64.deb
+ sha512sums = 31a1aa9dc03272576e3898a09a7e2fd7e93635fa6f7760337588efcbeb67b26d68870a5be5bb3d1f1b3c73fbd86d02109ef7b9fdb3aac037e26bd1ddc509d8ba
pkgname = clash-verge-bin
diff --git a/PKGBUILD b/PKGBUILD
index 494cab73fd94..4ed345c298fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: mindnightix <midnightix@protonmail.com>
+# Maintainer: Pylogmon <pylogmon@outlook.com>
pkgname=clash-verge-bin
_pkgname=clash-verge
-pkgver=1.0.3
-pkgrel=1
+pkgver=1.3.8
+pkgrel=0
pkgdesc="A Clash GUI based on tauri."
arch=('x86_64')
url="https://github.com/zzzgydi/clash-verge"
license=('GPL3')
-depends=('libappindicator-gtk3' 'webkit2gtk' 'gtk3' 'libayatana-appindicator')
-provides=('clash')
-conflicts=('clash')
+depends=('webkit2gtk' 'gtk3' 'libayatana-appindicator' 'clash')
+optdepends=('clash-meta: Another Clash Kernel')
+
source=("${_pkgname}-${pkgver}-${arch}.deb::https://github.com/zzzgydi/clash-verge/releases/download/v${pkgver}/clash-verge_${pkgver}_amd64.deb")
-sha512sums=('9e00a6e25630c312c265c2b72115badf19271a76c53896e912b370485c6a95b51dee0fa61668f9b108fe48ad85c2817df36ef73516e2c834e04c97366b213958')
+sha512sums=('31a1aa9dc03272576e3898a09a7e2fd7e93635fa6f7760337588efcbeb67b26d68870a5be5bb3d1f1b3c73fbd86d02109ef7b9fdb3aac037e26bd1ddc509d8ba')
package() {
- tar xpf data.tar.gz -C ${pkgdir}
+ tar xpf data.tar.gz -C ${pkgdir}
+ rm ${pkgdir}/usr/bin/clash
+ rm ${pkgdir}/usr/bin/clash-meta
}