summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--uintptr_t.patch12
3 files changed, 21 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a73f70536ebb..b1655a221258 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -52,10 +52,12 @@ pkgbase = claws-mail-gtk2
conflicts = claws-mail
source = https://www.claws-mail.org/download.php?file=releases/claws-mail-3.19.1.tar.xz
source = https://www.claws-mail.org/download.php?file=releases/claws-mail-3.19.1.tar.xz.asc
+ source = uintptr_t.patch
source = bash_completion
validpgpkeys = 8B3B297A03468356692F8D592CD716D654D6BBD4
sha256sums = ac57fa557cf15c62e5f8fad247585fc609f0a696f6da54ed42cc000b6c6d6813
sha256sums = SKIP
+ sha256sums = 9f61f2b779c1cc14f1f4f21720b2c5a036d22c880a38edd74208c5945a94cef2
sha256sums = 3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb
pkgname = claws-mail-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index ec5bde9560c0..48ca0220eb9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,12 +37,19 @@ optdepends=('python: needed for some tools'
provides=('claws' "$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
+ uintptr_t.patch
bash_completion)
sha256sums=('ac57fa557cf15c62e5f8fad247585fc609f0a696f6da54ed42cc000b6c6d6813'
'SKIP'
+ '9f61f2b779c1cc14f1f4f21720b2c5a036d22c880a38edd74208c5945a94cef2'
'3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
+prepare() {
+ cd "${_pkgname}"-${pkgver}
+ patch -Np0 <../uintptr_t.patch
+}
+
build() {
cd "${_pkgname}"-${pkgver}
./configure --prefix=/usr --disable-static \
diff --git a/uintptr_t.patch b/uintptr_t.patch
new file mode 100644
index 000000000000..d2f03c478bad
--- /dev/null
+++ b/uintptr_t.patch
@@ -0,0 +1,12 @@
+diff -up ./src/plugins/litehtml_viewer/litehtml/os_types.h.orig ./src/plugins/litehtml_viewer/litehtml/os_types.h
+--- ./src/plugins/litehtml_viewer/litehtml/os_types.h.orig 2023-08-09 16:55:51.309999999 -0600
++++ ./src/plugins/litehtml_viewer/litehtml/os_types.h 2023-08-09 16:56:35.029999999 -0600
+@@ -1,6 +1,8 @@
+ #ifndef LH_OS_TYPES_H
+ #define LH_OS_TYPES_H
+
++#include <cstdint>
++
+ namespace litehtml
+ {
+ #if defined( WIN32 ) || defined( _WIN32 ) || defined( WINCE )