summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
-rw-r--r--ccm.install30
3 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a2b6433b18c..6b15898548e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
-# Generated by mksrcinfo v8
-# Sat Apr 13 22:13:32 UTC 2019
pkgbase = clean-chroot-manager
- pkgdesc = Wrapper scripts for managing clean chroots.
- pkgver = 2.95
+ pkgdesc = Wrapper for managing clean chroot builds with local repo therein.
+ pkgver = 2.226
pkgrel = 1
url = https://github.com/graysky2/clean-chroot-manager
install = ccm.install
arch = any
license = MIT
- depends = devtools>=20180528-1
+ depends = devtools>=1:1.0.0-1
depends = rsync
depends = libarchive>=3.3.3
+ depends = pacman>=6.0.2-7
conflicts = clean_chroot_manager
replaces = clean_chroot_manager
- source = clean-chroot-manager-2.95.tar.gz::https://github.com/graysky2/clean-chroot-manager/archive/v2.95.tar.gz
- sha256sums = 0b81b58de1d022e49bf9d488aab015fc4183e40b849701fa75adecf9a53156a1
+ source = clean-chroot-manager-2.226.tar.gz::https://github.com/graysky2/clean-chroot-manager/archive/v2.226.tar.gz
+ b2sums = fce60c3f94aa07b32fd9da8436e228a3ae79db2fe8164593578543e777280cf6bed5803bb43068d95029c68880a2dfb0c964d944f43077a72f96f16620066ffc
pkgname = clean-chroot-manager
-
diff --git a/PKGBUILD b/PKGBUILD
index 713da848a427..f4dfed86eff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: graysky <graysky AT archlinux DOT us>
+# Maintainer: graysky <therealgraysky AT protonmail DOT com>
pkgname=clean-chroot-manager
-pkgver=2.95
+pkgver=2.226
pkgrel=1
-pkgdesc='Wrapper scripts for managing clean chroots.'
+pkgdesc='Wrapper for managing clean chroot builds with local repo therein.'
arch=('any')
url='https://github.com/graysky2/clean-chroot-manager'
license=('MIT')
-depends=('devtools>=20180528-1' 'rsync' 'libarchive>=3.3.3')
+depends=('devtools>=1:1.0.0-1' 'rsync' 'libarchive>=3.3.3' 'pacman>=6.0.2-7')
conflicts=('clean_chroot_manager')
replaces=('clean_chroot_manager')
source=("$pkgname-$pkgver.tar.gz::https://github.com/graysky2/clean-chroot-manager/archive/v$pkgver.tar.gz")
-sha256sums=('0b81b58de1d022e49bf9d488aab015fc4183e40b849701fa75adecf9a53156a1')
+b2sums=('fce60c3f94aa07b32fd9da8436e228a3ae79db2fe8164593578543e777280cf6bed5803bb43068d95029c68880a2dfb0c964d944f43077a72f96f16620066ffc')
install=ccm.install
build() {
diff --git a/ccm.install b/ccm.install
index a45e3d56aba7..e2cfd39044f9 100644
--- a/ccm.install
+++ b/ccm.install
@@ -2,15 +2,27 @@
## arg 2: the old package version
post_upgrade() {
- for test in 2.92-1 2.87-1 2.81-1 2.73-1 2.72-1 2.55-1 2.17-1 2.22-1 2.69-1 2.93-1; do
- if [ "$(vercmp $2 $test)" -lt 1 ]; then
- echo
- echo '--> Please check ~/.config/clean-chroot-manager.conf against the'
- echo '--> provided /usr/share/clean-chroot-manager/ccm.skel to ensure it is'
- echo '--> updated as the script does not do this automatically.'
- exit 0
- else
- /bin/true
+ # define the versions for which a change is needed
+ for test in 2.101-1 2.201-1 2.202-1 2.208-1 2.212-1 2.213-1 2.221-1 2.224-1; do
+ if [ "$(vercmp $2 $test)" -lt 0 ]; then
+ cat <<END
+
+>>> New features/changes have been made with this release.
+ Check \$XDG_CONFIG_HOME/clean-chroot-manager.conf against
+ /usr/share/clean-chroot-manager/ccm.skel to ensure it is updated!
+
+END
+ fi
+ done
+
+ for test in 2.217-1; do
+ if [ "$(vercmp $2 $test)" -lt 0 ]; then
+ cat <<END
+
+>>> WARNING: Changes to this release require some users to nuke any existing
+ buildroot before using ccm with this release!
+
+END
fi
done
}