summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ad629d93379..379cdcf9af76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clifm-git
- pkgdesc = The KISS file manager: cli-based, ultra-lightweight, and lightning fast (development version)
+ pkgdesc = The KISS, non-curses terminal file manager (development version)
pkgver = 1.0.r148.g05714e7
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/leo-arch/clifm
arch = i686
arch = pentium4
@@ -26,4 +26,3 @@ pkgbase = clifm-git
sha256sums = SKIP
pkgname = clifm-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f9bb006d57ac..c3d8453b15d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=clifm-git
_pkgname=clifm
pkgver=1.0.r148.g05714e7
-pkgrel=2
-pkgdesc="The KISS file manager: cli-based, ultra-lightweight, and lightning fast (development version)"
+pkgrel=3
+pkgdesc="The KISS, non-curses terminal file manager (development version)"
arch=('i686' 'pentium4' 'x86_64' 'arm' 'aarch64' 'armv7h')
url="https://github.com/leo-arch/clifm"
license=(GPL2)
@@ -30,20 +30,19 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname/src"
- gcc -O3 -march=native -s -fstack-protector-strong -o "$_pkgname" *.c -lreadline -lacl -lcap
+ gcc -O3 -march=native -s -fstack-protector-strong -Wall -o "$_pkgname" *.c -lreadline -lacl -lcap
}
package() {
cd "$srcdir/$_pkgname"
install -Dm755 "src/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
- install -g 0 -o 0 -Dm644 manpage "$pkgdir/usr/share/man/man1/${_pkgname}.1"
+ install -Dm644 misc/manpage "$pkgdir/usr/share/man/man1/${_pkgname}.1"
gzip -9n "$pkgdir/usr/share/man/man1/$_pkgname.1"
- install -g 0 -o 0 -Dm644 "${_pkgname}.desktop" "$pkgdir/usr/share/applications/${_pkgname}.desktop"
- install -g 0 -o 0 -Dm644 completions.bash "$pkgdir/usr/share/bash-completion/completions/${_pkgname}"
- install -g 0 -o 0 -Dm644 completions.zsh "$pkgdir/usr/share/zsh/site-functions/_${_pkgname}"
- install -g 0 -o 0 -Dm644 "translations/spanish/${_pkgname}.mo" "$pkgdir/usr/share/locale/es/LC_MESSAGES/${_pkgname}.mo"
- mkdir -p "$pkgdir/usr/share/$_pkgname"
- install -g 0 -o 0 -Dm644 misc/mimelist.cfm "$pkgdir/usr/share/$_pkgname/mimelist.cfm"
+ install -Dm644 misc/"${_pkgname}.desktop" "$pkgdir/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 misc/completions.bash "$pkgdir/usr/share/bash-completion/completions/${_pkgname}"
+ install -Dm644 misc/completions.zsh "$pkgdir/usr/share/zsh/site-functions/_${_pkgname}"
+ install -Dm644 "translations/spanish/${_pkgname}.mo" "$pkgdir/usr/share/locale/es/LC_MESSAGES/${_pkgname}.mo"
+ install -Dm644 misc/mimelist.cfm "$pkgdir/usr/share/$_pkgname/mimelist.cfm"
cp -r plugins "$pkgdir/usr/share/$_pkgname"
cp -r functions "$pkgdir/usr/share/$_pkgname"
}