summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 958340353549..1c3e57275369 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clight
pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms.
- pkgver = 3.0
+ pkgver = 3.1
pkgrel = 1
url = https://github.com/FedeDP/Clight
install = clight.install
@@ -17,9 +17,10 @@ pkgbase = clight
depends = clightd>=3.0
optdepends = geoclue2: to retrieve user location through geoclue2.
optdepends = upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.
+ optdepends = bash-completion: to add support for bash automatic completion.
backup = etc/default/clight.conf
- source = Clight-3.0.tar.gz::https://github.com/FedeDP/Clight/archive/3.0.tar.gz
- sha256sums = d904e20f90e3166d26a9c8a72b401ee104c06c53660b70bb809ba1eabc32b0d3
+ source = Clight-3.1.tar.gz::https://github.com/FedeDP/Clight/archive/3.1.tar.gz
+ sha256sums = 24d95c1d812d7b9293e647ac00c1a0a62429b74d11d9a746865d52a2f0f7e7fc
pkgname = clight
diff --git a/PKGBUILD b/PKGBUILD
index cc2318102697..0637889b1b5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=clight
_gitname=Clight
-pkgver=3.0
+pkgver=3.1
pkgrel=1
pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms."
arch=('i686' 'x86_64')
@@ -12,10 +12,11 @@ backup=(etc/default/clight.conf)
depends=('systemd>=221' 'popt' 'libconfig' 'gsl' 'clightd>=3.0')
makedepends=('git' 'cmake' 'bash-completion')
optdepends=('geoclue2: to retrieve user location through geoclue2.'
- 'upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.')
+ 'upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.'
+ 'bash-completion: to add support for bash automatic completion.')
source=("${_gitname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
install=clight.install
-sha256sums=("d904e20f90e3166d26a9c8a72b401ee104c06c53660b70bb809ba1eabc32b0d3")
+sha256sums=("24d95c1d812d7b9293e647ac00c1a0a62429b74d11d9a746865d52a2f0f7e7fc")
prepare() {
cd "${srcdir}/${_gitname}-${pkgver}"