summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD34
-rwxr-xr-xclight-gui.desktop9
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50737583feaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = clight-gui-git
+ pkgdesc = Qt GUI for Clight
+ pkgver = r34.51e68b4
+ pkgrel = 1
+ url = https://github.com/nullobsi/clight-gui
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = clight-git
+ depends = qt5-charts
+ provides = clight-gui
+ conflicts = clight-gui
+ source = git+https://github.com/nullobsi/clight-gui.git
+ source = clight-gui.desktop
+ sha256sums = SKIP
+ sha256sums = f5fbdb9d0e537aa3a95f01bafcfe34ee4cc217a91a5ed59000cc26d1afab7dd8
+
+pkgname = clight-gui-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9434e207be90
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!clight-gui.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4a367c15600
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=clight-gui-git
+pkgver=r34.51e68b4
+pkgrel=1
+pkgdesc="Qt GUI for Clight"
+arch=('x86_64')
+url="https://github.com/nullobsi/clight-gui"
+license=('GPL3')
+depends=('clight-git' 'qt5-charts')
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/nullobsi/clight-gui.git'
+ "${pkgname%-git}.desktop")
+sha256sums=('SKIP'
+ 'f5fbdb9d0e537aa3a95f01bafcfe34ee4cc217a91a5ed59000cc26d1afab7dd8')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S "${pkgname%-git}/src" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ install -Dm755 "build/${pkgname%-git}" -t "$pkgdir/usr/bin"
+ install -Dm644 "${pkgname%-git}.desktop" -t "$pkgdir/usr/share/applications"
+}
diff --git a/clight-gui.desktop b/clight-gui.desktop
new file mode 100755
index 000000000000..305ed52b468c
--- /dev/null
+++ b/clight-gui.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Icon=display-brightness
+Name=Clight GUI
+Exec=clight-gui
+Terminal=false
+Hidden=false
+Categories=Utility
+Comment=Qt GUI for Clight