summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 955b5358b7b9..2d78d32505f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clight-gui-git
pkgdesc = Qt GUI for Clight
- pkgver = r54.630438b
+ pkgver = r61.48c9579
pkgrel = 1
url = https://github.com/nullobsi/clight-gui
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7b1ecd73c479..33faf0343b21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=clight-gui-git
-pkgver=r54.630438b
+pkgver=r61.48c9579
pkgrel=1
pkgdesc="Qt GUI for Clight"
arch=('x86_64')
@@ -23,12 +23,15 @@ pkgver() {
build() {
cmake -B build -S "${pkgname%-git}/src" \
-DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_PREFIX_PATH=/usr/lib/cmake/Qt5 \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DGENERATE_TRANSLATIONS=ON \
-Wno-dev
make -C build
}
package() {
- install -Dm755 "build/${pkgname%-git}" -t "$pkgdir/usr/bin"
+ make -C build DESTDIR="$pkgdir" install
+
install -Dm644 "${pkgname%-git}.desktop" -t "$pkgdir/usr/share/applications"
}