summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da70a94ebb21..97247e7153e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = clightd
- pkgdesc = Bus interface to change screen brightness and capture frames from webcam.
+pkgbase = clightd-no-ddc
+ pkgdesc = Bus interface to change screen brightness based on ambient brightness (DDC disabled).
pkgver = 5.6
- pkgrel = 1
+ pkgrel = 4
url = https://github.com/FedeDP/Clightd
arch = x86_64
arch = aarch64
@@ -14,13 +14,14 @@ pkgbase = clightd
depends = libxrandr
depends = libxext
depends = polkit
- depends = ddcutil
depends = libmodule
depends = libjpeg-turbo
depends = libusb
depends = libdrm
depends = wayland
- source = clightd-5.6.tar.gz::https://github.com/FedeDP/Clightd/archive/5.6.tar.gz
+ provides = clightd
+ conflicts = clightd
+ source = clightd-no-ddc-5.6.tar.gz::https://github.com/FedeDP/Clightd/archive/5.6.tar.gz
sha256sums = c629cb3a83e17677cc146f366a53768bca8c944d92b2a96d6091e4c564810267
-pkgname = clightd
+pkgname = clightd-no-ddc
diff --git a/PKGBUILD b/PKGBUILD
index 2786552ef4ca..b0c4494476ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,17 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutantota dot com>
+# Maintainer: Ewout van Mansom <ewout@vanmansom.name>
+# Contributor: Mark Wagie <mark dot wagie at tutantota dot com>
# Contributor: Federico Di Pierro <nierro92@gmail.com>
-pkgname=clightd
+pkgname=clightd-no-ddc
pkgver=5.6
-pkgrel=1
-pkgdesc="Bus interface to change screen brightness and capture frames from webcam."
+pkgrel=4
+pkgdesc="Bus interface to change screen brightness based on ambient brightness (DDC disabled)."
arch=('x86_64' 'aarch64')
url="https://github.com/FedeDP/Clightd"
license=('GPL')
depends=('systemd-libs' 'linux-api-headers' 'libx11' 'libxrandr' 'libxext' 'polkit'
- 'ddcutil' 'libmodule' 'libjpeg-turbo' 'libusb' 'libdrm' 'wayland')
+ 'libmodule' 'libjpeg-turbo' 'libusb' 'libdrm' 'wayland')
+conflicts=('clightd')
+provides=('clightd')
makedepends=('git' 'cmake')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('c629cb3a83e17677cc146f366a53768bca8c944d92b2a96d6091e4c564810267')
@@ -19,7 +22,7 @@ build() {
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBEXECDIR=lib/"$pkgname" \
- -DENABLE_DDC=1 \
+ -DENABLE_DDC=0 \
-DENABLE_GAMMA=1 \
-DENABLE_DPMS=1 \
-DENABLE_SCREEN=1 \