summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD36
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb89fbb97e35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = clightd
+ pkgdesc = Bus interface to change screen brightness and capture frames from webcam.
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://github.com/FedeDP/Clightd
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = systemd>=221
+ depends = linux-api-headers
+ depends = libx11
+ depends = libxrandr
+ depends = libxext
+ depends = polkit
+ depends = libxss
+ depends = ddcutil
+ depends = libmodule>=3.1.0
+ optdepends = clight: user service to automagically change screen backlight matching ambient brightness.
+ source = Clightd-3.0.tar.gz::https://github.com/FedeDP/Clightd/archive/3.0.tar.gz
+ sha256sums = a52d340ba4ac01fa115e54ca8f82ea9f7f6863103eef3a517425b42615accca0
+
+pkgname = clightd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..587bd73ed683
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Federico Di Pierro <nierro92@gmail.com>
+
+pkgname=clightd
+_gitname=Clightd
+pkgver=3.0
+pkgrel=1
+pkgdesc="Bus interface to change screen brightness and capture frames from webcam."
+arch=('i686' 'x86_64')
+url="https://github.com/FedeDP/${_gitname}"
+license=('GPL')
+depends=('systemd>=221' 'linux-api-headers' 'libx11' 'libxrandr' 'libxext' 'polkit' 'libxss' 'ddcutil' 'libmodule>=3.1.0')
+makedepends=('git' 'cmake')
+optdepends=('clight: user service to automagically change screen backlight matching ambient brightness.')
+source=("${_gitname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=("a52d340ba4ac01fa115e54ca8f82ea9f7f6863103eef3a517425b42615accca0")
+
+prepare() {
+ cd "${srcdir}/${_gitname}-${pkgver}"
+ mkdir -p build
+}
+
+build() {
+ cd "${srcdir}/${_gitname}-${pkgver}/build"
+ cmake \
+ -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE="Release" \
+ ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}-${pkgver}/build"
+ make DESTDIR="$pkgdir" install
+}