summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
-rw-r--r--climate.install11
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..266c291f23d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = climate
+ pkgdesc = Climate is the ultimate command line tool for Linux
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/adtac/climate
+ install = climate.install
+ arch = any
+ license = GPLv3
+ optdepends = unzip: extracting zip files
+ optdepends = wget: retrieving files
+ optdepends = curl: making http requests
+ optdepends = dig: dns support
+ optdepends = git: git support
+ optdepends = rar: extacting rar files
+ optdepends = python: running python scripts
+ optdepends = pip: installing python packages
+ optdepends = node: running node scripts
+ optdepends = fdupes: de-deplicating files
+ optdepends = sshfs: ssh filesystem support
+ optdepends = 7z: extracting 7z files
+ source = https://github.com/adtac/climate/archive/v0.2.tar.gz
+ sha256sums = 781f42f4d59374e90f9c3efba271209d8b5e985279696bdd93bcd2f826f0177e
+
+pkgname = climate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6269f2c67bd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ian Ker-Seymer <i.kerseymer@gmail.com>
+
+pkgname=climate
+pkgver=0.2
+pkgrel=1
+pkgdesc="Climate is the ultimate command line tool for Linux"
+url="https://github.com/adtac/climate"
+arch=('any')
+license=('GPLv3')
+optdepends=('unzip: extracting zip files'
+ 'wget: retrieving files'
+ 'curl: making http requests'
+ 'dig: dns support'
+ 'git: git support'
+ 'rar: extacting rar files'
+ 'python: running python scripts'
+ 'pip: installing python packages'
+ 'node: running node scripts'
+ 'fdupes: de-deplicating files'
+ 'sshfs: ssh filesystem support'
+ '7z: extracting 7z files')
+install="${pkgname}.install"
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('781f42f4d59374e90f9c3efba271209d8b5e985279696bdd93bcd2f826f0177e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm644 climate "${pkgdir}/usr/bin/climate"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ chmod +x "$pkgdir/usr/bin/climate"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/climate.install b/climate.install
new file mode 100644
index 000000000000..41983d360137
--- /dev/null
+++ b/climate.install
@@ -0,0 +1,11 @@
+## arg 1: the new package version
+post_install() {
+ true;
+}
+
+## arg 1: the old package version
+post_remove() {
+ true;
+}
+
+# vim:set ts=2 sw=2 et: