summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c623fc2d4c68..43947fb0adfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
-pkgbase = clinfo
+# Generated by mksrcinfo v8
+# Fri Jul 1 00:08:57 UTC 2016
+pkgbase = clinfo-git
pkgdesc = Print all known information about all available OpenCL platforms and devices in the system
- pkgver = 2.0.15.03.24
+ pkgver = 2.1.16.01.12.r2.g271b884
pkgrel = 1
url = https://github.com/Oblomov/clinfo
arch = i686
@@ -14,5 +16,5 @@ pkgbase = clinfo
source = git+https://github.com/oblomov/clinfo.git
md5sums = SKIP
-pkgname = clinfo
+pkgname = clinfo-git
diff --git a/PKGBUILD b/PKGBUILD
index a839eada6f34..d9571a87e49c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Zanny <lordzanny@gmail.com>
+# Maintainer: Ivan Shapovalov <intelfx@intelfx.name>
+# Contributor: Zanny <lordzanny@gmail.com>
-pkgname=clinfo
-pkgver=2.0.15.03.24
+pkgname=clinfo-git
+pkgver=2.1.16.01.12.r2.g271b884
pkgrel=1
pkgdesc="Print all known information about all available OpenCL platforms and devices in the system"
arch=(i686 x86_64)
@@ -15,19 +16,19 @@ replaces=(clinfo)
source=(git+https://github.com/oblomov/clinfo.git)
md5sums=('SKIP')
-pkgver() {
- cd ${srcdir}/${pkgname}
- echo $(git describe --tags | cut -f1 -d"-")
+function pkgver() {
+ cd clinfo
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
}
build() {
- cd ${srcdir}/${pkgname}
- make
+ cd clinfo
+ make
}
package() {
- cd ${srcdir}/${pkgname}
- install -D -m755 clinfo "${pkgdir}/usr/bin/clinfo"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 man/clinfo.1 "${pkgdir}/usr/share/man/man1/clinfo.1"
-} \ No newline at end of file
+ cd clinfo
+ install -D -m755 clinfo "${pkgdir}/usr/bin/clinfo"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 man/clinfo.1 "${pkgdir}/usr/share/man/man1/clinfo.1"
+}