summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d366120ca761..9989cf22d42d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cling
pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
pkgver = 0.9
- pkgrel = 1
+ pkgrel = 2
url = https://root.cern.ch/cling
arch = i686
arch = x86_64
@@ -22,4 +22,3 @@ pkgbase = cling
sha256sums = SKIP
pkgname = cling
-
diff --git a/PKGBUILD b/PKGBUILD
index 9dfcc951c32f..6a5fc8825f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cling
pkgver=0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
arch=("i686" "x86_64")
url="https://root.cern.ch/cling"
@@ -74,6 +74,11 @@ package() {
install -Dm644 "$srcdir/llvm/tools/cling/LICENSE.TXT" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # include CMake target import file so that other packages are able to use
+ # `find_package(Cling REQUIRED)`
+ install -Dm644 "$srcdir/build/lib/cmake/cling/ClingTargets.cmake" \
+ "$pkgdir/opt/cling/lib/cmake/cling"
+
# omit man page for clang's scan-build
rm -f "$pkgdir/opt/cling/share/man/man1/scan-build.1"