summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--python38-fix.patch13
3 files changed, 7 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1531d151d9a..32b173487f71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clingo
pkgdesc = Grounding tools for (disjunctive) logic programs
- pkgver = 5.4.0
- pkgrel = 2
+ pkgver = 5.4.1
+ pkgrel = 1
url = https://potassco.org/
arch = i686
arch = x86_64
@@ -15,10 +15,8 @@ pkgbase = clingo
depends = lua
depends = python
conflicts = clasp
- source = git+https://github.com/potassco/clingo#tag=v5.4.0
- source = python38-fix.patch
+ source = git+https://github.com/potassco/clingo#tag=v5.4.1
sha256sums = SKIP
- sha256sums = 782d9fa710e59cba36bc3bfb922d52de0469cd3d0c5c591308f8e459139bd72f
pkgname = clingo
diff --git a/PKGBUILD b/PKGBUILD
index 00a3208d1687..c8e597b158aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
pkgname=clingo
-pkgver=5.4.0
-pkgrel=2
+pkgver=5.4.1
+pkgrel=1
pkgdesc='Grounding tools for (disjunctive) logic programs'
arch=('i686' 'x86_64' 'pentium4')
url='https://potassco.org/'
@@ -12,17 +12,11 @@ license=('MIT')
depends=('lua' 'python')
makedepends=('clang' 'cmake' 'git' 'ninja' 're2c')
conflicts=('clasp')
-source=("git+https://github.com/potassco/clingo#tag=v${pkgver}"
- "python38-fix.patch")
-sha256sums=('SKIP'
- '782d9fa710e59cba36bc3bfb922d52de0469cd3d0c5c591308f8e459139bd72f')
+source=("git+https://github.com/potassco/clingo#tag=v${pkgver}")
+sha256sums=('SKIP')
prepare() {
sed '/#include <xlocale.h>/d' -i "${srcdir}"/clingo/clasp/libpotassco/src/string_convert.cpp
-
- cd "${srcdir}/${pkgname}"
- # Upstream patch
- patch -Np1 -i "${srcdir}/python38-fix.patch"
}
build() {
diff --git a/python38-fix.patch b/python38-fix.patch
deleted file mode 100644
index 6593a5764766..000000000000
--- a/python38-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/libpyclingo/pyclingo.cc b/libpyclingo/pyclingo.cc
-index 9480203..6a7068c 100644
---- a/libpyclingo/pyclingo.cc
-+++ b/libpyclingo/pyclingo.cc
-@@ -1177,7 +1177,7 @@ PyTypeObject ObjectBase<T>::type = {
- sizeof(T), // tp_basicsize
- 0, // tp_itemsize
- PythonDetail::Get_tp_dealloc<T>::value, // tp_dealloc
-- nullptr, // tp_print
-+ 0, // tp_print
- nullptr, // tp_getattr
- nullptr, // tp_setattr
- nullptr, // tp_compare