summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--init.configure.patch18
3 files changed, 32 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b400259e01a..624c6658aeff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 5.1.1
-# Sun Aug 12 21:06:58 UTC 2018
+# Fri Sep 21 12:45:21 UTC 2018
pkgbase = cliqz
pkgdesc = Firefox-based privacy aware web browser, build from sources
- pkgver = 1.21.3
+ pkgver = 1.22.0
pkgrel = 1
url = https://cliqz.com/
arch = i686
@@ -41,8 +41,10 @@ pkgbase = cliqz
options = !emptydirs
options = !makeflags
options = !strip
- source = https://github.com/cliqz-oss/browser-f/archive/1.21.3.tar.gz
- sha256sums = d8f574f61e854c218f102c16764d64701d5a8c947a52f50ea85f7895455e5b54
+ source = https://github.com/cliqz-oss/browser-f/archive/1.22.0.tar.gz
+ source = init.configure.patch
+ sha256sums = bcb598df874ba5c3fd904ea4f33b05600037062eed33a12899af1f96bda1245f
+ sha256sums = 531ced6caeb57877e2b39d7aeb2eba3c03e15a1aaa5a27df3391e59b7d592549
pkgname = cliqz
diff --git a/PKGBUILD b/PKGBUILD
index 826b1a3bf5c4..79543f156c75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=cliqz
_pkgname=browser-f
-pkgver=1.21.3
+pkgver=1.22.0
pkgrel=1
_cqzbuildid=$(curl "http://repository.cliqz.com.s3.amazonaws.com/dist/release/$pkgver/lastbuildid")
pkgdesc="Firefox-based privacy aware web browser, build from sources"
@@ -13,8 +13,10 @@ depends=(gtk2 gtk3 libxt startup-notification dbus-glib nss libvpx libevent
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm libnotify gtk2 gtk3 wget pulseaudio)
conflicts=(cliqz-bin)
-source=("https://github.com/cliqz-oss/browser-f/archive/$pkgver.tar.gz")
-sha256sums=('d8f574f61e854c218f102c16764d64701d5a8c947a52f50ea85f7895455e5b54')
+source=("https://github.com/cliqz-oss/browser-f/archive/$pkgver.tar.gz"
+ init.configure.patch)
+sha256sums=('bcb598df874ba5c3fd904ea4f33b05600037062eed33a12899af1f96bda1245f'
+ '531ced6caeb57877e2b39d7aeb2eba3c03e15a1aaa5a27df3391e59b7d592549')
options=(!emptydirs !makeflags !strip)
prepare() {
@@ -27,6 +29,9 @@ prepare() {
sed -i "s/@MOZ_APP_NAME@/$pkgname/g" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
sed -i "s|^Exec=${pkgname}$|Exec=/usr/lib/${pkgname}/${pkgname} %u|" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
+ # rust.configure problem
+ patch build/moz.configure/init.configure ../../init.configure.patch
+
cat >> toolkit/mozapps/installer/linux/rpm/mozilla.desktop <<END
Actions=new-forget-window;
@@ -83,7 +88,6 @@ ac_add_options --with-system-nss
ac_add_options --with-system-libevent
ac_add_options --with-system-png
ac_add_options --enable-pulseaudio
-ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
diff --git a/init.configure.patch b/init.configure.patch
new file mode 100644
index 000000000000..0841038ef522
--- /dev/null
+++ b/init.configure.patch
@@ -0,0 +1,18 @@
+--- init.configure.upstream 2018-09-21 13:11:04.786186503 +0200
++++ init.configure 2018-09-21 13:13:35.415460493 +0200
+@@ -591,7 +591,14 @@
+ # There is also a quartet form:
+ # CPU_TYPE-MANUFACTURER-KERNEL-OPERATING_SYSTEM
+ # But we can consider the "KERNEL-OPERATING_SYSTEM" as one.
+- cpu, manufacturer, os = triplet.split('-', 2)
++ if triplet.count('-') == 1:
++ # Some new rust targets only have one dash and follows the form:
++ # CPU_TYPE-OPERATING_SYSTEM
++ # See: https://github.com/rust-lang/rust/pull/52763
++ manufacturer = None
++ cpu, os = triplet.split('-')
++ else:
++ cpu, manufacturer, os = triplet.split('-', 2)
+
+ # Autoconf uses config.sub to validate and canonicalize those triplets,
+ # but the granularity of its results has never been satisfying to our