summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1af8d4f304b5..c4a27fafc9e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clock-tui
pkgdesc = A clock, timer, and stopwatch for your terminal
pkgver = 0.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/race604/clock-tui
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 0eefe91b2e1c..bca2c0dc6b73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Wesley Moore <wes@wezm.net>
pkgname=clock-tui
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A clock, timer, and stopwatch for your terminal"
arch=("x86_64")
url="https://github.com/race604/clock-tui"
@@ -13,6 +13,7 @@ sha256sums=('1f592ca74e84d39bcd6f31a69f368422a68e4c9f2d786a193faaae49a389f392')
build() {
cd "$pkgname-$pkgver"
cargo build --release --locked
+ cargo run --release --locked --bin xtask
}
package() {
@@ -20,5 +21,11 @@ package() {
install -Dm755 "target/release/tclock" "$pkgdir/usr/bin/tclock"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm644 "assets/gen/_tclock" "$pkgdir/usr/share/zsh/site-functions/_tclock"
+ install -Dm644 "assets/gen/tclock.bash" "$pkgdir/usr/share/bash-completion/completions/tclock"
+ install -Dm644 "assets/gen/tclock.fish" "$pkgdir/usr/share/fish/vendor_completions.d/tclock.fish"
+
+ install -Dm644 "assets/gen/tclock.1" "$pkgdir/usr/share/man/man1/tclock.1"
}