summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rwxr-xr-xclonehero.sh3
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e43ab68229c6..ae47b3922d6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clonehero
pkgdesc = Clone of Guitar Hero and Rockband-style games
pkgver = 0.21.7
- pkgrel = 1
+ pkgrel = 2
url = https://clonehero.net/
install = clonehero.install
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = clonehero
source = clonehero.desktop
sha256sums = 4bc58ac7cb113d9d0df67a57b27522d0fdd8acdc34b5c86194c01601bf94c92e
sha256sums = 01125237ef90f8435523fed5ae09246a76eb562408c50e76597964b5675385cf
- sha256sums = 6ce5bd0b73e704b7221d8d03a77ffa66d887685ee7e57ccecf704a73caaae53a
+ sha256sums = a985b5761bcc287c627184ea8947b50adf4e208d77e4bb65d15d3d604566c403
sha256sums = a97d85930ac4844b3c5e90d4da8faa7a9b5267909d45be59b1fa39abc76df5fe
pkgname = clonehero
diff --git a/PKGBUILD b/PKGBUILD
index 21bd9047aed5..c45f39fe3979 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: 01189998819991197253 <dev.ben01189998819991197253+aur@gmail.com>
pkgname=clonehero
pkgver=0.21.7
-pkgrel=1
+pkgrel=2
pkgdesc="Clone of Guitar Hero and Rockband-style games"
arch=('x86_64')
url="https://clonehero.net/"
@@ -14,13 +14,14 @@ source=("SHA256SUM"
"$pkgname.install"
"$pkgname.sh"
"$pkgname.desktop")
+_mega_source_url="https://mega.nz/#!DE8ghYRL!loJZ0poH0QaIlhsuC4mWs7w14M9yP9t_3iTMTKeJchk"
sha256sums=('4bc58ac7cb113d9d0df67a57b27522d0fdd8acdc34b5c86194c01601bf94c92e'
'01125237ef90f8435523fed5ae09246a76eb562408c50e76597964b5675385cf'
- '6ce5bd0b73e704b7221d8d03a77ffa66d887685ee7e57ccecf704a73caaae53a'
+ 'a985b5761bcc287c627184ea8947b50adf4e208d77e4bb65d15d3d604566c403'
'a97d85930ac4844b3c5e90d4da8faa7a9b5267909d45be59b1fa39abc76df5fe')
prepare() {
- mega-get https://mega.nz/#!DE8ghYRL!loJZ0poH0QaIlhsuC4mWs7w14M9yP9t_3iTMTKeJchk
+ mega-get ${_mega_source_url}
sha256sum --check SHA256SUM
tar -xzvf $pkgname-linux.tar.gz
}
diff --git a/clonehero.sh b/clonehero.sh
index fa5cee4ce794..96f84b534138 100755
--- a/clonehero.sh
+++ b/clonehero.sh
@@ -41,7 +41,8 @@ fi
if [[ "/opt/$pkgname/clonehero_Data" -nt "$HOME/.$pkgname/clonehero_Data" ]]; then
echo "Replacing old data folder"
# This was the name of the data folder before v0.21.7
- rm "$HOME/.$pkgname/Clone Hero_Data"
+ rm -rf "$HOME/.$pkgname/Clone Hero_Data"
+ rm -rf "$HOME/.$pkgname/clonehero_Data"
cp -r "/opt/$pkgname/clonehero_Data" "$HOME/.$pkgname/clonehero_Data"
fi