summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20c9e1fd7b15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cloog-git
+ pkgdesc = Library that generates loops for scanning polyhedra
+ pkgver = 0.18.4
+ pkgrel = 2
+ url = http://www.bastoul.net/cloog/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = isl
+ provides = isl15
+ provides = cloog
+ source = cloog-0.18.4::git+http://repo.or.cz/cloog.git#branch=master
+ md5sums = SKIP
+
+pkgname = cloog-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30e82376efb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
+# Contributor: Allan McRae <allan@archlinux.org>
+
+pkgname=cloog-git
+pkgver=0.18.4
+pkgrel=2
+pkgdesc="Library that generates loops for scanning polyhedra"
+arch=('i686' 'x86_64')
+url="http://www.bastoul.net/cloog/"
+license=('GPL')
+depends=('isl')
+source=('cloog-0.18.4::git+http://repo.or.cz/cloog.git#branch=master')
+provides=('isl15' 'cloog')
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ git submodule init
+ git submodule update --recursive
+ sh autogen.sh
+ ./configure --prefix=/usr --with-isl --with-osl
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # There are certain race conditions on running the tests, so we restrict
+ # it to one job (one CPU core).
+ make -j1 check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR=$pkgdir/ install
+}