summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--vtk_jsoncpp.patch98
3 files changed, 107 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a4aecdb2ebb..38ca7b4b947a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cloudcompare-git
pkgdesc = A 3D point cloud (and triangular mesh) processing software
- pkgver = 2.12.1.r92.g597daac8
+ pkgver = 2.13.r3.g36cc2b5c9
pkgrel = 1
url = http://www.danielgm.net/cc/
arch = i686
@@ -47,6 +47,7 @@ pkgbase = cloudcompare-git
source = cloudcompare-cork::git+https://github.com/CloudCompare/cork.git
source = CloudCompare.desktop
source = ccViewer.desktop
+ source = vtk_jsoncpp.patch
source = nanoflann::git+https://github.com/jlblancoc/nanoflann
source = libE57Format::git+https://github.com/asmaloney/libE57Format
source = CCCoreLib::git+https://github.com/CloudCompare/CCCoreLib
@@ -63,6 +64,7 @@ pkgbase = cloudcompare-git
sha256sums = SKIP
sha256sums = 14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe
sha256sums = 821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc
+ sha256sums = ce48e2816ebb5d388283396b12cdb94272b3fd3eb1655845eacbf226ad918969
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 982047907494..a2bfbf1dc720 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ name=cloudcompare
#_fragment="#branch="
options=('!strip') # strip would also remove plugins, for some reason
pkgname=${name}-git
-pkgver=2.12.1.r92.g597daac8
+pkgver=2.13.r3.g36cc2b5c9
pkgrel=1
pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
@@ -31,11 +31,13 @@ source=("${name}::git+https://github.com/CloudCompare/CloudCompare.git${_fragmen
"${name}-cork::git+https://github.com/CloudCompare/cork.git"
CloudCompare.desktop
ccViewer.desktop
+ vtk_jsoncpp.patch
)
sha256sums=('SKIP'
'SKIP'
'14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe'
'821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc'
+ 'ce48e2816ebb5d388283396b12cdb94272b3fd3eb1655845eacbf226ad918969'
'SKIP'
'SKIP'
'SKIP'
@@ -55,6 +57,7 @@ pkgver() {
prepare() {
prepare_submodule
+ git -C "${srcdir}"/cloudcompare apply -v "${srcdir}"/vtk_jsoncpp.patch
# sed "/CXX_STANDARD/s/14/17/" -i "${srcdir}/${name}"/cmake/CMakeSetCompilerOptions.cmake
}
@@ -122,6 +125,8 @@ build() {
-DPLUGIN_STANDARD_QJSONRPC=ON
-DPLUGIN_STANDARD_QMPLANE=ON
-DEIGEN_ROOT_DIR=/usr/include/eigen3
+ -DJsonCpp_INCLUDE_DIR=/usr/include
+ -DJsonCpp_LIBRARY=/usr/lib
)
diff --git a/vtk_jsoncpp.patch b/vtk_jsoncpp.patch
new file mode 100644
index 000000000000..39e01ea020c1
--- /dev/null
+++ b/vtk_jsoncpp.patch
@@ -0,0 +1,98 @@
+Submodule plugins/core/Standard/qMasonry contains modified content
+diff --git a/plugins/core/Standard/qMasonry/qAutoSeg/CMakeLists.txt b/plugins/core/Standard/qMasonry/qAutoSeg/CMakeLists.txt
+index 9865f33..b6b0d42 100644
+--- a/plugins/core/Standard/qMasonry/qAutoSeg/CMakeLists.txt
++++ b/plugins/core/Standard/qMasonry/qAutoSeg/CMakeLists.txt
+@@ -6,7 +6,7 @@ option( PLUGIN_STANDARD_MASONRY_QAUTO_SEG "Check to install QAutoSeg plugin" OFF
+ if ( PLUGIN_STANDARD_MASONRY_QAUTO_SEG )
+
+ project( QAUTO_SEG_PLUGIN )
+-
++
+ AddPlugin( NAME ${PROJECT_NAME} )
+
+ target_sources( ${PROJECT_NAME}
+@@ -26,12 +26,14 @@ if ( PLUGIN_STANDARD_MASONRY_QAUTO_SEG )
+ # Find Packages
+ # Find PCL
+ #set( PCL_DIR "C:/Program Files/PCL 1.9.1") #DGM: can't do that as it will obviously conflict with most of the users settings ;)
++ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} /usr/lib/cmake/vtk )
++ find_package( JsonCpp REQUIRED )
+ find_package( PCL 1.9.1 REQUIRED )
+
+ # Find OpenCV
+ #set( OpenCV_DIR "C:/opencv/build" ) #DGM: can't do that as it will obviously conflict with most of the users settings ;)
+ find_package( OpenCV REQUIRED )
+-
++
+ if (WIN32)
+ # We need to copy the OpenCV "World" DLL file next to CloudCompare.exe
+ set( OpenCV_WORLD_DLL "" CACHE FILEPATH "Opencv 'World' DLL file path" )
+@@ -48,7 +50,7 @@ if ( PLUGIN_STANDARD_MASONRY_QAUTO_SEG )
+ # [C/C++]>[Preprocessor]>[Preprocessor Definitions]
+ add_definitions( ${PCL_DEFINITIONS} )
+
+- # For Use Not PreCompiled Features
++ # For Use Not PreCompiled Features
+ #add_definitions( -DPCL_NO_PRECOMPILE )
+
+ # [Linker]>[General]>[Additional Library Directories]
+@@ -67,7 +69,7 @@ if ( PLUGIN_STANDARD_MASONRY_QAUTO_SEG )
+ copy_files("${OpenCV_WORLD_DEBUG_DLL}" ${CLOUDCOMPARE_DEST_FOLDER} 2)
+ endif()
+ endif()
+-
++
+ endif()
+-
++
+ endif()
+diff --git a/plugins/core/Standard/qMasonry/qManualSeg/CMakeLists.txt b/plugins/core/Standard/qMasonry/qManualSeg/CMakeLists.txt
+index 1c13d67..79ff351 100644
+--- a/plugins/core/Standard/qMasonry/qManualSeg/CMakeLists.txt
++++ b/plugins/core/Standard/qMasonry/qManualSeg/CMakeLists.txt
+@@ -6,7 +6,7 @@ option( PLUGIN_STANDARD_MASONRY_QMANUAL_SEG "Check to install qManualSeg plugin"
+ if ( PLUGIN_STANDARD_MASONRY_QMANUAL_SEG )
+
+ project( QMANUAL_SEG_PLUGIN )
+-
++
+ AddPlugin( NAME ${PROJECT_NAME} )
+
+
+@@ -20,10 +20,12 @@ if ( PLUGIN_STANDARD_MASONRY_QMANUAL_SEG )
+ PRIVATE
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+-
++
+ # Find Packages
+ # Find PCL
+ #set( PCL_DIR "C:/Program Files/PCL 1.9.1") #DGM: can't do that as it will obviously conflict with most of the users settings ;)
++ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} /usr/lib/cmake/vtk )
++ find_package( JsonCpp REQUIRED )
+ find_package( PCL 1.9.1 REQUIRED )
+
+ # Find OpenCV
+@@ -46,7 +48,7 @@ if ( PLUGIN_STANDARD_MASONRY_QMANUAL_SEG )
+ # [C/C++]>[Preprocessor]>[Preprocessor Definitions]
+ add_definitions( ${PCL_DEFINITIONS} )
+
+- # For Use Not PreCompiled Features
++ # For Use Not PreCompiled Features
+ #add_definitions( -DPCL_NO_PRECOMPILE )
+
+ # [Linker]>[General]>[Additional Library Directories]
+diff --git a/plugins/core/Standard/qPCL/PclUtils/CMakeLists.txt b/plugins/core/Standard/qPCL/PclUtils/CMakeLists.txt
+index a78dd7129..5b5c1e2af 100644
+--- a/plugins/core/Standard/qPCL/PclUtils/CMakeLists.txt
++++ b/plugins/core/Standard/qPCL/PclUtils/CMakeLists.txt
+@@ -2,6 +2,8 @@ project( QPCL_PLUGIN_UTILS_LIB )
+
+ find_package( Qt5 COMPONENTS Widgets REQUIRED )
+
++set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} /usr/lib/cmake/vtk )
++find_package( JsonCpp REQUIRED )
+ find_package( PCL 1.9 REQUIRED )
+
+ add_library( ${PROJECT_NAME} STATIC )