summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD126
-rw-r--r--cork.patch79
-rw-r--r--vtk_jsoncpp.patch98
4 files changed, 238 insertions, 117 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2049beb9c73..38ca7b4b947a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cloudcompare-git
pkgdesc = A 3D point cloud (and triangular mesh) processing software
- pkgver = 2.10.2.r857.ga33ffe93
+ pkgver = 2.13.r3.g36cc2b5c9
pkgrel = 1
url = http://www.danielgm.net/cc/
arch = i686
@@ -13,37 +13,69 @@ pkgbase = cloudcompare-git
makedepends = laz-perf
makedepends = libharu
makedepends = ninja
- makedepends = pcl
makedepends = proj
makedepends = python
depends = cgal
- depends = dlib
depends = fbx-sdk
- depends = ffmpeg
+ depends = ffmpeg4.4
depends = glew
depends = glu
depends = mesa
depends = mpir
+ depends = pcl
depends = pdal
+ depends = laszip
depends = qt5-base
depends = qt5-tools
depends = qt5-svg
+ depends = qt5-websockets
depends = shapelib
depends = tbb
- depends = vxl
- optdepends = pcl
+ depends = opencascade
+ depends = opencv
+ depends = gdal
+ depends = openmpi
+ depends = nlohmann-json
+ depends = fmt
+ depends = jsoncpp
+ depends = utf8cpp
+ depends = fast_float
provides = cloudcompare
conflicts = cloudcompare
- source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git
+ options = !strip
+ source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git#branch=master
source = cloudcompare-cork::git+https://github.com/CloudCompare/cork.git
- source = cork.patch
source = CloudCompare.desktop
source = ccViewer.desktop
+ source = vtk_jsoncpp.patch
+ source = nanoflann::git+https://github.com/jlblancoc/nanoflann
+ source = libE57Format::git+https://github.com/asmaloney/libE57Format
+ source = CCCoreLib::git+https://github.com/CloudCompare/CCCoreLib
+ source = PoissonRecon::git+https://github.com/cloudcompare/PoissonRecon
+ source = mplane-plugin::git+https://github.com/hvs-ait/mplane-plugin
+ source = ptrans::git+https://gitlab.univ-nantes.fr/E164955Z/ptrans
+ source = masonry-cc::git+https://github.com/CyberbuildLab/masonry-cc
+ source = JSonRPCPlugin::git+https://gitlab.com/theadib/JSonRPCPlugin
+ source = dlib::git+https://github.com/davisking/dlib
+ source = cc-treeiso-plugin::git+https://github.com/truebelief/cc-treeiso-plugin
+ source = q3DMASC::git+https://github.com/dgirardeau/q3DMASC
+ source = googletest::git+https://github.com/google/googletest
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 3f8692fbff2b92ebf422f2c4de46f2f9164cd37879092c66f171b32fea464227
sha256sums = 14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe
sha256sums = 821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc
+ sha256sums = ce48e2816ebb5d388283396b12cdb94272b3fd3eb1655845eacbf226ad918969
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = cloudcompare-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a5076dcd7201..a2bfbf1dc720 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,59 +4,80 @@
# Contributor : Danilo Bargen <aur at dbrgn dot ch>
# shellcheck disable=SC2034,SC2154 # allow unused/uninitialized variables.
+## Configuration env vars:
+_fragment=#${FRAGMENT:-branch=master}
+# Use CMAKE_FLAGS=xxx:yyy:zzz to define extra CMake flags
+[[ -v CMAKE_FLAGS ]] && mapfile -t -d: CMAKE_FLAGS < <(echo -n "$CMAKE_FLAGS")
+
name=cloudcompare
#_fragment="#branch="
+options=('!strip') # strip would also remove plugins, for some reason
pkgname=${name}-git
-pkgver=2.10.2.r857.ga33ffe93
+pkgver=2.13.r3.g36cc2b5c9
pkgrel=1
pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
url="http://www.danielgm.net/cc/"
license=('GPL2')
-depends=('cgal' 'dlib' 'fbx-sdk' 'ffmpeg' 'glew' 'glu' 'mesa' 'mpir' 'pdal' 'qt5-base' 'qt5-tools' 'qt5-svg' 'shapelib' 'tbb' 'vxl')
-makedepends=('clang' 'cmake' 'doxygen' 'git' 'laz-perf' 'libharu' 'ninja' 'pcl' 'proj' 'python')
-optdepends=('pcl')
+depends=('cgal' 'fbx-sdk' 'ffmpeg4.4' 'glew' 'glu' 'mesa' 'mpir' 'pcl' 'pdal' 'laszip' 'qt5-base' 'qt5-tools' 'qt5-svg' 'qt5-websockets' 'shapelib' 'tbb' 'opencascade' 'opencv' 'gdal')
+#fix pcl:>vtk:>vtkm:>openmp missing deps
+depends+=(openmpi)
+depends+=(nlohmann-json fmt jsoncpp)
+depends+=(utf8cpp fast_float)
+makedepends=('clang' 'cmake' 'doxygen' 'git' 'laz-perf' 'libharu' 'ninja' 'proj' 'python')
conflicts=('cloudcompare')
provides=('cloudcompare')
source=("${name}::git+https://github.com/CloudCompare/CloudCompare.git${_fragment}"
"${name}-cork::git+https://github.com/CloudCompare/cork.git"
- cork.patch
CloudCompare.desktop
ccViewer.desktop
+ vtk_jsoncpp.patch
)
sha256sums=('SKIP'
'SKIP'
- '3f8692fbff2b92ebf422f2c4de46f2f9164cd37879092c66f171b32fea464227'
'14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe'
- '821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc')
-
-prepare() {
- git -C "${srcdir}/${name}" submodule update --init --recursive
- git -C "${srcdir}/${name}-cork" apply -v "${srcdir}"/cork.patch
-}
+ '821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc'
+ 'ce48e2816ebb5d388283396b12cdb94272b3fd3eb1655845eacbf226ad918969'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
git -C "${srcdir}/${name}" describe --long --tag | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ prepare_submodule
+ git -C "${srcdir}"/cloudcompare apply -v "${srcdir}"/vtk_jsoncpp.patch
+# sed "/CXX_STANDARD/s/14/17/" -i "${srcdir}/${name}"/cmake/CMakeSetCompilerOptions.cmake
+}
+
build() {
+ export CCACHE_BASEDIR="$srcdir"
# shellcheck disable=SC2191
- CMAKE_FLAGS=(
+ CMAKE_FLAGS+=(
-Wno-dev
+ -DPCL_QHULL_REQUIRED_TYPE=SHARED
-DCMAKE_CXX_STANDARD=14
- -DCMAKE_CXX_FLAGS=-fpermissive
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -fpermissive -DSUPPORT_TOPO_STREAM_OPERATORS -Wno-deprecated-declarations"
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_LIBDIR=lib
-DCMAKE_BUILD_TYPE=Release
- -DCOMPILE_CC_CORE_LIB_WITH_CGAL=ON
- -DCOMPILE_CC_CORE_LIB_WITH_TBB=ON
- -DWITH_FFMPEG_SUPPORT:BOOL=ON
- -DFFMPEG_INCLUDE_DIR:PATH=/usr/include
- -DFFMPEG_LIBRARY_DIR:PATH=/usr/lib
+ -DCCCORELIB_USE_CGAL=ON
+ -DCCCORELIB_USE_TBB=ON
-DPOISSON_RECON_WITH_OPEN_MP:BOOL=ON
- -DPLUGIN_EXAMPLE_GL:BOOL=ON
- -DPLUGIN_EXAMPLE_IO:BOOL=ON
- -DPLUGIN_EXAMPLE_STANDARD:BOOL=ON
+ -DPLUGIN_EXAMPLE_GL:BOOL=OFF # no need to bundle examples
+ -DPLUGIN_EXAMPLE_IO:BOOL=OFF
+ -DPLUGIN_EXAMPLE_STANDARD:BOOL=OFF
-DPLUGIN_GL_QEDL:BOOL=ON
-DPLUGIN_GL_QSSAO:BOOL=ON
-DPLUGIN_IO_QADDITIONAL:BOOL=ON
@@ -66,22 +87,25 @@ build() {
-DPLUGIN_IO_QFBX:BOOL=ON # requires update of AUR/fbx-sdk (https://www.autodesk.com/content/dam/autodesk/www/adn/fbx/2020-1-1/fbx202011_fbxsdk_linux.tar.gz)
-DFBX_SDK_INCLUDE_DIR:PATH=/usr/include
-DFBX_SDK_LIBRARY_FILE:FILEPATH=/usr/lib/libfbxsdk.so
- -DPLUGIN_IO_QPDAL:BOOL=ON
+ -DPLUGIN_IO_QLAS:BOOL=ON
-DPLUGIN_IO_QPHOTOSCAN:BOOL=ON
-DPLUGIN_IO_QRDB:BOOL=OFF # requires rdblib (package for AUR from http://www.riegl.com/products/software-packages/rdblib/)
- -DPLUGIN_STANDARD_QANIMATION:BOOL=ON
- -DPLUGIN_STANDARD_QBROOM:BOOL=ON
- -DPLUGIN_STANDARD_QCANUPO:BOOL=ON # requires dlib
- -DDLIB_ROOT:PATH="/usr" # required by qcanupo plugin
+ -DPLUGIN_IO_QSTEP=ON # requires opencascade
+ -DOPENCASCADE_INC_DIR="/usr/include/opencascade"
+ -DOPENCASCADE_LIB_DIR="/usr/lib"
+ -DPLUGIN_STANDARD_QCANUPO:BOOL=ON
-DPLUGIN_STANDARD_QCOMPASS:BOOL=ON
-DPLUGIN_STANDARD_QCORK:BOOL=ON # require mpir, cork (cork-git is not enough)
-DMPIR_INCLUDE_DIR:PATH=/usr/include # required by qcork plugin
-DCORK_INCLUDE_DIR:PATH="${srcdir}/${name}-cork/src" # required by qcork plugin
+ -DFFMPEG_INCLUDE_DIR:PATH=/usr/include/ffmpeg4.4 # required by qAnimation plugin
+ -DFFMPEG_LIBRARY_DIR:PATH=/usr/lib/ffmpeg4.4 # required by qAnimation plugin
-DCORK_RELEASE_LIBRARY_FILE:FILEPATH="${srcdir}/${name}-cork/lib/libcork.a" # required by qcork plugin
-DMPIR_RELEASE_LIBRARY_FILE:FILEPATH=/usr/lib/libmpir.so # require by qcork plugin
-DPLUGIN_STANDARD_QCSF:BOOL=ON
-DPLUGIN_STANDARD_QFACETS:BOOL=ON # requires shapelib
-DOPTION_USE_SHAPE_LIB:BOOL=ON
+ -DOPTION_USE_GDAL=ON
-DPLUGIN_STANDARD_QHOUGH_NORMALS:BOOL=ON
-DPLUGIN_STANDARD_QHPR:BOOL=ON
-DPLUGIN_STANDARD_QM3C2:BOOL=ON
@@ -91,10 +115,23 @@ build() {
-DPLUGIN_STANDARD_QRANSAC_SD:BOOL=ON
-DPLUGIN_STANDARD_QSRA:BOOL=ON
-DOPTION_USE_DXF_LIB:BOOL=ON # required by qsra plugin
+ -DPLUGIN_STANDARD_MASONRY_QAUTO_SEG=ON
+ -DPLUGIN_STANDARD_MASONRY_QMANUAL_SEG=ON
+ -DPLUGIN_STANDARD_QANIMATION=ON
+ -DQANIMATION_WITH_FFMPEG_SUPPORT=ON
+ -DPLUGIN_STANDARD_QBROOM=ON
+ -DPLUGIN_STANDARD_QCANUPO=ON
+ -DPLUGIN_STANDARD_QCOLORIMETRIC_SEGMENTER=ON
+ -DPLUGIN_STANDARD_QJSONRPC=ON
+ -DPLUGIN_STANDARD_QMPLANE=ON
-DEIGEN_ROOT_DIR=/usr/include/eigen3
+ -DJsonCpp_INCLUDE_DIR=/usr/include
+ -DJsonCpp_LIBRARY=/usr/lib
+
+
)
msg2 "Build Cork lib"
- make -C "${srcdir}/${name}-cork"
+ make -C "${srcdir}/${name}-cork" CXXFLAGS="$CXXFLAGS -DSUPPORT_TOPO_STREAM_OPERATORS"
msg2 "Build CloudCompare"
cmake -B build -S "${srcdir}/${name}" -G Ninja "${CMAKE_FLAGS[@]}"
# shellcheck disable=SC2086 # allow slitting for MAKEFLAGS carrying multiple flags.
@@ -116,3 +153,36 @@ package() {
install -D -m 644 ${name}/qCC/images/icon/cc_viewer_icon.svg "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/cc_viewer_icon.svg
}
# vim:set sw=2 ts=2 et:
+
+# Generated with git_submodule_PKGBUILD_conf.sh ( https://gist.github.com/bartoszek/41a3bfb707f1b258de061f75b109042b )
+# Call prepare_submodule in prepare() function
+
+prepare_submodule() {
+ git -C "$srcdir/CCCoreLib" config submodule.extern/nanoflann.url "$srcdir/nanoflann"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/IO/qE57IO/extern/libE57Format.url "$srcdir/libE57Format"
+ git -C "$srcdir/cloudcompare" config submodule.extern/CCCoreLib.url "$srcdir/CCCoreLib"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/Standard/qPoissonRecon/extern/PoissonRecon.url "$srcdir/PoissonRecon"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/Standard/qMPlane.url "$srcdir/mplane-plugin"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/Standard/qColorimetricSegmenter.url "$srcdir/ptrans"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/Standard/qMasonry.url "$srcdir/masonry-cc"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/Standard/qJSonRPCPlugin.url "$srcdir/JSonRPCPlugin"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/Standard/qCanupo/contrib/dlib.url "$srcdir/dlib"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/Standard/cc-treeiso-plugin.url "$srcdir/cc-treeiso-plugin"
+ git -C "$srcdir/cloudcompare" config submodule.plugins/core/Standard/q3DMASC.url "$srcdir/q3DMASC"
+ git -C "$srcdir/libE57Format" config submodule.test/extern/googletest.url "$srcdir/googletest"
+ git -C "$srcdir/cloudcompare" -c protocol.file.allow=always submodule update --init --recursive
+}
+source+=(
+ "nanoflann::git+https://github.com/jlblancoc/nanoflann"
+ "libE57Format::git+https://github.com/asmaloney/libE57Format"
+ "CCCoreLib::git+https://github.com/CloudCompare/CCCoreLib"
+ "PoissonRecon::git+https://github.com/cloudcompare/PoissonRecon"
+ "mplane-plugin::git+https://github.com/hvs-ait/mplane-plugin"
+ "ptrans::git+https://gitlab.univ-nantes.fr/E164955Z/ptrans"
+ "masonry-cc::git+https://github.com/CyberbuildLab/masonry-cc"
+ "JSonRPCPlugin::git+https://gitlab.com/theadib/JSonRPCPlugin"
+ "dlib::git+https://github.com/davisking/dlib"
+ "cc-treeiso-plugin::git+https://github.com/truebelief/cc-treeiso-plugin"
+ "q3DMASC::git+https://github.com/dgirardeau/q3DMASC"
+ "googletest::git+https://github.com/google/googletest"
+)
diff --git a/cork.patch b/cork.patch
deleted file mode 100644
index 370b0260eb10..000000000000
--- a/cork.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-diff --git a/Makefile b/Makefile
-index a9fbb62..8ca986c 100644
---- a/Makefile
-+++ b/Makefile
-@@ -62,7 +62,7 @@ INC := $(INC) $(GMPINC)
- # use the second line to disable profiling instrumentation
- # PROFILING := -pg
- PROFILING :=
--CCFLAGS := -Wall $(INC) $(CONFIG) -O2 -DNDEBUG $(PROFILING)
-+CCFLAGS := -fPIC -Wall $(INC) $(CONFIG) -O2 -DNDEBUG $(PROFILING)
- CXXFLAGS := $(CCFLAGS) $(CPP11_FLAGS)
- CCDFLAGS := -Wall $(INC) $(CONFIG) -ggdb
- CXXDFLAGS := $(CCDFLAGS)
-@@ -193,7 +193,7 @@ bin/off2obj: obj/off2obj.o
-
- obj/isct/triangle.o: src/isct/triangle.c
- @echo "Compiling the Triangle library"
-- @$(CC) -O2 -DNO_TIMER \
-+ @$(CC) $(CCFLAGS) -O2 -DNO_TIMER \
- -DREDUCED \
- -DCDT_ONLY -DTRILIBRARY \
- -Wall -DANSI_DECLARATORS \
-diff --git a/src/mesh/mesh.isct.tpp b/src/mesh/mesh.isct.tpp
-index a0acc15..69d33a8 100644
---- a/src/mesh/mesh.isct.tpp
-+++ b/src/mesh/mesh.isct.tpp
-@@ -650,14 +650,14 @@ public:
- // DGM: to replace lambda in IsctProblem constructor!
- void quantizeVerts(const Quantization& quantizer)
- {
-- if (!mesh)
-+ if (!TopoCache::mesh)
- return;
-
-- size_t N = mesh->verts.size();
-+ size_t N = TopoCache::mesh->verts.size();
- quantized_coords.resize(N);
-
- uint write = 0;
-- for (Vptr v = verts.getFirst(); v != NULL; v = verts.getNext(v))
-+ for (Vptr v = TopoCache::verts.getFirst(); v != NULL; v = TopoCache::verts.getNext(v))
- {
- #ifdef _WIN32
- Vec3d raw = mesh->verts[v->ref].pos;
-@@ -1106,7 +1106,7 @@ void Mesh<VertData,TriData>::IsctProblem::findIntersections()
- if(nTrys <= 0) {
- CORK_ERROR("Ran out of tries to perturb the mesh");
- //std::logic_error
-- throw std::exception("Ran out of tries to perturb the mesh");
-+ throw std::runtime_error("Ran out of tries to perturb the mesh");
- //exit(1);
- }
-
-diff --git a/src/mesh/mesh.topoCache.tpp b/src/mesh/mesh.topoCache.tpp
-index cf225d6..b648d5f 100644
---- a/src/mesh/mesh.topoCache.tpp
-+++ b/src/mesh/mesh.topoCache.tpp
-@@ -504,7 +504,7 @@ void Mesh<VertData, TriData>::TopoCache::print()
- cout << "TRIS" << endl;
- int tri_count = 0;
- tris.for_each([&](Tptr t) {
-- cout << " " << t << ": " << *t << endl;
-+ cout << " " << t << ": " << endl;
- tri_count++;
- });
- cout << "There were " << tri_count << " TRIS" << endl;
-diff --git a/src/util/prelude.h b/src/util/prelude.h
-index 6836ace..6981d20 100644
---- a/src/util/prelude.h
-+++ b/src/util/prelude.h
-@@ -60,7 +60,7 @@ std::ostream &err();
- err() << "ENSURE FAILED at " \
- << __FILE__ << ", line #" << __LINE__ << ":\n" \
- << " " << #STATEMENT << std::endl; \
-- throw std::exception("ENSURE FAILED"); \
-+ throw std::runtime_error("ENSURE FAILED"); \
- } \
- }
- #endif // ENSURE
diff --git a/vtk_jsoncpp.patch b/vtk_jsoncpp.patch
new file mode 100644
index 000000000000..39e01ea020c1
--- /dev/null
+++ b/vtk_jsoncpp.patch
@@ -0,0 +1,98 @@
+Submodule plugins/core/Standard/qMasonry contains modified content
+diff --git a/plugins/core/Standard/qMasonry/qAutoSeg/CMakeLists.txt b/plugins/core/Standard/qMasonry/qAutoSeg/CMakeLists.txt
+index 9865f33..b6b0d42 100644
+--- a/plugins/core/Standard/qMasonry/qAutoSeg/CMakeLists.txt
++++ b/plugins/core/Standard/qMasonry/qAutoSeg/CMakeLists.txt
+@@ -6,7 +6,7 @@ option( PLUGIN_STANDARD_MASONRY_QAUTO_SEG "Check to install QAutoSeg plugin" OFF
+ if ( PLUGIN_STANDARD_MASONRY_QAUTO_SEG )
+
+ project( QAUTO_SEG_PLUGIN )
+-
++
+ AddPlugin( NAME ${PROJECT_NAME} )
+
+ target_sources( ${PROJECT_NAME}
+@@ -26,12 +26,14 @@ if ( PLUGIN_STANDARD_MASONRY_QAUTO_SEG )
+ # Find Packages
+ # Find PCL
+ #set( PCL_DIR "C:/Program Files/PCL 1.9.1") #DGM: can't do that as it will obviously conflict with most of the users settings ;)
++ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} /usr/lib/cmake/vtk )
++ find_package( JsonCpp REQUIRED )
+ find_package( PCL 1.9.1 REQUIRED )
+
+ # Find OpenCV
+ #set( OpenCV_DIR "C:/opencv/build" ) #DGM: can't do that as it will obviously conflict with most of the users settings ;)
+ find_package( OpenCV REQUIRED )
+-
++
+ if (WIN32)
+ # We need to copy the OpenCV "World" DLL file next to CloudCompare.exe
+ set( OpenCV_WORLD_DLL "" CACHE FILEPATH "Opencv 'World' DLL file path" )
+@@ -48,7 +50,7 @@ if ( PLUGIN_STANDARD_MASONRY_QAUTO_SEG )
+ # [C/C++]>[Preprocessor]>[Preprocessor Definitions]
+ add_definitions( ${PCL_DEFINITIONS} )
+
+- # For Use Not PreCompiled Features
++ # For Use Not PreCompiled Features
+ #add_definitions( -DPCL_NO_PRECOMPILE )
+
+ # [Linker]>[General]>[Additional Library Directories]
+@@ -67,7 +69,7 @@ if ( PLUGIN_STANDARD_MASONRY_QAUTO_SEG )
+ copy_files("${OpenCV_WORLD_DEBUG_DLL}" ${CLOUDCOMPARE_DEST_FOLDER} 2)
+ endif()
+ endif()
+-
++
+ endif()
+-
++
+ endif()
+diff --git a/plugins/core/Standard/qMasonry/qManualSeg/CMakeLists.txt b/plugins/core/Standard/qMasonry/qManualSeg/CMakeLists.txt
+index 1c13d67..79ff351 100644
+--- a/plugins/core/Standard/qMasonry/qManualSeg/CMakeLists.txt
++++ b/plugins/core/Standard/qMasonry/qManualSeg/CMakeLists.txt
+@@ -6,7 +6,7 @@ option( PLUGIN_STANDARD_MASONRY_QMANUAL_SEG "Check to install qManualSeg plugin"
+ if ( PLUGIN_STANDARD_MASONRY_QMANUAL_SEG )
+
+ project( QMANUAL_SEG_PLUGIN )
+-
++
+ AddPlugin( NAME ${PROJECT_NAME} )
+
+
+@@ -20,10 +20,12 @@ if ( PLUGIN_STANDARD_MASONRY_QMANUAL_SEG )
+ PRIVATE
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+-
++
+ # Find Packages
+ # Find PCL
+ #set( PCL_DIR "C:/Program Files/PCL 1.9.1") #DGM: can't do that as it will obviously conflict with most of the users settings ;)
++ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} /usr/lib/cmake/vtk )
++ find_package( JsonCpp REQUIRED )
+ find_package( PCL 1.9.1 REQUIRED )
+
+ # Find OpenCV
+@@ -46,7 +48,7 @@ if ( PLUGIN_STANDARD_MASONRY_QMANUAL_SEG )
+ # [C/C++]>[Preprocessor]>[Preprocessor Definitions]
+ add_definitions( ${PCL_DEFINITIONS} )
+
+- # For Use Not PreCompiled Features
++ # For Use Not PreCompiled Features
+ #add_definitions( -DPCL_NO_PRECOMPILE )
+
+ # [Linker]>[General]>[Additional Library Directories]
+diff --git a/plugins/core/Standard/qPCL/PclUtils/CMakeLists.txt b/plugins/core/Standard/qPCL/PclUtils/CMakeLists.txt
+index a78dd7129..5b5c1e2af 100644
+--- a/plugins/core/Standard/qPCL/PclUtils/CMakeLists.txt
++++ b/plugins/core/Standard/qPCL/PclUtils/CMakeLists.txt
+@@ -2,6 +2,8 @@ project( QPCL_PLUGIN_UTILS_LIB )
+
+ find_package( Qt5 COMPONENTS Widgets REQUIRED )
+
++set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} /usr/lib/cmake/vtk )
++find_package( JsonCpp REQUIRED )
+ find_package( PCL 1.9 REQUIRED )
+
+ add_library( ${PROJECT_NAME} STATIC )